Posts by BeastOfBodmin

    I am trawling through that massive thread at the moment.


    Meanwhile I found this, which might mean I have to connect my external DAC in order for squeezelite to start.


    So I connected the DAC and this is what I got


    The only mention of squeezelite that I can find is in the LE repo: Program Add-ons > Multimedia Tools. What you do with that .. I have no idea.

    Even with my newly flashed LibreELEC Pi3+, in KODI / Add-ons / Program add-ons I saw only


    LibreELEC Configuration

    LibreELEC Module Drivers


    So I went to


    KODI / Add-ons / Download / Install from repository / LibreELEC Add-ons / Program add-ons


    and chose to install


    Multimedia Tools


    which currently includes alsamixer, mediainfo, mesa-deoms, mpg123, opencaster, squeezelite, tsdecrypt and tstools.


    The installation failed a few times in a strange way (The button "Install" had a trash can icon under it). I removed it and then it installed.


    Now Multimedia (9.2.0.109) tools was installed, but I still could not find squeezelite in kodi. As it happens, changes for this version are


    - Update squeezelite to b2ed99e and support all possible media formats


    Via an ssh session I found this:


    KodiPi:~ # find /storage/ | grep squee

    /storage/.kodi/addons/virtual.multimedia-tools/bin/squeezelite

    KodiPi:~ # ls -l /storage/.kodi/addons/virtual.multimedia-tools/bin/squeezelite

    -rwxr-xr-x 1 root root 848320 Feb 27 17:19 /storage/.kodi/addons/virtual.multimedia-tools/bin/squeezelite


    So I rebooted. And still I can't find squeezelite. I tried this:


    KodiPi:~ # /storage/.kodi/addons/virtual.multimedia-tools/bin/squeezelite

    [17:56:29.238166] test_open:281 playback open error: No such file or directory

    [17:56:29.238601] output_init_common:384 unable to open output device: default


    What am I doing wrong?


    Latest log is at http://ix.io/2R6b

    For those who happened to be here looking for a solution to install from OSX (Catalina in my case), here is a guide that worked: Installation [LibreELEC.wiki]

    That guide does not work for macos Catalina 10.15.7 (19H524)


    It is not possible to launch the app.


    I tried to run it on the command line, with and without sudo. It seems to want to run setgid at some point, which macos does not like. Shades of Windows 8.


    This


    $ /Applications/LibreELEC\ USB-SD\ Creator.app/Contents/MacOS/applet


    causes a pop-up to ask for an admin user's password


    Then there appears a pop-up window from the LibreElec app containing (and an Edit button):


    Code
    PasteBoard: Error creating pasteboard: com.apple.pasteboard.clipboard [-4960]
    PasteBoard: Error creating pasteboard: com.apple.pasteboard.find [-4960]
    2021-02-27 16:30:20.729 LibreELEC USB-SD Creator[40871:5505930] The application with bundle ID com.apple.ScriptEditor.id.LibreELEC is running setugid(), which is not allowed. Exiting. (1)


    Clicking on Edit launches the macos Script Editor with this:


    -- https://discussions.apple.com/message/23355413#23355413

    -- https://discussions.apple.com/thread/133512?start=0&tstart=0


    set myPath to POSIX path of (path to me as text) -- gets it in "/" form

    set ASTID to AppleScript's text item delimiters -- save 'em

    set AppleScript's text item delimiters to "/"

    set theFolder to (text 1 thru text item -2 of myPath) & "/" as Unicode text

    set AppleScript's text item delimiters to ASTID -- restore 'em

    set execpath to theFolder & "Contents/MacOS/LibreELEC USB-SD Creator"

    set quotedexec to quoted form of execpath

    do shell script "sudo " & quotedexec with administrator privileges


    So I suppose it is the last line that causes the problems.

    Next problem: If I boot the Pi with the ethernet cable connected, the system clock is set to


    Apr 11 2019 18:28:36


    If I boot without the ethernet cable connected, the system clock is correctly set. I installed and configured tvheadend as per this post, but no luck.


    Then, as per this post, I set timeserver #1 to be the IP address of my router and rebooted, but no change.


    Which of these is the next step?


    1. Work out how to give the tvheadend (avahi?) user the rights to change the system clock


    2. Fix ntp (I don't think it is broken, as without eth0 being connected, the system clock is correctly set


    3. Something else

    tvheadend looks to be quite amazing.


    It didn't solve my system clock problem though.

    Hi, resolved with tvheadend server when tick option time update, no need NTP server and no need network connection.

    It's worth mentioning that to find this option, one must install the add-on and then go to http://server-ip:9981 in a web browser.


    Go through the initial setup wizard


    Then it's


    Configuration > General > Base


    Set "User interface level:" > Expert


    Save


    search the page for "Update time:" and check the box


    Save

    Code
    cp /etc/connman/main.conf /storage/.config/connman_main.conf

    ^ edit "PreferredTechnologies = ethernet,wifi,cellular" to be "PreferredTechnologies = wifi,ethernet,cellular" and save/reboot. This ensures connman will allow a persistent default route over WiFi, else when you connect Ethernet connman prefers it and overwrites default routes. You can also use the console "connmanctl" utility over SSH to set the Ethernet interface properties (static address, etc.) but I suspect the GUi will behave once you've changed the technology preference.

    That did the trick!


    Merry Christmas!

    Q1: Why can't I save network settings changes via a USB keyboard (do I need a mouse /facepalm)?


    Q2. How do I have both wlan0 and eth0 start at boot, with wlan0 using dhcp and eth0 using a fixed IP?


    0. With no ethernet cable connected, I reboot my Pi.


    1. Hunched over in front of my TV, using a USB keyboard in a RPi, using the Kodi GUI, in the network settings, when I make changes I can't seem to save them. That is, the "Save" button cannot be selected with the keyboard.


    2. With the settings


    Gear icon > LibreELEC > System > Network > Wireless Networks > Active

    Gear icon > LibreELEC > System > Network > Wired Networks > Active


    and no ethernet cable connected, the one and only entry in


    Gear icon > LibreELEC > System > Connections


    is (correctly) my home WiFi with IP address 192.168.1.129/ ready/ dhcp


    3. With the settings


    Gear icon > LibreELEC > System > Network > Wireless Networks > Active

    Gear icon > LibreELEC > System > Network > Wired Networks > Active


    and a crossover ethernet cable connected directly to a device (an old Squeezebox 3), A new connection appears in


    Gear icon > LibreELEC > System > Connections


    called "Wired" and is bound to eth0. It is configured as manual. It has the IP/ subnet mask/ default router I want (this might not be correct, but it is what I want).


    192.168.10.1/ 255.255.255.0


    4. Leaving the system in the state described by 3., I reboot via the GUI.


    5. The Pi comes up, but only eth0 is ready. wlan0 is idle. This is not what I want.


    6. I disconnect the ethernet cable and reboot. This brings me back to step 0.