Posts by Morphy

    Thanks for looking into it for me :) Like I said, had it all set up in retropie but I can't remember what I did as it was a while ago. I looked at the autoconfig folder on RP and GoodbetterbestLtdGioteckVX22.4GWirelessController.cfg is not in a udev folder but works fine weirdly. I placed it in a udev folder in your build and its working now. Just the shoulder buttons dont do page up and page down in ES but I can prob figure that out at some point.

    The controller is discontinued now but it was sold in a big store outlet here in the UK called Argos. I imagine there's a few of them about as they're not a bad piece of kit for the pricepoint (low!)


    1. [ 8426.516232] hid-generic 0003:25F0:83C2.0002: input,hidraw0: USB HID v1.10 Gamepad [Goodbetterbest Ltd Gioteck VX2 2.4G Wireless Controller] on usb-3f980000.usb-1.2/input0

    I probably should explain why I wanted access to the autoconfig folder:

    My controller was not set up automatically in retroarch after configuring in ES. In retropie this is done automatically I believe? It's been a while since I set that up so could be wrong. I had a look in my retroarch config folder on my RP install and copied the files out of there into autoconfig on LE which I thought would work however the retroarch.cfg points somewhere else...

    Now I tried setting up the controller in retroarch and it places the config file in autoconfig/udev which doesnt seem right to me but it works anyway.

    Another thing, in ES my shoulder buttons normally page up and down on the games lists however in this version not so?

    I already gave you a brief explanation. If you don't understand it well then better don't change it.;)

    Learn what an overlay filesystem is and when it's used. Overlay filesystem - ArchWiki then compare this new knowledge with this file at libreelec-9.0-rr · 5schatten/ · GitHub and I hope you will understand why your changes are not really needed.

    Wow, condescending, much :rolleyes:

    I understand you cannot write to /usr/... and I can see what you've done however I don't think that it's working correctly? I have placed my joypad .cfg files in ~/.config/retroarch/autoconfig and this should be overlaid into /usr/share/retroarch/autoconfig correct?

    mount shows this:

    1. none on /tmp/autoconfig type overlay (rw,relatime,lowerdir=/usr/share/retroarch/autoconfig,upperdir=/storage/.config/retroarch/autoconfig,workdir=/storage/.tmp/autoconfig-workdir)

    Sorry if I'm failing to understand this however all I want is to be able to access the retroarch config files over samba...

    No. The directories in /tmp are an overlay filesystem that allows read and write access otherwise you wouldn't be able to update assets or retroarch-joypad-autoconfig through Retroarchs update function because /usr/share/retroarch would be read-only.

    As stated above RA 1.7.4 was a broken "stable release" so delete your retroarch.cfg and re-run retroarch to create a correct default config.

    Sorry my mistake it was the /usr/share entry obviously. Some of the directories have changed from ~/.config/retroarch/ to /tmp.

    The dir that specifically made my controllers stop working was:

    1. joypad_autoconfig_dir = "/tmp/autoconfig"

    Should be:

    1. joypad_autoconfig_dir = "~/.config/retroarch/autoconfig"

    I'm not sure why you've changed from the .config folder to tmp folder on certain entries but I prefer .config as I can access this over samba by default.

    Can you try audio_driver = "alsathread" too? It's the default setting.

    Yep works too. I think audio_driver = was blank as default, but I may be mistaken

    Can you post the terminal output of aplay -L? It looks like this on my RPi:

    1. null
    2. Discard all samples (playback) or generate zero samples (capture)
    3. default:CARD=ALSA
    4. bcm2835 ALSA, bcm2835 ALSA
    5. Default Audio Device
    6. sysdefault:CARD=ALSA
    7. bcm2835 ALSA, bcm2835 ALSA
    8. Default Audio Device

    Looks identical to that

    Do you use external USB sound devices?

    Nope HDMI out to Onkyo AV AMP

    I managed to get this working by adding this to the ovpn file:
    redirect-gateway def1

    Right ok I thought it discovered the servers from the initial url. When I connect with VPN manager it doesn't work, I get my usual IP address not a VPN one. When I connect with the OE VPN connection it works ok and I get a new VPN IP. The connection method is PPPT apparently.

    The use of user defined vpns is documented on a wiki page. You should go read that

    Thanks yea I've been looking at the wiki. Don't think I've missed anything. As far as I can tell I don't need any crt's just username and password which I've entered. Weirdly it says I'm connected however I only get one server option and the IP is my current one.

    Uploaded a log from a defaulted LE 8.0 installation just to rule any other addons out.

    Can see this error:
    ERROR: Linux route add command failed: external program exited with error status: 2
    Just been having a trawl around and found this suggestion to add slickvpn to the OE connections which works. Now how to get it working with VPN manager.

    I haven't looked at the zip, but the first example you have has the user key and cert commented out - so the import thinks they're not needed.

    Thanks for the reply. Yea I'm not quite sure what's required as a bit of a newb to all this. My provider only lists that ovpn under Ubuntu/Mint so thought that's all i needed. The other zip has a crl.pem file as well which I've no idea what's for. That was under the openvpn windows FAQ. I've tried creating some .crt files from this tutorial and removed the # from the ovpn file but still no dice. I'll try get some logs if you would be so kind to have a look at them.