Cant force 1080/50Hz on plasma

  • Hi all.

    running a S905X (named X96) from china..on a 42 Panasonic plasma from 2007 with a flirc2.

    it works fine.

    but I just cant seem to force 1080/50Hz in KODI. every now and then ( not every time... which is even more weird) my X96 switches back to 1080/60Hz. and I have to change to 50Hz again an calibrate...etc.. very annoying. and the only thing that is wrong with the player. otherwise it runs smootly. ( not using logitechs products - since they lag 0.5-1 secs )


    50Hz makes my movies run smootly but when the player chooses 60hz by itself after powered of for some hours, the movies have small glitches/lags which I can see right away.

    what i dont understand is that ajust to refreshrate is turned off. and the setting to 50Hz should!?? be remembered right ? but it doesnt.. something overrides the setting on kodi..


    my advancedsettings follows.

    I dont know what the issue is..

    please give input..

    is it something to do with hdmi ports ?


    -----------

    </advancedsettings>

    <video>

    <adjustrefreshrate>

    <override>

    <fpsmin>29.96</fpsmin>

    <fpsmax>30.01</fpsmax>

    <refresh>60</refresh>

    </override>

    <override>

    <fpsmin>23.96</fpsmin>

    <fpsmax>24.01</fpsmax>

    <refresh>23.976</refresh>

    </override>

    <override>

    <fpsmin>24.99</fpsmin>

    <fpsmax>25.01</fpsmax>

    <refresh>50</refresh>

    </override>

    <override>

    <fpsmin>49.99</fpsmin>

    <fpsmax>50.01</fpsmax>

    <refresh>60</refresh>

    </override>

    </adjustrefreshrate>

    </video>


    <cache>

    <memorysize>524288000</memorysize>

    <buffermode>1</buffermode>

    <readfactor>10</readfactor>

    </cache>


    <loglevel hide="true">-1</loglevel> <!-- Disables logging -->

    <playcountminimumpercent>95</playcountminimumpercent>

    <skiploopfilter>0</skiploopfilter> <!-- For low CPU device use 16 or higher -->

    <nodvdrom>true</nodvdrom>



    </advancedsettings>

  • Hi all.

    I think i solved this.

    My plasma i HD ready! so using the setting 720P,50Hz seems to not be overrided to some default 1080p/60 hz setting. by the tv/kodi.

  • Hi all.

    I think i solved this.

    My plasma i HD ready! so using the setting 720P,50Hz seems to not be overrided to some default 1080p/60 hz setting. by the tv/kodi.

    I had a 37 inch from that year TH-37PX60B, and the 42 inch version was almost the same. As you say, it's HD Ready, so the resolution support is mainly for 720p at 50 and 60 Hz, although 1080i is also offered, that's not so much help for LibreELEC / Kodi. I'm not sure what exact TV you have but the TH-42PX60B uses a panel which is actually 1024x768 and so the TV does some rescaling of the 720p input to fit the screen as well.

  • its the TH-42PX80E


    I also had the plasma set to automatic screen resolution( by mistake ?), so I have set it to 16:9 default..

    it hasn't changed any thing the last boots of Librelec, and since my eyes are old and the black is still very good in this plasma model, i have no need for more than 720.

    now it seems to work.! lets see..


    very happy with Libreelec!!

  • well its still going on ever 2-3 times i restart the box, the resolution is back top 1080/60hz, and not possible to edit.. have to restart to edit!.


    very annoying

  • Hi all.


    Solved it.!


    1: disabled overscan on plasma..


    2: and added to advancedsettings the following lines so that the resolution is fixed at 50hz


    <resolutions>

    <resolution>

    <description>1920x1080 @ 50.00 - Full Screen</description>

    <subtitles>1041</subtitles>

    <pixelratio>1.000000</pixelratio>

    <overscan>

    <left>49</left>

    <top>24</top>

    <right>1880</right>

    <bottom>1049</bottom>

    </overscan>

    </resolution>

    </resolutions>

    Edited once, last by ressurex ().