Cannot access Libreelec Nuc via Windows 10

  • What file are you adding your changes to, paste the full path of the file you are changing.


    The only samba.conf file LibreELEC replaces is /storage/.config/samba.conf.sample.


    I suspect you're either editing the wrong file, or if you're editing via Windows then your Windows editor is creating a file with a .txt extension that is being ignored.

  • Well 1 problem solved..that is accessing Libreelec from Windows 10..

    Now I cannot access windows 10 from Libreelec...

    I did create a new user account on Windows 10....made it password protected and shared a folder with everyone..

    Now when I go to file manager in kodi on rpi2 to add source and browse to SMB..there is absolutely nothing in there...not even my other Libreelec laptop..

    Tryed the new smb settings in services from None to smb3 and restarter each time and still nothing..

    This is on the latest 8.1.0


    Update:

    I can access windows 10 and PC if I force SMB V1 but not 2 and 3

    Zeroconf also working to access other Libreelec and Windows 10 Creators..


    Should the SMB V2 and V3 be working for me?

    Edited once, last by Mario77 ().

  • Read the 8.1.0 announcement, in particular the section "!!! SAMBA UPDATE – IMPORTANT !!!" (third bullet point).

    Should the SMB V2 and V3 be working for me?


    Not if you're forcing SMB1.


    If you haven't already setup your smb:// sources then you'll need to enable SMB1 on your server (and force Kodi to make only SMB1 connections), then set up your sources in Kodi using network browsing (if available). If network browsing no longer works (which is possible, depending on your server, Samba4 in LibreELEC, and the way the wind is blowing), then you'll just have to add network locations manually in Kodi (leave the username/password blank - add this when prompted on first access, saved in passwords.xml), then add your sources.


    Once your sources are all configured, disable SMB1 on your server, configure SMB in Kodi as "None" (ie. auto-negotiate, which should mean SMB3 or maybe SMB2, depending on your server).


  • Thanks...very clear explanation and everything working as it should...

    In short....add new sources with force SMB 1..."save password for this path" ticked and after that back to force smb to "None" and source is still coming up

  • I have same issues , and yes I do use custom samba , but windows is version 7

    Update the box will stop acsess true network , (popup appears ; users / password ) , downgrade to 8.0.2 will open it again

    Compleet new install with 8.1.0 does give network acsess


    (Edit ; problem solved ; removed custom samba , upgrade , customise new samba)

    Edited once, last by JohnA ().

  • Back for some more help...


    Ok so now I managed to access Libreelec from PC and Vice versa with SMB set to none working still but I m noticing a small hickup when trying to access my PC from Libreelec while PC is sleeping..

    I have wakeonlan enabled...Pc network set to wakeup PC,,wakeonlan.xml on libreelec set but it's only working when I change the source address and wakeonlan.xml to IP instead of host name..

    I understand that there is hosts.config to map ip address to host but not sure how to edit this

    I tryed adding these lines to hosts.config first as shown below ,and then with arrows but none seemed to work...

    try 1: 192.168.0.9 MARIO-DESKTOP

    try 2: <192.168.0.9> <MARIO-DESKTOP>

  • Look at /etc/hosts.

    This is how /etc/hosts looks like but WOL doesnt work for some reason


    It only works if I change source to IP address but not by hostname...I m using Rpi 2


    EDIT: Never mind it's working fine now...

    Files

    • hosts.txt

      (402 Byte, downloaded 146 times, last: )

    Edited 2 times, last by Mario77 ().