v8.1.0 beta - key presses on remote are repeated twice

  • Hi all,

    I'm not posting in the "bug" section because I'm not completely sure this is the case.


    After installation of v8.1.0 BETA, key presses on remote are repeated twice; the remote is a Logitech Harmony Ultimate configured as MCE.

    I now have disabled LIRC on LibreElec settings and everything seems to work fine, I'm just wondering if this is correct ? How everything worked fine with previous versions ?

    Here is my kodi.log: UIZU

    Thanks :)

  • I am having the same problem:


    using an original microsoft MCE remote, with the original microsoft RC6 receiver.


    After upgrading my system initially everything worked fine, but after a reboot every keypress is repeated.

  • LibreELEC supports MCE remotes out-of-the box without having to run lircd - they are handled by the Linux kernel.


    In general, keep lirc disabled and if you need to configure your remote use ir-keytable. Lirc is meant to be used only in very special cases, with odd remotes that aren't supported by the linux kernel / ir-keytable.


    If you enable lirc eg with an MCE remote it can happen that the button presses are decoded both by the kernel and by lirc, and you get double actions.


    so long,


    Hias

  • Then it will be better to disable [lirc] in the setting by default ... less confusion

    Lirc shouldn't be enabled by default, you have to manually turn that on.


    If it behaved differently on your setup it would be great if you could post steps how to reproduce this.


    IIRC the only cases where lirc was automatically enabled in the past were if you used lirc_rpi on the RPi or if you had an old xbox dvd remote receiver plugged in.


    so long,


    Hias

  • Lirc shouldn't be enabled by default, you have to manually turn that on.

    If it behaved differently on your setup it would be great if you could post steps how to reproduce this.


    [...]


    Nothing special, I just update LE v8.0.2MR through the le-addon. After reboot the entry 'lirc' was present and active.


    My device: Zotac Zbox ci321nano with LE x86_64_generic

  • I cannot find where to Disable lirc-option in libreelec-settings

    Please provide guidance.

    EDIT:

    Found it:-

    Settings->LibreELEC->Services->Lirc->Enable Lirc->OFF

    Edited once, last by robfish ().


  • Nothing special, I just update LE v8.0.2MR through the le-addon. After reboot the entry 'lirc' was present and active.


    My device: Zotac Zbox ci321nano with LE x86_64_generic

    I could now (partly) reproduce the issue on RPi and understand what's going on:


    In LE 8.0.x lirc is automatically enabled if an IR receiver supporting the /dev/lirc interface is detected. If you go to LE Settings->Services "Enable Lirc" will be set to on.


    But although lirc was enabled it wouldn't be started unless you had a .config/lircd.conf file or were using the lirc_rpi driver on RPi or had an old xbox dvd remote dongle connected. As the remote buttons were still decoded by the kernel everything worked as before and we all seem to have missed the fact that Lirc was actually enabled when it shouldn't have been...


    In 8.1.0 Lirc handling changed: on a fresh install it won't be enabled by default, and if you enable it it will actually be started - using a default lircd.conf file if you didn't provide your own.


    So, on a 8.0.x->8.1.0 upgrade you are now presented with an enabled and actually running lircd.


    The one thing I don't quite understand, and also couldn't reproduce so far, is why you get the "double buttonpresses" on Generic.


    When lircd starts it will automatically disable in-kernel decoding. OTOH there's also the ir-keytable auto-configuration running which enables in-kernel decoding for MCE and a bunch of other remotes. Although that leads to 2 configuration services fighting against each other I had expected lircd to be run last, and thus win, and lead to remote buttons only be decoded by lircd, not the kernel - this is also what I got in my tests on RPi.


    It would be great if someone plagued by double-presses could do a few tests on 8.1.0, maybe that'll give some clues about why that happens:

    Enable lirc in LE settings, reboot, then run the following commands:

    Code
    1. ir-keytable -r | paste
    2. journalctl -a | paste


    so long,


    Hias

  • Hi, I recently switched from Openelec to LibreELEC. I added the files lircd.conf, Lircmap.xml and remote.xml on LibreELEC 8.1. It didn't work until I turned on "Enable Lirc". After this it worked perfectly fine, but after some time it stopped working completely. I don't understand what's wrong. Under Openelec 5.95.3 everything was fine. Turning "Enable Lirc" on and off allows me to use my remote once, but afterwards it stops working. The remote I'm using is the Xbox one remote. I also added dtoverlay=lirc-rpi to the config.

  • [...]

    It would be great if someone plagued by double-presses could do a few tests on 8.1.0, maybe that'll give some clues about why that happens:

    Enable lirc in LE settings, reboot, then run the following commands:

    It's strange. I have activated 'lirc', reboot, and the error with double commands no longer occurs. But if I now deactivate 'lirc' again, irc no longer works, so I have to activate 'lirc' in settings now. o0


    Here still my logs:

    Code
    1. with activated 'lirc'
    2. http://sprunge.us/dGVU
    3. http://sprunge.us/GEGS
    4. with deactivated 'lirc'
    5. http://sprunge.us/KMgd
    6. http://sprunge.us/YPjR

    Looks as if the error only happens at the first reboot after update.


    rgds

    Hanxi

  • Hi, I recently switched from Openelec to LibreELEC. I added the files lircd.conf, Lircmap.xml and remote.xml on LibreELEC 8.1. It didn't work until I turned on "Enable Lirc". After this it worked perfectly fine, but after some time it stopped working completely. I don't understand what's wrong. Under Openelec 5.95.3 everything was fine. Turning "Enable Lirc" on and off allows me to use my remote once, but afterwards it stops working. The remote I'm using is the Xbox one remote. I also added dtoverlay=lirc-rpi to the config.

    Please post the output of these commands when the remote stopped working:

    Code
    1. journalctl -a | paste
    2. dmesg | paste
    3. systemctl status lircd | paste
    4. systemctl status lircd-uinput | paste
    5. systemctl status eventlircd | paste


    so long,


    Hias

  • Same for me - LE x86_64_generic - NUC6CAYH


    add me to the list too, i didn't knowingly have this switched on prior to the update (8.0.2 intel generic), after updating to 8.1.0 intel generic (using manual update process by dumping in target files to smb updates folder) i noticed the double remote click issue, found this thread and sure enough Lirc was enabled in LibreELEC settings.


    probably not relevant at all but hardware is Intel NUC7i5BNH

  • It's strange. I have activated 'lirc', reboot, and the error with double commands no longer occurs. But if I now deactivate 'lirc' again, irc no longer works, so I have to activate 'lirc' in settings now. o0

    This means lircd successfully disabled in-kernel decoding. If you then disable lirc that won't be re-enabled again and your remote no longer works. You could manually enable it on the shell via "ir-keytable -p rc6,nec", but in general it's easier to just reboot.


    Quote

    Here still my logs:

    Crap, the interesting stuff (enabled protocols) didn't make it into the logs - ir-keytable sends them to stderr instead of stdout...


    If you catch a situation with double-presses again, please run these commands instead:

    Code
    1. ir-keytable -r 2>&1 | paste
    2. journalctl -a | paste


    But no need to spend too much time on that, the info that the issue doesn't always occur was already helpful!

    Quote
    Looks as if the error only happens at the first reboot after update.

    It's probably rather random if you get that issue or not - after all if there's a fight between 2 configuration services it's not good and the easy solution is to just disable lirc in LE settings.


    so long,


    Hias