System lockups.

  • Wonder if anyone could have a look at my log and tell me how to fix some of the error's in there. I'm getting errors "can't find" certain folders and windows.


    I don't know if these are the cause, but my system regularly locks up. Sometimes video stops and audio continues, other times both audio & video stop. I can't bring the menu up or do any functions. If I SSH in and restart Kodi, it will restart and work fine again. This can happen after a few minutes or an hour. The end of this log is where it has currently locked up again.

    kodi.zip

    Thank you for taking the time. It is frustrating.

  • 22:21:00.943 T:140117368126784 NOTICE: Running on LibreELEC (community) - Version: devel-20170712 8.0, kernel: Linux x86 64-bit version 4.11.9


    I'm not sure where you got this build from.


    Is this an older Milhouse build, then first upgrade to the latest nightly build. After that, visit his specific topic/thread on the Kodi forum.

    If not, start with a fresh installation of the stable 8.0.2 Generic LibreELEC build.

  • Sorry. Should have mentioned, it's the LE8 Extended build by escalade. I'd love to use the stable build, but couldn't find a way to integrate retroarch & Emulation Station into it.

  • Yeah. I forgot about that. Sorry.

    I was just reading about the Gamestarter addon that can be installed on the official. I might give that ago.


    Thanks for your time.

  • Hi again. I decided to try the official build and have only installed the essentials so far.

    Downloaded and installed 8.0.2 gen stable for Intel

    TVHeadend and got that up and running.

    LCDProc and set that up.

    My custom remote button mapping.

    Running standard skin. There are quite a few errors relating to importing media. Not worried about them.

    Freezing seems to have stopped. Only been up and running for an hour or so now.


    Still have errors relating to button mapping. Not sure if it's anything to do with my custom remote.xml or not. I don't think I have any entries in it like the errors that are occuring.

    Have attached the log kodi.zip

    and remote.xml kodi.zip


    Can you see anything I have done wrong, or would it be elsewhere?

    Would like to know where to look.

    Thank you.

    Files

    • remote.zip

      (2.54 kB, downloaded 99 times, last: )
  • Button mapping is not my field of expertise. Someone else will have to step in.

  • Just had this error after the system locked up. I had just started a backup before installing some more addons and the video locked up. Menu response is veeeerrrryyy slow.

    ERROR: (VDPAU) Error: An invalid pointer was provided.(4) at /home/chewitt/LibreELEC.80-images/build.LibreELEC-Generic.x86_64-8.0.2/kodi-147cec4/xbmc/cores/VideoPlayer/DVDCodecs/Video/VDPAU.cpp:1041

    Logs from this crash attached.

    log-2017-07-30-12.24.21.zip

    I have an NVidia GPU.

    Thank you.

  • I occasionally get this same error and lockups on my generic X86_64 NVidia machine running LE 8.0.1 though I haven't been able to figure out a pattern.


    This morning I hit the error when launching a TV channel...


    It started with a few Invalid Handle errors.

    07:46:34.872 T:140562470610688 ERROR: (VDPAU) Error: An invalid handle value was provided.(3) at /home/a/LibreELEC.tv/build.LibreELEC-Generic.x86_64-8.0.1/kodi-fc1619b/xbmc/cores/VideoPlayer/DVDCodecs/Video/VDPAU.cpp:1041

    07:46:34.872 T:140562470610688 ERROR: Decode - avcodec_decode_video returned failure


    The TV channel seemed to play OK, but the whole thing froze when I hit exit to return to the Kodi Home screen (with video still playing in the background). At this point I see several occurrences of the following error in kodi.log


    07:46:44.635 T:140562470610688 ERROR: (VDPAU) Error: An invalid pointer was provided.(4) at /home/a/LibreELEC.tv/build.LibreELEC-Generic.x86_64-8.0.1/kodi-fc1619b/xbmc/cores/VideoPlayer/DVDCodecs/Video/VDPAU.cpp:1041


    I tried hitting stop a few times to come out of the video but the whole thing was locked up so I just restarted kodi via SSH -> 'systemctl restart kodi'


    I've attached the kodi logfile, but unfortunately don't have a debug log. (this only happens very occasionally, I cannot reproduce at will, and I don't leave debug logging in place, since I find this causes poor performance in other areas).


    However, here is a kodi logfile from my occurrence this morning.

    GgWK


    I am planning to upgrade when v8.2.0 has been released in the hope that maybe the NVidia driver bump could resolve it.


    In the meantime, I'm not sure whether anyone can comment as to where the problem may lie from the logfile, and indeed whether upgrading to 8.2.0 will fix it.

  • In the end for me it was the graphics driver. Used to work well for me on OE6 but when I moved to LE 8 the new nVidia driver was having problems.


    You actually have to go back to an older driver. New driver only works on 900 series and later I think.


    I think you had to enter this line via SSH.


    Code
    1. wget http://chewitt.libreelec.tv/96-nvidia.rules -O /storage/.config/udev.rules.d/96-nvidia.rules