Brix J1900 onboard Wifi/BT issue

  • Hi, I've been having some problems with Wifi/BT on my Gigabyte Brix, I think it started on LE 8.0.2 but not sure. The main problem is that sometimes I boot, and I only see my Wifi WLAN0 and BT doesn't work (Both share the same card, a Realtek 8723BE). Sometimes BT works, but Wifi does not and I can't see any Access Points when I got the Wifi Networks, nothing is showing... like if WLAN0 is not being detected. Reboot, and again.... sometime it works both, sometimes only one... most of the time, only BT works... it's driving me crazy.


    Things I tried: Deleted all my storage and started fresh. Followed the first time setup perfectly, configured everything, reboot a couple of times... and again, the problem showed again. Anyone having a similar problem ? Any ideas what to check to be able to identify the problem at least ?


    On 8.0.0 I used to have 2 wifi's, the onboard and a TPLink external and both worked perfectly fine including BT from the onboard one.... I even was able to see WLAN0 and WLAN1 on the wifi networks, but since TPLink driver for AC was wrongfully added on last version, I can only use my onboard till they fix the main source and get a new version of LE, but I don't think that's the problem, although my TPLink is still connected, because I use it for Windows.


    Sorry for the long chat... :) Any ideas are welcome. Thnks !

  • No, it's not. Though about enabling it but shouldn't be my case and it used to work without it on previous versions. Will try anyway later... just in case. Thanks Klojum.

  • No good news, still having the problem. Boot the Brix and no Wifi on LE 8.0.2. Reboot and maybe it just works fine... maybe not. Like really random, sometimes I get Wifi, sometimes I don't.