what am i missing or doing wrong? cross-compiling LE8

  • When i saw how the LE8 community build had BOTH kodi and retroarch. i wanted to test it on my cubox-i 4x4.

    strangely enough, there was no imx6 build for it. so, i look up how make it. so i have the directory, ran the make image command with the correct parameters.

    ......until i get errors. i have a ~30MB log file documenting the whole process.

    i'm running Ubuntu 16.04 headless on a 500GB duo-core tower with 4GB ram. Am i running out of RAM here?

    the last time i tried this project was back in august. i have already tried the "Generic" build of LE8 on my laptop, and i still want it on my cubox.

    so, as the title says..."what am i missing or doing wrong?"

  • Build completed - git aa967f4. No errors.

    Try removing cmake package and build again:

    1. PROJECT=imx6 ARCH=arm ./scripts/clean cmake
    2. PROJECT=imx6 ARCH=arm make image


  • No idea what this could be. I think it is cmake package problem because it should go to 100%. Seems you will have to figure out that yourself :(


  • hmmm.....

    "qmake: could not exec '/usr/lib/i386-linux-gnu/qt4/bin/qmake': No such file or directory"

    is qmake necessary? this shows up every time...

    even stranger is when i use "whereis qmake", it says "qmake: /usr/bin/qmake" not '/usr/lib/i386-linux-gnu/qt4/bin/qmake'

    are these files one and the same?

  • Quote

    qmake: could not exec '/usr/lib/x86_64-linux-gnu/qt4/bin/qmake': No such file or directory

    I get this too if type qmake on console. But still can make image.


  • ok, this probably foolish of me to ask and most likely to be denied...

    any chance you can upload your build? my past experiences tend to show me as a more of a tester than builder....

  • i might have to give up on this project anyway, the build you just uploaded, its doing the black screen glitch on my cubox-i 4x4.

    thanks for your time and effort, but it looks like i have the short end of the straw for this aspect of "computers"....