Librespot addon

  • Hi, your addon is so great! Will you update it for matrix?


    When installing the beta 1 librespot doesn't appear on the addons repo


    Thanks very much

  • hello,


    thank you very much for the addon!

    running the latest rpi4 nightliy (le10.0 nightly-20210411-5a67b41) and librespot crashes after playing some songs from a playlist.

    tried it several times. it crashes after playing 2-3 songs. doesn't matter which song.


    full kod.log: http://ix.io/2VSd


    would be great if someone can look into it!

    (after a quick search it looks like a utf-8 problem: python - UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 23: ordinal not in range(128) - Stack Overflow )


    thx very much!

  • jomir could you please check @ Issues · librespot-org/librespot · GitHub and

    Commits · librespot-org/librespot · GitHub And see if this a know bug or if there is a known fix? otherwise - can you please raise it as an issue. Do any of your song titles have extended characters?

  • jomir could you please check @ Issues · librespot-org/librespot · GitHub and

    Commits · librespot-org/librespot · GitHub And see if this a know bug or if there is a known fix? otherwise - can you please raise it as an issue. Do any of your song titles have extended characters?

    thx for the quick answer. the songs didn't hv any special characters:

    i didn't find any similar known bugs at Issues · librespot-org/librespot · GitHub

    but i found a similar (closed) pull request at librespot: stop crashing when logging titles with wide characters by vpit · Pull Request #4339 · LibreELEC/LibreELEC.tv · GitHub


    mglae suggests a fix:

    thx! will try and test tomorrow.

    Edited once, last by jomir ().

  • playlist is running for hours now. no crash. looks like the patch fixed the problem. thank you very much!

  • Since the recent Spotify update librespot no longer shows up on the device list, I have rebooted and no joy from that. is there a compatibility issue or has something broke somewhere? I have tried to uninstall and reinstall the addon but that did nothing also. Other devices show up as normal IE my phone & Google speaker.

  • Just installed Librespot for the first time on RPi 4 with last version of Libreelec and i have some questions. I see it's working through pulseaudio, although i use ALSA as my output! Why does it use pulseaudio? is it possible to make it work directly? Second question, why do i see format 1411 kbps, instead of ogg vorbis? And last question is CPU load, it's relatively higher, than when i play 16-44.1 flac format from usb storage or streaming, using upnp renderer. It's about 40% against 17-19. And it's that high on home menu screen.

    Edited once, last by fominator ().

  • Hi,

    I have Rpi4 with LE 10b2 and librespot installed. Everything works well, but there is two volume regulations: in phone and in LibreELEC. My question is how to set volume always max in librespot and modify it only via Spotify in phone?