Resume from Suspend please help.

  • Hi,


    I'm a libreelec newbie, so please excuse if this question is a bit lame.
    But I need help.


    Changed my system from running win7 and kodi to running libreelec 8.0.1
    So far it been a pleasant experience :shy:


    The system spec is as follows :
    Intel core 2 due E7500 @2.93GHz
    Zotac geforce 9300 mini-itx board
    4GB ram
    96GB ssd drive


    I have one setup problem, on win7 my suspend and wake from S3 sleep with remote and USB receiver was working 100%.
    On libreelec the system suspends fine, usb activate, PC comes on, but there is no activity from the HDD and nothing from kodi - screen just stays blank, nothing happens when you press any keys. You have to hold the power button for complete power off then it starts up again.


    Please assist me with this, only thing keeping me from being complete happy with the switch ...


    Thanks
    Mike
    [hr]
    Update, screen is not actually blank on resume. It has the text : LibreELEC (official) - Version: 8.0.1
    Like on bootup but without the libreelect graphic logo and it just stays like that.

    Edited once, last by MikeT ().

  • Double check which Nvidia driver is active.
    Normally only the newer Nvidia gfx cards have syspend problems.
    Your box should default to the legacy video driver.


  • Double check which Nvidia driver is active.
    Normally only the newer Nvidia gfx cards have syspend problems.
    Your box should default to the legacy video driver.



    Not sure if everybody saw the update :


    Update, screen is not actually blank on resume. It has the text : LibreELEC (official) - Version: 8.0.1
    Like on bootup but without the libreelect graphic logo and it just stays like that.


    I loaded the generic LE 8.0.1 image - so guess that would be the legacy driver - not sure how to check ?


    also created a resume script and write to a .log just to see if it gets that far ..... it does not - just hangs the system


    I then tried to connect too the LE box from another PC using putty - and it just tells me the connection times out.
    So it seems the system hangs at that point ?


    Mike

  • Hello!


    Check/try what happens if you edit those settings below in your BIOS.


    1. Dissable HPET
    2. force BIOS Post of addon videocard.
    3. S1/S3 state (I guess the PC is to old for S4/5)
    4. Acpi settings (wake on lan/keyboard/mouse)


    Regards
    Nicolas

    Edited once, last by Nicolas ().


  • Hi,
    Thanks for the suggestions.


    Tried all the above with the following results ....
    1.) No difference
    2.) this is onboard video card - but when I force repost of video - on resume screen is black - hanging
    when I do not force repost - the screen just displays "LibreELEC (official) - Version: 8.0.1" - hanging
    3.) Yes only S1 and S3 - with S1 it suspends with power light flashing - cannot get it to come on again.
    S3 - suspends no problem, and will wakeup with keyboard or USB remote - but hangs as mentioned.
    4.) ACPI settings - tried all different combinations - no difference.


    I also checked the video driver and I am using the legacy nvidia drivers.


    Not sure that the correct drivers is actually included ...
    With the onboard video - the chipset is nForce 730i/geforce 9300.


    Anyone know if the mentioned chipset is supported by the current drivers ?
    If not, is there a way to load older drivers manually in libreelec ?


    link to the full spec of the board i am talking about

  • nForce chipsets are getting pretty old... Support is fading away.
    The alternative is: fully power down your htpc. It saves a bit of electricity as well.
    Booting with a SSD should be done in under 20 seconds... Is that such a big deal?


    Or why not get a simple & cheap alternative like a Raspberry Pi 3 ?

  • If USB power on from your remote works it is even better than suspending the PC!


    Btw I am also using shutdown instead of suspend.
    Regards
    Nicolas


  • If USB power on from your remote works it is even better than suspending the PC!


    Btw I am also using shutdown instead of suspend.
    Regards
    Nicolas


    Nope - its wake from suspend with the remote - power-on does not work.
    [hr]


    nForce chipsets are getting pretty old... Support is fading away.
    The alternative is: fully power down your htpc. It saves a bit of electricity as well.
    Booting with a SSD should be done in under 20 seconds... Is that such a big deal?


    Or why not get a simple & cheap alternative like a Raspberry Pi 3 ?


    :( not great news .....
    Windows 7 runs this thing perfectly - with suspend wake working flawlessly, smooth playback.
    Just liked the linux setup more - boot time is quicker, and you get a component feel from it - not booting into windows, seeing desktop and then kodi loading.


    I already have 3 pi's running in the house - each bedroom, running libreelec - that is what prompted me to change my main HTPC over to libreelec and give it a go.
    Looks like I might have to install windows again :(

    Edited once, last by MikeT ().

  • On some Mainboards you have to set a pin to power the USB ports if the PC is off. On mine I had to switch USB ports because some do work some don't.


    Regards
    Nicolas


  • On some Mainboards you have to set a pin to power the USB ports if the PC is off. On mine I had to switch USB ports because some do work some don't.


    Regards
    Nicolas


    will give that a try, thanks.
    that jumper is already set, that is what enables wake from suspend, else it powers down the USB as well.


    Have seen that the usb ir receiver stays active even if the PC is powered down, but does not turn on the pc.
    will try different ports and see if that helps.

  • And set everthing in ACPI to enable (power on by mouse, keyboard, lan, timer by OS, pci, etc).


    Regards
    Nicolas