Just video but no audio

  • Hi!
    I have a big issue with Libreelec and my Onkyo 609 receiver, the issue was also present with Openelec, so I assume it is connected to my specific setup.
    Anyway, I have been running on an older OpenElec release (5.0.8) for quite some time (as later releases didn't work in terms of audio output). I decided to have a go with Libreelec instead, but I get the same issue as I had with the later Openelec releases.

    I get no audio output, only video. It is pretty obvious that it is connected to the Onkyo, as it works as it should when connecting it directly to a TV without the receiver. I have enabled audio pass through for all of the types, without success.

    Anyone have a clue? I can attach a logfile later on when I am back home.

    HW: Asus E45M1-i with a HD 6320 GPU (Realtek® ALC892 8-Channel High Definition Audio CODEC)
    Onkyo 609
    Benq W1070


  • Okay, I just experienced a very strange thing. I decided to retrieve some debug logfiles instead of these more general ones. When the HTPC started I had audio!! One drawback was that the resolution was 640x480p (instead of the desired 1920x1080p), I retrieved the debug logfile, attached to this post as debugfile_1. I had a quick look at the audio settings (note that the output device is ALSA: HD-Audio Generic, @@@):

    I decided to restart the HTPC, and change the resolution and get a new debug logfile. But then the audio wasn't working again, and I did no changes to the settings that may have created this behavior. I took a new screenshot on (this time, note that the output device have changed slightly (ALSA:HD-Audio Generic, HDMI), the video output remains the same though:

    The change of audio output (no "@@@") causes the system to not send any audio. In fact, the audio stream is not available at all (grayed out):

    I have added the debug log file below, debugfile_1 is the one where everything worked. Debugfile_2 also contains the issues I had after rebooting

    Please let me know if you require more information of me. I am stuck for the moment, I don't know how to move forward.

  • could you please try the following....

    Set the output configuration to "fixed" and set it to 48? Does that help?

    Thank you for your feedback, it is very appreciated. I tried this setting but no luck. Strangely though, when I started the HTPC tonight, the audio worked, again. But only the first time, after a reboot of the computer I am back to square one. There is no way to force the sound back. I tried to shut everything down to do it again, with the exact same pre-requisite, but no change.
    After some extensive testing I now know what causes the error, but really dont know how to fix it. The issue seems to be connected to my projector. When I start the system, I tend to start the computer first, then the receiver, and the projector last. Everyone that owns a projector knows that the projector don't light up instantly, for me it can take up to 20-30 seconds. This will make the audio work everytime I start the system. But it does not work if I reboot the computer, since the projector is running at that time.

    So, I tried to shut everything down again, and then started up again. It works. So there is something with the settings regarding Projector or Projector<->Receiver.
    Or can I bypass this issue with a setting in Kodi? The workaround is good enough, for now, but I would really want to fix this very very annoying issue.

    Edited once, last by Exile82 (April 28, 2017 at 8:35 PM).

  • Ah, that thing...ok. As for the reason you have some AMD hardware, I can't help much. If you would have Intel or NVidia based HTPC there are workarounds to dump the EDID information the HTPC gets and fake a connected monitor.

    The way I know of don't work for AMD devices. So you always have to turn on the HTPC as the last device in the chain.