DVB-C issues with DD Cine CT V6

  • Hello,

    I used my Digital Devices CT V6 TV-Card for some years now in OE with VDR. After uprading to LE it doesn't work anymore. I then made a clean install of LE (Generic.x86_64-6.90.004) and later of OE (Generic.x86_64-6.0.3). Both without success. I think I'm doing something wrong. But I don't know what...

    Here my steps:

    • Installing LE Generic.x86_64-6.90.004 (with standard setting, only activating SSH)
    • Enabling VDR PVR Backend from the LibreELEC Add-ons-Repository (The two addons VDR Configuration and VDR VNSI Client are automatically installed and activated)
    • Enabling TV under TV->General (The message appears "No PVR add-on enabled - The PVR manager has been enabled without any enabled PVR add-on..."
    • Now the VDR VNSI Client is diabled. I enabled the VDR Client, but no success.
    • I made a reboot. After starting Kodi the message appears again "No PVR add-on enabled...". Again I enabled the VDR Client, but no success.
    • When I start the Channel scanner Configuration from the VDR Configuration add-on, the message "Unable to connect to VDR restfull API" appears.

    I tried several time activation / deactivating add-ons with reboots. Nothing helped. I also tried tvheadend without success.

    LibreELEC:~ # ls /dev/dvb
    ls: /dev/dvb: No such file or directory
    LibreELEC:~ # dmesg | grep DDBridge
    [    5.816334] DDBridge driver detected: Digital Devices DVBCT V6.1 DVB adapter

    I think it is a problem with the driver, but i'm not familiar with this. Thanks for your help

  • Thank you for your help!
    I made a clean install, but it's like before.
    Only one thing changed: After three reboots now the VDR VNSI Client stay enabled, so I getting the message "VDR VNSI Client - Connection lost".

  • Today I upgraded to LE v7.90.010 ALPHA. After that, my DD Cine CT V6 don't works.

    HTPC:~ # ls -l /dev/dvb/adapter*
    ls: /dev/dvb/adapter*: No such file or directory

    Back to v7.90.009 ALPHA it worked again. Did I something wrong, or is this TV-Tuner not supported in the offical releases anymore? Thanks!

  • could you post a log from 009 too ?

    form 009: JNMT

    [ 8.073958] Digital Devices PCIE bridge driver 0.9.23, Copyright (C) 2010-15 Digital Devices GmbH
    [ 8.080738] DDBridge driver detected: Digital Devices DVBCT V6.1 DVB adapter
    [ 8.080755] DDBridge: HW 0001000d REGMAP 00010004
    [ 8.088069] Port 0: Link 0, Link Port 0 (TAB 1): DUAL DVB-C/T
    [ 8.089092] Port 1: Link 0, Link Port 1 (TAB 2): NO MODULE
    [ 8.090115] Port 2: Link 0, Link Port 2 (TAB 3): NO MODULE
    [ 8.090647] 0 netstream channels
    [ 8.090650] DVB: registering new adapter (DDBridge)
    [ 8.090651] DVB: registering new adapter (DDBridge)

  • Ah yea, 4.8 uses a dd bridge patch from 3rd party, that won't work at 4.9 and was dropped. Looks like 4.9 don't support your card completely :/

    The ddbridge patch for 4.9 is working fine on my DD Cine CT V6 with my private build. Unfortunately it was conflicting with the TBS driver patches that has been added to the LibreELEC 4.9 kernel and could not be updated.

    As the TBS driver patches are removed in the meantime I will PR the ddbridge patch again the next few days.