Sync issues after upgrade from LE 7.0x to 8.01 (Pi 3)

  • Hi all,


    First, let me give thanks to the devs and everyone involved for such an incredible open-source media center - it has changed the way we watch TV and opened our eyes to content we didn't even know existed. Thank you!


    After upgrading to LE 8.0.1 the migration process hung on the MythTV addon, presumably since I didn't have the back-end fully set up yet. Is there a way to restart this wizard from the shell when logged in via SSH? e.g. kodi --migrate... Would it help the issue below?


    After the update, there are a couple of interesting things that happen now. When starting a live stream, the UI will show that the stream started and is playing at the top of the screen and kodi.log will show that playback has started but the display won't switch to the stream for a few seconds. When viewing an RT live stream for example, it will exhibit this behavior and then the video will start/stutter and be in sync for a couple of seconds, then it will sort of skip and fast-forward for a second or two and be out of sync. I've played with various combinations of syncing audio via PLL adjust, syncing refresh at start/stop, etc. to no avail.


    This also appears to affect the Retrospect addon, although I think it eventually syncs up... need to play with it a bit more to see exactly how that behaves.


    Is this a known issue? Does the RT addon need to be updated or would the Kodi migration wizard solve this problem if it's allowed to run?


    Thanks again,


    - Phil


    Edit PS: previous version was LibreElec 7.03? I can't find it in the downloads section anymore but it was the latest 7.x version for the Pi 2/3.

    Edited once, last by pquesinb ().

    • Official Post

    generally there is no Kodi migration wizard.


    After upgrading to LE 8.0.1


    From which version did you upgrade to LE 8.0.1?


    Could you please provide a full debuglog?


  • Thanks for looking into this.


    I was surprised as I'd never seen a migration process on Kodi before. I forget the exact wording but it said something like "Add on migration in progress...". There are references to it in the Kodi forum.


    The Retrospect add-on appears to be fine, as are "on-demand" RT titles like Keiser Report, etc. The RT Live stream is definitely a problem after the update so this may be an add-on incompatibility, hence my question about whether or not the migration process (which hung) might have fixed it.


    I also noticed that the visualizations for playing music, like the rotating FFT display, act like there is no audio going to them after the update. The display rotates but the bars do not jump, as if you were playing a silent track.


    Full debug log from when the RT Live video is started until it is stopped is at the below URL:
    K6U0R6YH


    The video starts out in sync but a couple of seconds in it looks like it does a fast-forward or rewind and then it's pretty far off... I'm guessing more like 5.8 or 12 seconds based on the resyncs seen in the log like the following:


    11:17:11.208 T:1961817200 DEBUG: Resolution 1920x1080 (1920x1080) @ 59.94 - Full Screen (31) not a very good match for fps 25.000 (weight: 0.199), trying 2:3 cadence
    11:17:11.208 T:1961817200 DEBUG: Resolution 1920x1080 (1920x1080) @ 59.94 - Full Screen (31) not a very good match for fps 25.000 with 2:3 cadence (weight: 0.041), choosing 60 hertz
    11:17:11.208 T:1961817200 NOTICE: Display resolution ADJUST : 1920x1080 (1920x1080) @ 60.00 - Full Screen (16) (weight: 0.200)
    11:17:11.209 T:1925182368 DEBUG: CAESinkPi:Drain delay:0ms now:0ms
    11:17:11.209 T:1925182368 DEBUG: CAESinkPi:Deinitialize
    11:17:11.209 T:1925182368 DEBUG: CAESinkPi:SetAudioProps hdmi_stream_channels 0 hdmi_channel_map 00000000
    11:17:11.209 T:1961817200 NOTICE: VideoPlayer: OnLostDisplay received
    11:17:11.239 T:1484305312 DEBUG: CVideoPlayer::CheckContinuity - resync backward :2, prev:5919999.999998, curr:119999.999995, diff:-5800000.000003


    I tried it again (not logged here) and it settled in around 1 second off... I'm not sure if it did the same thing and got that close to being back in sync during the fully logged attempt above. If I come up with any additional info that seems like it might be useful I'll post it here.


    Again thanks,


    - Phil

  • I see that I edited my initial post instead of the reply... previous version upgraded from was LE 7.0.3, I think. It was the latest stable version 7.x for the Pi 2/3.


    I've tried removing and installing the inputstream plugins, etc. to no avail. I was very surprised to see a full version upgrade option from the GUI but I'm guessing that full version upgrades don't usually go flawlessly. If no one has any ideas I'll try doing a full reinstall and restore the configuration from backup. It seems especially strange that some streams will start to play according to the log but they won't display on screen - it can take up to 30 seconds for the focus to switch from the UI to the stream ... usually less but it has taken that long on more than one occasion (?!?).


    I should also mention that I have an advancedsettings.xml file as follows, which has helped with buffering issues in the past but shouldn't affect this issue:
    <advancedsettings>
    <network>
    <cachemembuffersize>52428800</cachemembuffersize>
    <readbufferfactor>2.0</readbufferfactor>
    </network>
    </advancedsettings>


    Regards,


    - Phil