LibreELEC TBS 5520 SE

  • I've bought the TBS 5520 SE USB box (without remote control) and set it to my librelec (various versions tested) but couldn't get it recognized...


    actual installation is the wonderfull 7.0.2.dvb_drivers by CvH / many thx for that built! I tried any "TBS driver" in the DVB Driver Configuration but without any luck / any change just took some time of thinking and a reboot - it does not give any feedback wich one is selected currently?


    but the receiver does appear on lsusb only:


    of course I "dmesg|paste"d > QCWY but as far as I understand the USB isn't recon' at all! right? It's the same with any TBS Driver so far! :huh:


    Am I missing some steps? As mentioned this is a fresh install of LibreELEC-Generic.x86_64-7.0.2-dvb-drivers-1.66 without any changes than the DVB Driver Configuration? I tried LibreELEC-Generic.x86_64-8.0.1-digital_devices without success and I missed the DVB Drivers Configuration addon?
    May the USB box corrupt? Or does the "SE" in TBS 5520 SE make any difference.


    Any help appreciated - CvH ???

  • meanwhile I changed to 8.0.1 without success... additionally I tried TBS open source drivers and crazycats media build (containing tbs5521) but I cannot load the custom firmware because of missing module... dvb-usb-tbs5520 exists but does not load the tbs 5520 se...


    verbose lsusb told me

  • dvb-usb-tbs5520se.


    Driver not tested, so if you have some PC with regular linux (desktop or server) and can provide remote access ... I can checkmand debug driver for 5520se.


  • dvb-usb-tbs5520se.


    where do I get this driver? could not find it in compiled media_build...
    is it fair just to copy the ko beside dvb-usb-tbs5520.ko?


    sorry i'm not able to give remote access through current firewall settings...


  • wonderful! thank you!!
    compiled on my Ubuntu machine, installed it's drivers and rebooted!


    whoooop whoop I'm excited!! BUT obviously my Ubuntu (kernel 4.4.0.72) isn't the LE... I cannot test it any further
    sooo, how do I get this wonderful driver to my LE installation (currently 8.0.1 with kernel 4.9.x)??

    Edited once, last by garglkarg ().

  • I have this device and am trying compile driver from github for armhf platform - no success. Did someone successfully compile a functional driver?


  • Did someone successfully compile a functional driver?


    yes I did! but on my generic intel pc with Ubuntu installed. got the usb box running with compiled crazycat drivers - it overrides my Nvidia and it had some crashes in the beginning but everything works fine now. have my tvheadend up and kore running.
    I'm very pleased and satisfied!

  • Help to understand the kernel failure when connecting the tuner.

  • Sorry to bump old thread. Was considering to buy a TBS 5520 SE. Anyone can tell me if now it works with Libreelec? Wanted to know also if in Tvheadend there are two tuners (dvb-t and dvb-s) that are switched on the fly, or if we have to switch by sotftware the tuners before using them (as in windows).

    Thnak you,

    sdf

  • Was considering to buy a TBS 5520 SE. Anyone can tell me if now it works with Libreelec?

    this is no LibreELEC problem more a general driver problem - as long none reports something back you can expect it as NOT working

  • saw that was supported with open source drivers in the tbs forum.

    If anyone has bought it and can report back

    Thank you CvH,

    sdf