7.0.3 -> 8.0.1 NUC loses its mind re:EDID with AVR in the mix

  • Greetings. I'm running the following, wired as such:


    Intel NUC NUC5CPYH (4K but 1080p preferred, latest firmware)
    |
    Pioneer VSX-1022-K receiver (1080p, latest firmware)
    |
    Hisense 50H8C (4K, latest firmware)


    LE 7.0.3 installer: no issue
    LE 7.0.3 operation: no issue


    LE 8.0.1 installer: only the top-left quarter of the installer is visible
    LE 8.0.1 operation (after bypassing receiver for installation): max resolution is 576p/50Hz, and only a few other resolutions are available


    I've been able to find two workarounds so far:


    Workaround A.)
    Connect the NUC directly to the TV (which works great), pull the EDID info, and follow the wiki for using a custom EDID (Custom EDID - LibreELEC) after bring the receiver back into the mix. This seems to work well enough, but I can only pass through very basic AC3 or DTS, and lose most of the capabilities of my receiver.


    Workaround B.)
    Grab all the details of a working modeline at 1080p, and with the receiver in the mix, use xrandr to add the known-good modeline and then activate it. One of many downsides here is that I need to both set up the modeline and then choose it from the UI after each boot.


    Is workaround B preferred, and is the right way to go about using that with a custom xorg.conf? Is there a minimal xorg.conf file I can use for just a custom modeline?


    I had to revert the system to 7.0.3 for family use, so I don't have 8.0.1 logs available at present. I do have the Hisense EDID file as obtained from 8.0.1, and I can pull any info from the running 7.0.3 installation.


    Thanks.

  • You are not alone! This issue seems very similar to my experience:
    thread-5912.html


    The custom xorg.conf seems to be the easiest way for a temporary workaround from ,y experience.


    There seems to be quite a few HDMI related issues with all Intel NUC boxes and LE. Hopefully a permanent fix will be found soon!

  • That's an odd statement considering the issue is only present when he adds the AVR, and it works fine if he adds the EDID. Obviously the receiver is at fault for not properly passing through the EDID. I have an Intel NUC which works great with my Denon AVR.


    Ask Pioneer for a fix! ;)


    EDIT: Don't know how I missed the fact that it worked in 7.0.x and not in 8.0.x :P The relevant difference would probably be the x.org and xf86-video-intel version. Even though it worked in older versions it could still be the AVR that was at fault and the older drivers just worked differently.


    Try creating /storage/.config/xorg.conf like this:

    Code
    Section "Device"
      Identifier  "Intel Graphics"
      Driver      "modesetting"
    EndSection

    Edited once, last by escalade ().

  • Yeah, I'm sure the receiver could be improved, but given its 5-year age, I'm not expecting much in the way of firmware support from Pioneer at this point. It's had a pretty good (and compatible) life so far.


    I'll try out the modesetting driver.

  • No luck with just the modesetting driver, looks like I'll need to build up a bigger xorg.conf.


    I did have luck adding the Hisense EDID to the installer flash drive, so at least I don't need to swap cables to do the 8.0.1 install anymore. :D That is some tiny curses font at 4K.

    Edited once, last by Cabal ().

  • I had no luck with multiple iterations of an xorg.conf, so I ended up going with an autostart.sh:

    Bash
    #!/bin/sh
    (
    sleep 6
    xrandr --newmode 1920x1080 148.5 1920 2008 2052 2200 1080 1084 1089 1125 \
    +HSync +VSync
    xrandr --addmode HDMI2 1920x1080
    xrandr --output HDMI2 --mode 1920x1080
    ) &


    Any suggestions on xorg.conf syntax would be great.


    I also set up the Hisense's edid.cpio in /flash (for a usable boot screen), and the Pioneer's edid.bin in .config/firmware/edid (in case it reboots with the TV/AVR off).


    Not pretty, but everything works again (mostly).