LibreELEC on berryboot

  • I get LibreELEC_7.0.2 not convert to squashfs to update it, since in berryboot only appears the version 7.0.1
    I tried to change it but only get a picture of 4.1kb
    I've also tried downloading the .tar of noobs, remove it and pass it to .img but when I start with berryboot tells me it's not squashfs
    Any other way?
    Can anyone give it to me?
    Thank you

    Adding your own custom operating systems to the menu
    How to Multi-Boot Your Raspberry Pi with BerryBoot

    Edited once, last by jose383 ().

    • Official Post

    To keep things simple: Either you install LibreELEC onto your RPi device directly (without the BerryBoot system), or you need to wait until Berryboot offers the next LibreELEC version.

  • Ok, I think that Berryboot isn't a crap as others said.
    I'll tell you how to update LibreELEC to the latest version.
    Acording to Berryboot code, already working with OpenELEC, you have to copy SYSTEM file from inside the update .tar into /storage/.update.
    Then, at next reboot, Berryboot will find this image and replace its own with this new one before mounting it and booting.
    The result is a new version of LibreELEC with the aplied changes that you already made to the previous versions.
    This can be done because LibreELEC as well as it predecesor OpenELEC is distributed on a squashfs archive, the same that Berryboot relies on.
    The only flaw I found to this method is that you can't apply this kind of update to a restored backup of LibreELEC because when you do it, the main image becomes the restored backup and includes LibreELEC with all changed you made to your system. So, if after restoring a backup you update LibreELEC with this method you will be overwriting your customizations with a blank LibreELEC image and will lose your config.
    I hope you understand my poor english writing. Sorry for that.

  • Hi

    the easiest way to update LibreElec If you use Berryboot is:

    1) download the package LibreElec but with suffix *.tar (for example here FTP)

    2) from .tar exporting directory \target and copy the contents to directory Update in your LibreElec.

    3) reboot LibreElec

    4) that is all

  • To keep things simple: Either you install LibreELEC onto your RPi device directly (without the BerryBoot system), or you need to wait until Berryboot offers the next LibreELEC version.


    I used to use BerryBoot for LE and Retroarch, but frankly Micro SD cards have gotten seriously cheap these days I'm happy to just swap the card when I need to change between the two. BerryBoot doesn't save that much time or effort, particularly if you run an OS that doesn't offer a reboot function.

    Even the cards with UHS ratings from reputable top end manufacturers (SanDisk, Samsung, etc.) are very reasonably priced now. -- 128 GB for approx 16 £/€ :) We can thank competition for that.


    Adam Reece

  • I have a same problem with my Rasp 3B+.

    1 - I install Berryboot and Distro Raspian Debian

    2 - I upload my Retropie.img (converted with squashfs procedure) and it work good.

    3 - I have a big problem to convert my images OpenElec or LibreElec, becouse these images don't have /etc/* directory. So these Instructions to berryboot format conversion don't work: $ sudo mount /dev/mapper/loop0p2 /mnt

    $ sudo sed -i 's/^\/dev\/mmcblk/#\0/g' /mnt/etc/fstab
    $ sudo sed -i 's/^PARTUUID/#\0/g' /mnt/etc/fstab
    $ sudo rm -f /mnt/etc/console-setup/cached_UTF-8_del.kmap.gz
    $ sudo rm -f /mnt/etc/systemd/system/
    $ sudo rm -f /mnt/etc/systemd/system/
    $ sudo rm -f /mnt/etc/rc3.d/S01resize2fs_once

    After Squashfs procedure and I try to upload adn start Libreelec image on Berryboot but I obtain an error squashfs like this: "directory etc/system.d don't found"... i don't remember correct error.

    So... I try to used a LibreElec image downloaded from this site:

    Downloads Berryboot Images ⇢ Berryboot OS Images

    The image works on Berryboot, but during start configuration (like language, ssh enable/samba enable) LE blocked...

    Any idea?

  • Don't use BerryBoot, it has been known to break LibreELEC for a long time. If you want a multiboot setup use NOOBS or PINN.

    so long,


  • NOOBs (and I think also PINN) support the installation of custom/locally created images.

    I used that successfully when testing RPi4 noobs installation of LE about half a year ago but can't remember the details. IIRC you need a tar file for each partition or sth like that - just check the NOOBs docs or the thread on the RPi forum.

    so long,