Network issues with v8.0.0.1 on Pi Zero W

  • HW
    RASPBERRY PI ZERO W


    LibreELEC version
    LibreELEC (Krypton) v8.0.0.1 for Pi Zero W (Kodi 1.7.1-RC1 Mar 4 2017)
    LibreELEC (Krypton) v8.0.0.1 for Pi Zero W – LibreELEC


    Issue
    Cannot find any SMB shared in my network


    Complete steps

    • Install LibreELEC
    • Boot, leave as default any configuration and connect to the wireless network
    • Go to Settings -> File manager -> Add source -> Browse -> Windows network (SMB)
    • Wait the loader
    • No shared network found


    I'm pretty sure that my samba share is right set. I can access from any other devices in my home, including an android tablet with the latest android Krypton version of Kodi (1.7.0 Feb 1 2017)


    Internet connection is working well, I can find and install plugins from the net.
    [hr]
    UPDATE: another significant issue, i cannot login into libreelec via ssh, although the ssh service is enabled


    Any ideas?

    Edited once, last by shady90 ().

  • It s happening to me on windows 10....can,t see my 2 openelec and libreelec devices from kodi...have to add manually and it works fine...so it s not an issue of network or smb settings..
    [hr]
    I m assuming that you enabled samba on libreelec?

    Edited once, last by Mario77 ().


  • It s happening to me on windows 10....can,t see my 2 openelec and libreelec devices from kodi...have to add manually and it works fine...so it s not an issue of network or smb settings..
    [hr]
    I m assuming that you enabled samba on libreelec?


    No, i hadn't enabled the samba service, because I don't need to share anything from my pi to other device. I need to read other devices shared folders.


    However, I tried to enable the service, reboot and retry, nothing change.


    I also tried manual add via IP and via hostname, it doesn't work.


    Mario77 do you have a pi zero w and the same libreelec version?

  • I dont have a pi zero..but I had that issue few times..and by editing sources.xml manually always solved the issue
    [hr]
    Also share the shared folder with everyone
    [hr]
    And I m not using krypton anymore...too many issues for my need.. i m sticking to libreelec 7.0.3 on my rpi and openelec on my downloading server...and upnp with a windows 10 pc
    [hr]
    Also if you need to wake up the shared folder machine with your zero always use ip for smb not name as it doesnt work
    [hr]


    I dont have a pi zero..but I had that issue few times..and by editing sources.xml manually always solved the issue
    [hr]
    Sorry missed your post...if when you add source manually it doesn't work still...it might be an issue with the shared machine....either nothing is shared or not shared properly...make sure you go to properties -security and add everyone to your shared folder


    [hr]


    In file manager add source instead of clicking on browse click on none and enter smb://192.168.0.9/ see what happens

    Edited once, last by Mario77 ().