(17.0-ALPHA4 Git:e31bee7), no render on play movie, screen stays black (cause found)

  • On some MKV files the following happens.


    Either on of the 2 things, situation 2 and 3:


    1: PLay movie OK, exit Movie OK
    2: Play movie, black screen, exit not possible
    3: Play movie OK, exit black, screen exit not possible.


    With the iOS remote apps starting a movie that always plays, exits the weird behavour when in black screen mode


    I have an full debug log of situation 2:



    idioteque - Pastebin.com


    Update 2016-06-30.


    It's not the mkv itself. Sometimes, playing the file upto 3-5x times it plays ok.


    it may be related to the swicht refreshrate. in combination with the pause to switch which also is not working. It


    Any more info can be provided. Perhaps its the type or codec type of the mkv, not sure. The same mkv works some times, some times it does not. it seems not to happen when fps= refreshrate and no switch is required.


    it would appear that if the switch takes too long and no canvas is available to render to the screen stays black even if the switch eventually finished. This could also explain why it previously worked, because the pause of 2,5 second still worked.

    Edited once, last by idioteque ().


  • Please try Milhouse build with kernel 4.6.3


    I had radom black screen after movie stop until 4.6.3

  • LE v7.90.001/002 use the KMS video driver which behaves badly on older Intel GPUs. In v7.90.003 (out shortly) and current Milhouse builds we reverted back to the Intel driver which should solve issues like this.

  • tested with 003 and the issue is still here.


    set display to 60hz


    pla moy which is 24hz, switch to referesh is on and


    after starting the movie the screen stays black.


    Do you need any further info or logs ?


  • tested with 004 alpha and issue is still here.


    any thoughts ?

  • Has anyone been able to make any progress on this? Plenty of threads seem to be addressing this issue and I have the exact same problem. Jarvis is literally unusable for me because of kernel issues (i.e. black screen as above).


    Going back to 6.0.3 solves everything but I would love to upgrade. I'd give Milhouse builds a try but aren't they Pi-only?


    Any help would be appreciated.

  • just an update.


    OpenElec 7.0.0 and LibreElec 7.95.10 both have this issue.


    OpenElec 5.08 does not exibit this issue.


    23,97fps files played on my panasonic 24Hz TV exibit this issue.


    I'm using LE/OE so am unable to run an alpha version