rutorrent can't connect

  • LibreELEC version 6.90.004 7.0
    Raspberry Pi 3


    rtorrent is working in "detach"


    Code
    1. [02.04.2016 13:27:57] WebUI started.
    2. [02.04.2016 13:27:57] No connection to rTorrent. Check if it is really running. Check $scgi_port and $scgi_host settings in config.php and scgi_port in rTorrent configuration file.


    Quote


    Seems there is an issue with the current build. It doesn't setup scgi or xmlrpc properly. I have downloaded the previous build and coppied lib/libxmlrpc* from old into my working dir and this has fixed it here. Can someone fix/rollback these libraries in the repo?

    Edited once, last by Soringo ().

  • Should've I posted it in a different subforum?


    If a log is needed, please, let me know how I can get it.


    Best regards

  • Fix for me was:

    Code
    1. ln -s /usr/lib/libssl.so /storage/.kodi/addons/service.downloadmanager.rTorrent/lib/libssl.so.32
    2. ln -s /usr/lib/libcrypto.so /storage/.kodi/addons/service.downloadmanager.rTorrent/lib/libcrypto.so.32


    Note the .32 there, not .35 as stated in OE forum.

  • For now I've just downgraded back to LE 7.90.008 ALPHA
    .009 introduced LibreSSL v2.4.4 that broke everything.

  • After update libreelec from 8 to 8.0.1 rutorrent cant connect
    [01.05.2017 00:33:58] WebUI started.
    [01.05.2017 00:33:58] Bad response from server: (0 [error,getplugins])
    [01.05.2017 00:33:58] Bad response from server: (0 [error,getuisettings])


    please help


    if i run rtorrent via ssh
    Error in option file: ~/.rtorrent.rc:14: Could not prepare socket for listening: Address already in use

    Edited once, last by Lubos ().