[8.2.2.3] LibreELEC 8.2 for S912

  • kszaq, you are a legend! Thanks so much for your hard work! I have sent "coffee" money. It really sucks that the chipset developers leave these things to independent devs such as yourself, to fight an uphill battle.


    Cheers,
    Ken

  • Thank you Ken.


    Unfortunately as long as we have to rely on libhybris these builds will stay experimental. I am still fighting with resolution switching, can't make it work properly. :(

  • I noticed that AMLogic updated their root build today, to include the S912 chipset:
    buildroot-openlinux-20161230.tar.gz
    buildroot-2016-12-30 - Amlogic openlinux
    Supported builds:1. mesongxb_p200_release2. mesongxb_p200_32_release3. mesongxb_p201_release4. mesongxb_p201_32_release5. mesongxl_p212_release6. mesongxl_p212_32_release7. mesongxl_p212_4358_32_release8. mesongxl_p230_release9. mesongxl_p230_32_release10. mesongxm_q200_release11. mesongxm_q200_32_release12. meson8_k200_release13. meson8_k200b_release14. meson8b_m200_release15. meson8b_m201_release16. meson8m2_n200_release
    Hopefully this will help. :-)
    [hr]
    kszaq You are most welcome! The fact that you were able to even make this boot with S912 is brilliant; libhyris or no. :-)

    Edited once, last by kenmills ().


  • Thank you Ken.


    Unfortunately as long as we have to rely on libhybris these builds will stay experimental. I am still fighting with resolution switching, can't make it work properly. :(


    What if you make a 1080p and a 2160p version then no switching needed?
    I would be happy with a 2160p version, never switched to anything else.

    RPI3 1GB, Z4 RK3368 1GB, MINI MX-G 2GB, Mini M8S II 2GB (coreelec.org 9.0.1), H96 Pro 3GB (coreelec.org 9.0.1), ODORID N2 2GB (coreelec.org 9.0.1), H/K AVR 161S, LG 60SJ810V
    pel.hu

  • I have only 1080p TV, can't test this. ;)


    If you want to test 2160p, please try setting it in Android and then reboot to LE.

  • Great work! I got my KM8 PRO 2/16 back from storage to test and all the basics are working by not providing a dtb file from SD:


    Accelerated video playback
    Audio pass-through
    Bluetooth
    Remote
    Gbit ethernet
    WiFi
    HDR (no Dolby Vision though)
    Smooth GUI most of the time


    I have only 1080p TV, can't test this. ;)


    If you want to test 2160p, please try setting it in Android and then reboot to LE.


    This also works :D , or by setting mode manually or using /sys/class/display/mode but in some situations the output will glitch out and only the top half of the screen is filled.


    Only thing left are the stability issues you mentioned, some graphic glitches and some performance drops.

    Edited once, last by meijjaa ().


  • I have only 1080p TV, can't test this. ;)


    If you want to test 2160p, please try setting it in Android and then reboot to LE.


    Thank you, it's working, I mean the GUI settings says 3840x2160 now (not really 4k, as we know the 4k GUI patch is there)
    If I start a FHD movie then only the upper half of the screen is visible and hangs up when I try to stop.
    4k plays full screen.

    RPI3 1GB, Z4 RK3368 1GB, MINI MX-G 2GB, Mini M8S II 2GB (coreelec.org 9.0.1), H96 Pro 3GB (coreelec.org 9.0.1), ODORID N2 2GB (coreelec.org 9.0.1), H/K AVR 161S, LG 60SJ810V
    pel.hu

    Edited once, last by Pelican ().

  • Hello,


    I'm new on this forum and I discover your post with interest.


    I've tested your LE on my Chinese box (egoiggo s12 pro) ans it works almost like a charm.


    Remote : ok
    Audio passtrought : ok (tested with Dolby digital, dts, dts hd)
    Gigabit ethernet : ok


    Thank you a lot for your great job ;)

  • New build in OP. Only minor improvements, we're still very limited by having to use libhybris for OpenGL.

  • Thank you!

    RPI3 1GB, Z4 RK3368 1GB, MINI MX-G 2GB, Mini M8S II 2GB (coreelec.org 9.0.1), H96 Pro 3GB (coreelec.org 9.0.1), ODORID N2 2GB (coreelec.org 9.0.1), H/K AVR 161S, LG 60SJ810V
    pel.hu

  • CPU temperature works! :)
    Everything works fine and smooth except the restarts...


    How to install libreelec on Tanix Tx8 Amlogic S912 RAM 2g. Thank you


    Read the first post!

    RPI3 1GB, Z4 RK3368 1GB, MINI MX-G 2GB, Mini M8S II 2GB (coreelec.org 9.0.1), H96 Pro 3GB (coreelec.org 9.0.1), ODORID N2 2GB (coreelec.org 9.0.1), H/K AVR 161S, LG 60SJ810V
    pel.hu

    Edited once, last by Pelican ().


  • CPU temperature works! :)



    Read the first post!


    thank you. More details please
    [hr]

    thank you. More details please


    I tried all the methods and it does not work
    [hr]


    CPU temperature works! :)



    Read the first post!



    thank you. More details please
    [hr]
    thank you. More details please.
    I tried all the methods and it does not work

    Edited once, last by yadvb ().

  • You haven't given any details what and how you tried.
    Have you tried with the default dtb? Without any dtb? with one of the provided dtb? with your own dtb? from sd? from usb?
    Without that info I can repeat here the same what is in the OP.


    (And you are able to edit your post... you don't need to quote me 3 times...)

    RPI3 1GB, Z4 RK3368 1GB, MINI MX-G 2GB, Mini M8S II 2GB (coreelec.org 9.0.1), H96 Pro 3GB (coreelec.org 9.0.1), ODORID N2 2GB (coreelec.org 9.0.1), H/K AVR 161S, LG 60SJ810V
    pel.hu

    Edited once, last by Pelican ().

  • @yadvb
    In a single post you're saying "thank you. More details please" four times.
    But you did not provide any details yourself on what you have tried.


    I suggest you read this tutorial carefully then retry installing.

    Edited once, last by vitorp07 ().


  • @yadvb
    In a single post you're saying "thank you. More details please" four times.
    But you did not provide any details yourself on what you have tried.


    I suggest you read this tutorial carefully then retry installing.


    I download the image of the link Index of /s912/8.0-alpha-preview2/
    I burn it on SDCARD with LibreELEC.USB-
    SD.Creator.Win32


    I followed the method


    toothpick method: disconnect the power supply, insert card/drive, push reset button and connect the power while holding the button. Wait until LibreELEC logo appears and release the button.


    The box remains on the Amlogic S912 logo

    Edited once, last by yadvb ().


  • So you used the default dtb.
    Try to delete dtb.img from the card.
    Try to use another dtb.

    RPI3 1GB, Z4 RK3368 1GB, MINI MX-G 2GB, Mini M8S II 2GB (coreelec.org 9.0.1), H96 Pro 3GB (coreelec.org 9.0.1), ODORID N2 2GB (coreelec.org 9.0.1), H/K AVR 161S, LG 60SJ810V
    pel.hu

    Edited once, last by Pelican ().