hide mouse pointer and boot / shutdown messages

  • I'm trying to streamline/customize the entire boot up and shut down process on my htpc using LibreELEC.


    Could anyone tell me how to completely hide the mouse pointer on boot up?
    I can see the mouse pointer in the middle of the screen and it stays there until kodi loads and then hides itself.
    I would like to never see it since I don't use a mouse.


    Also is there anyway to hide the messages that show up as I boot and shutdown from LibreELEC?


    Thanks!

  • For the messages you will have to edit your "extlinux.conf" file in the folder "flash", adding "morequiet" in the APPEND line like so;

    Code
    DEFAULT linux
    PROMPT 0
     
    LABEL linux
     KERNEL /KERNEL
     APPEND boot=LABEL=System  morequiet disk=LABEL=Storage  quiet


    SSH and send this command;

    Code
    mount -o remount,rw /flash


    make the changes to the file, then SSH and send this command;

    Code
    mount -o remount,ro /flash


    reboot

    Edited once, last by vitorp07 ().

  • thanks for the info @vitorp07


    on my Intel build, the file I edited was /flash/syslinux.cfg - i could not find extlinux.conf in /flash


    it contained the same text as you mentioned so i edited it.


    It appears there's no boot messages any more from LE :D but the when shutting down i'm still seeing messages.

  • Place it at the end of the line after "quiet" like this;

    Code
    APPEND boot=LABEL=System  morequiet disk=LABEL=Storage  quiet systemd.show_status=0


    This should block you from seeing any systemd messages.

    Edited once, last by vitorp07 ().

  • I've managed to achieve this on rpi 4 by adding the above to cmdline.txt in /flash so it looks like this:

    Code
    boot=UUID=xxxx-xxxx morequiet disk=UUID=xxxxxxxx-xxxxx-xxxx-xxxxxxx quiet systemd.show_status=0

    It works fine apart from I'm still seeing "waiting for network...." even though this option is disabled in LE settings. Enabling it just results in another line with the same. Any idea how I can suppress this as well?