WiFi issues on RPI 3 poor speed and latency SOLUTION!

  • Had issues of some very slow wifi speeds. When connected on Ethernet streaming was superior to wifi.


    Turned out to be powersaving on the wlan card that is disturbing.


    Disable this by installing iw from libre elec "network tools" plugin package including iw.


    Add the following line in /storage/.config/autostart.sh/storage/.kodi/addons/virtual.network-tools/bin/iw wlan0 set power_save off
    Check afterwards with iwconfig that it is disabled.


    1. Logonto device with ssh
    ssh [email protected]<yourip>
    password:libreelec
    2. issue

    Code
    1. iwconfig


    and see it wlan0 has Power Management: on
    3.

    Code
    1. nano /storage/.config/autostart.sh



    4. Add this lite to the created file

    Code
    1. /storage/.kodi/addons/virtual.network-tools/bin/iw wlan0 set power_save off


    5.

    Code
    1. reboot


    6. SSH in again and issue iwconfig should look something like
    eth0 no wireless extensions.
    lo no wireless extensions.
    wlan0 IEEE 802.11 ESSID:"NET"
    Mode:Managed Frequency:2.447 GHz
    Access Point: 2C:20:38:CE:8B:15
    Bit Rate=65 Mb/s Tx-Power=31 dBm
    Retry short limit:7 RTS thr:off
    Fragment thr:off Encryption key:off
    Power Management:off
    Link Quality=54/70 Signal level=-56 dBm
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:0
    Missed beacon:0


    Happy WiFi!

  • is this with the built-in wifi or a third-party USB device?


    reason for asking is that we already disable power management in the kernel for the built-in device.

  • This is for the built in. Mine was still on powersaving according to iw after installing fresh 7.95. The device now works much better.

    Edited once, last by Sodan ().

  • On my Raspi2 I got

  • If you just accept the fact that the built-in WiFi for the RPi3 just isn't exactly the strongest (I mean, have you seen the size of the antenna?), then it's easy to work around it either by another USB WiFi stick, or by making sure you have a plastic case and keeping it as close to the router as possible, and preferably within line of sight.

  • Well I can accept that, but after turning powersave off and locking my router not to use other channels than 1-11 it works flawless.


    When router selects 12 or higher the Pi cant se it

  • Code
    1. echo "options cfg80211 ieee80211_regdom=DE" > /storage/.config/wifi.conf
    2. reboot


    ^^ If you set wireless regulatory domain to somewhere that supports channels 12/13 they will appear. It defaults to the General world regdomain though, which does not allow them.

  • Code
    1. echo "options cfg80211 ieee80211_regdom=DE" > /storage/.config/wifi.conf
    2. reboot


    ^^ If you set wireless regulatory domain to somewhere that supports channels 12/13 they will appear. It defaults to the General world regdomain though, which does not allow them.


    Ok will check. The gui is not handling this i pressume from any regional settings there? I noted this same behaviour with Rasbian Pixel too

  • It's something we might add in 9.0 but it will remain a manual process as display settings don't always map to geographic location, e.g. I'm English so want UK formatting on things, but live somewhere else which would require a non-UK regdomain. I believe Raspbian has a config option for wireless in the noobs initial set-up wizard, but again it's a manual process.

  • this weekend i was "playing" with few rpi3´s connected to my Mikrotik router.

    I used libreelec 8.2.3.

    I could not get correct stream from tvheadend, with router behind doors...

    I was playing with settings in winbox with wireless radio configuration. Nothing helped, just small improvements. I was sitting next to raspberry with notebook, or phone and it worked fine, but not in my pi´s.

    After some time i found these comments... I disabled power management via iwconfig, as described above. It helped much more than other setting i tried to change!

    But it was still not reliable... I have some experience with mikrotik routers, but not with streaming HD channells. Then i checked signal, it was -68dbm, so i did not see a reason why it would not work... Then i removed rpi from behind tv, and put it into front... With signal strength around -60dbm it was finally fluent. It is just on the edge, but working.

  • Had issues of some very slow wifi speeds. When connected on Ethernet streaming was superior to wifi.


    Turned out to be powersaving on the wlan card that is disturbing.


    <<SNIP SNIP SNIP SNIP instructions - thanks for your help SNIP SNIP >>



    Sad times......



    Firstly chewitt you should be aware, this is broken? (?)


    LibreELEC (community): nightly-20190829-bd4ba9f (RPi2.arm)

    LibreElecPi:~ # iwconfig

    wlan0 IEEE 802.11 ESSID:off/any

    Mode:Managed Access Point: Not-Associated Tx-Power=31 dBm

    Retry short limit:7 RTS thr:off Fragment thr:off

    Encryption key:off

    Power Management:on



    I am using a very new nightly version, to test some things broken for me.

    Power management I have never played with before, and it's defaulting to ON ? :/




    If I run this command it successfully turns off power management.

    "/storage/.kodi/addons/virtual.network-tools/bin/iw wlan0 set power_save off"


    However, when I add it to autostart.sh it doesn't execute at start ? Anyone know why?

    Perhaps this might fix my issue here.

    Rebooting Pi, with ETH0 connected, stops Wifi connecting next time, is Wifi reliable?



  • I have the same problem.

    I added the command in autostart.sh, and the first time Power Management changed it to off. however after turning the rasp off and on, it goes back to on, even with the edited file.


    I try to run some videos stored on a NAS, on the same network. the NAS is on a giethernet router and the rpi on the wifi.