Unable to build - lirc patches won't apply

  • Hello,


    I'm trying to build LibreELEC for the RPi 2 and created a Docker-Image for this purpose. My problem is, when it comes to install "lirc" the build fails while applying the patches.

    Code
    1. APPLY PATCH (common)   /LibreELEC.tv/packages/sysutils/lirc/patches/lirc-0001-always-enable-uinput.patch
    2. patching file configure.ac
    3. Hunk #1 FAILED at 33.
    4. 1 out of 1 hunk FAILED -- saving rejects to file configure.ac.rej
    5. Makefile:12: recipe for target 'image' failed
    6. make: *** [image] Error 1
    7. rm -rf build.*/* build.*/.stamps


    Just for completeness - this is the Dockerfile, which I use to build the Image:


    And this is the simple build_script.sh


    Maybe someone knows what I'm doing wrong and can point out my mistake :D


    Thanks
    S.

  • Lirc sources were silently updated with same version number. And now patches are not compatible anymore. Will be fixed.


    In the mean time you can change URL in file packages/sysutils/lirc/package.mk to

    Code
    1. PKG_URL="https://sourceforge.net/projects/lirc/files/LIRC/$PKG_VERSION/$PKG_NAME-$PKG_VERSION.tar.bz2"

    Better support for Amlogic devices: use CoreELEC

    Blu-ray Disc Java menus support - forum thread, Github

    my lamp addon (unofficial/community with limited support)
    my touchscreen support and instructions by Grruhn (now touchscreen addon exists in repository)

    Edited once, last by vpeter ().

  • Thanks, looks to be a packaging cock up by lirc - the version of the 0.9.4c package now includes several post-0.9.4c commits which break the build. Obviously, these extra commits should not have been added to the 0.9.4c package.


    I've added PR1252 which will download the 0.9.4c package from a different url. This new URL is serving the original 0.9.4c package without the extra commits.


    Either manually change the URL in your local repo and restart the build, or wait until PR1252 is merged.