JustBoom DAC Zero

  • I had a few minutes to play with the new build, 7.95.2. I see the same issue with the screen blanking after idle time.

    What I found suspicious was the short duration of time. I timed it, and it was almost exactly a minute. Under the audio settings is the "Keep audio device alive" setting, which defaults to one minute. I changed it to two minutes and tested again. The time to blank the screen moved to two minutes. When set to always, I haven't seen the issue occur, and I've been running it for a good while now. The screen does go dim, as expected, and can be 'woken' from the dim screen, as expected.

    Thanks again!

    Interesting so it is definitely a software issue then somewhere - what happens if instead of dtoverlay=justboom-dac you put in dtoverlay=hifiberry-dac ? Does the same issue occur?

    what happens if you try and load some audio over the command line once the screen goes blank after keep alive?

    @ Hias - will test that sure!

    Only thing is though - why would that I2S thing effect the Pi Zero but not the Pi B+ or any of the others?

  • @ Hias - will test that sure!

    Only thing is though - why would that I2S thing effect the Pi Zero but not the Pi B+ or any of the others?

    Phil added that I2S thingy (actually changing the DMA priorities) because under some conditions the I2S stream would get out of sync and result in garbage output (mostly noise or so). That only happened on the RPi3 and only with the downstream DMA code but not the upstream one - so that was very mysterious as well (at least to me).

    I might be barking up the wrong tree, but the mysteriousness of the RPi0 issue remembered me of the other mysterious one :)

    BTW: Another interesting test would be to check if you get the same issues on Raspbian if you use kernel 4.9 (sudo BRANCH=next rpi-update).

    so long,


  • OK we have tried the 7.0.3 you've suggested and Kodi gets stuck at startup on the splash screen with or without our card on the Pi Zero.
    Not much else to do here as I don't even get to SSH to it.

  • Something really odd is going on with the RPi0. I haven't soldered on the GPIO connector so I did a quick test with dtoverlay=rpi-dac (this will work even without a soundcard installed) and could reproduce the issue with the 7.95.2 build:

    When selecting the ALSA soundcard in settings my monitor went blank for a very short time, then came back immediately. GUI and ssh were still working.

    Then (maybe when the sounddevice was closed after the 1min idle time, didn't time it) the screen went completely black.

    Still, ssh working fine and nothing in dmesg or kodi log (didn't have kodi debug logging active though).

    At this point I tried running "tvservice -s" and it just locked up. Same with "vcdbg log msg". Seems like the GPU has crashed.

    I thought maybe it had something to do with GPU resampling so rebooted and disabled it in audio settings. Then, when changing audio device from ALSA to HDMI the screen went black and the RPi crashed (ssh down).

    Pulled the plug, kodi came up with ALSA audio and software resampling. Changing audio to HDMI crashed the RPi0 again.

    so long,


  • HiassofT are you able to test my latest #0211 RPi build (based on 4.9.9 with CONFIG_REGULATOR options for Cirrus Logic) with a Zero and the Just Boom?

    Edited once, last by milhouse ().

  • milhouse just tested with build 0211 and Justboom, same result (short blank screen when selecting audio device, crash when audio device was closed).

    Then I did another test with the Cirrus card instead of the Justboom, in this case it worked.

    Might sound odd, but an educated guess leads me to the conclusion something odd might be going with the kernel clock framework:

    Justboom DAC is configured as an I2S slave (RPi configures it's internal clocks), Cirrus is an I2S master (it drives the I2S clock and the RPi I2S driver skips changing the RPi clocks).

    Screen glitches when changing the RPi clocks have been reported before, and if the clocks are configured wrong (eg turned off completely) lockups can happen as well.

    Now to find out what exactly is happening, and why it only happens with the LE kernel not the official one. I guess we need Dom's and Phil's help.

    BTW: I could be wrong, this is just an educated guess.

    so long,


  • A very quick update before heading off to bed:

    I could reproduce the issues on Raspbian (kernel 4.9.9, kodi 17, probably any I2S soundcard that's an I2S slave) as well if I remove console=serial0 from cmdline.txt. Likewise adding that to the LE cmdline.txt prevents crashing.

    Just outputting sound via ALSA (eg running speaker-test -c 2 while kodi is setup for HDMI audio out) hasn't crashed so far.

    To crash the RPi0 we need no serial console (probably no serial device open at all) and kodi 17 switching audio out from HDMI to ALSA (short screen blank) and back to HDMI (hard crash).

    so long,


  • Sorry all, don't think we had notifications turned on so think we missed these messages!

    @Hias - thanks for all the testing and glad you got the Pi Zero we sent :-)

    With regards to moving forward, saw the update from Phil on GitHub.

    For the time being should we just use the console=serial0 fix, until such time as that official patch works its way though to LibreELEC?

  • If all goes well the fix should go into the 8.0 final release.

  • OK we've done some more testing today.

    Tested with both 7.0.3 and 7.95.2 as the base OS and reproduced the problem. Updated these with #213 and the problem is fixed.

    So all looks good :-)

  • tested this, the problem seems to have been sorted, thanks!

    Shame we didn't make it in 8.0.0. When do you think 8.0.1 will be out?

    Thanks for reporting back!

    I can't give an exact time schedule for the 8.0.1 release but it shouldn't be too far from now (could be 2 weeks or so, maybe longer, maybe shorter). We'd like to include kodi 17.1 and in the meantime we're collecting bug reports and trying to fix them :)

    so long,