rpi 3 video randomly stopping libreelec 7.0.2

  • Greetings,

    I am seeking some help interpreting my debug log files to determine why large video files randomly quit during playback.

    I was successfully using Openelec 6.0.3 on a Raspberry Pi3 for some time. I recently decided to upgrade to the latest stable version of Libreelec (7.0.2).

    I did this not as an upgrade, but a complete new (fresh) install.

    Since then, I have been having problems with movies being played back via smb (or nfs) - they randomly just stop and exit. There's no buffering indication or any indication for that matter. It's not always in the same place or the same frequency either.

    Being that it behaves normally with Openelec 6.0.3, I have mostly ruled out network problems because it’s the same Pi and adapter, just new Libreelec software. Also, live TV can play on for days without a hiccup, and most of the TV that we watch has far higher bitrates than the movies that 'stop' themselves.

    I can copy the whole movie to the RPI's SD card in 15 or so minutes over the same network without issue, and have even changed the buffer mode to '0' so as to buffer the playing movie on the SD card rather than RAM and it still quits. Although, playing the file locally (after copying to SD card over network via smb) works fine.

    I enabled debug mode and tried to peruse the log for info, but nothing stands out to me. I was hoping that somebody with better eyes could have a look and see if they spot abnormalities.

    On a side note, I also have a Raspberry Pi 2, and just today did the same upgrade to see if it would also exhibit the problem, and it does. Once I put Openelec 6.0.3 back on, everything behaved normally.

    Log located here -> view?usp=sharing (I can't paste to pastebin because of
    the size - '413 Request Entity Too Large' appears when I try)


    Thanks for looking.

  • It stops because of:

    Code
    1. 16:57:13 18168.835938 T:1697641376   ERROR: ffmpeg[652FF3A0]: [matroska,webm] Read error
    2. 16:57:51 18207.369141 T:1697641376   ERROR: ffmpeg[652FF3A0]: [matroska,webm] Read error
    3. 16:58:06 18222.324219 T:1622139808   ERROR: Read - Error( -1, 22, Invalid argument ) - Retrying
    4. 16:58:36 18252.328125 T:1622139808   ERROR: Read - Error( -1, 22, Invalid argument )


    Now that is some sort of network issue. What is the server you are using?
    The fact it works with OE 6.0.3 is surprising. Perhaps some difference in versions of libraries used?
    Might be worth trying with a Krypton LE build (7.90.010) just in case the issue is resolved.

  • Thanks for the reply popcornmix.


    I am using a Synology NAS (DS716+) as the storage device. I use an Edimax 7811UTC wireless dongle on 5GHz as the network interface.


    I went ahead and tried a 7.90.010 alpha release to the same effect (random stops). I am planning on snaking a cable to it over the weekend to see if it persists on a wired Ethernet connection as well.


    Interestingly enough I ran a smoke ping to the affected Pi(s) while playing the suspect files, and although the players did randomly stop, they never missed a ping reply.


    A couple questions...


    Being that this is a network issue, why doesn't it show 'buffering' and continue to try to play (like I've experienced in the past when I tried to use the on-board wireless under OE for high bitrate playback)?


    As previously mentioned, I also pushed the cache to the SD card and increased the read rate via advanced settings, but still have the issue. Via the onscreen display I can see the movie being buffered to about 2.75GB and then just appears to stop requesting data. The data then drops until it hits 0 and the movie stops (all the while replying to pings). Does that seem normal?


    I can also still transfer the file to the SD card rather quickly via samba without issue, hiccup or missed ping and play it reliably from there. Shouldn't buffering to the SD card essentially be the same behavior-wise?


    I apologize for my ignorance in these matters and for the possibly redundant questions. I would just like to understand this a little better so I can focus my troubleshooting time to be most effective.

  • Testing with an ethernet would be useful to narrow the issue down.
    In theory stream should stop to buffer and resume when buffer is full, but that assumes data is received without errors (but too slowly).


    Your log has read errors in which suggests the network connection dropped, which won't be recovered from.

  • I finally had some time to test this a bit more...


    With a wired Ethernet connection (or moving the wireless adapter to 2.4GHz), there's no problems. It appears to be the wireless adapter on 5GHz, under anything newer than OpenELEC 6.0.3 (even tried OE7.0 for S & Gs), including the latest LE 7.95.1 BETA that was just released.


    There must be a different driver in the newer Libre/Open-ELEC releases that just doesn't mix well with my adapter / access point.


    For now I can leave well enough alone, but as my 2.4GHz traffic increases, I will be looking for an alternative 5GHz solution.


    Anybody have a reliable 5GHz solution they can recommend?