[Not a Bug] RPi2 + Hifiberry Amp+: Soundcard missing in 7.90.010

  • Hi there,


    since 7.90.010 my soundcard doesn't appear in "aplay -l". In 7.90.009 everything is fine.


    Setup:
    RPi2 + Hifiberry Amp+


    Fresh installed version 7.0.2 with these additions in config.txt:

    Code
    1. dtoverlay=hifiberry-amp
    2. dtdebug=1



    Then updated to 7.90.008 (sound works) to 7.90.009 (sound works) to 7.90.010 (sound broken).


    Attached are output of "dmesg" and "vcdbg log msg".

    Files

    • 7.90.009.txt

      (30.65 kB, downloaded 123 times, last: )
    • 7.90.010.txt

      (30.05 kB, downloaded 118 times, last: )

    Edited once, last by debartand ().

  • Strange, can't find my hifiberry in LibreELEC-RPi2.arm-8.0-Milhouse-20170110210437-#0110-gf8d7242.
    Seems to be loaded:


    But is not listed in Settings -> System -> Audio -> Audio output device.


    uname -a:

    Code
    1. Linux LibreELEC 4.9.2 #1 SMP Tue Jan 10 21:05:42 GMT 2017 armv7l GNU/Linux


    config.txt:

    Edited once, last by ckarrie ().

  • A clean install from scratch did the trick.

    • Install 7.90.010
    • start Kodi
    • setup Kodi
    • upload latest updates from milhouse
    • append dtoverlay=hifiberry-amp to the lower end of config.txt
    • reboot
    • Setup Kodi audio options (44.1, 2 ch, hifiberry)
    • enjoy

    Edited once, last by ckarrie ().

  • With update to 7.95 RC3 I have only partial success.


    I can select the Hifiberry AMP driver and hear the system sound over the Hifiberry. However playing movies I have no sound with the Hifiberry, but only via HDMI output.


    Anybody with a similar observation or a hint where to look at?


    Thanks for the geat software to each contributer.


  • I can select the Hifiberry AMP driver and hear the system sound over the Hifiberry. However playing movies I have no sound with the Hifiberry, but only via HDMI output.


    Anybody with a similar observation or a hint where to look at?


    It sounds like you have enabled passthrough and it is set to HDMI. Try disabling it.

  • It sounds like you have enabled passthrough and it is set to HDMI. Try disabling it.


    thanks for the reply, but I guess thats not the case here.


    If I choose the Hifiberry Amp+ driver I hear the system sound from the Hifiberry speakers, but no sound from movies (neither Amp speakers, nor HDMI -> TV speakers).


    If I switch to the HDMI driver I can hear all sounds through the HDMI TV connection.

  • thanks for the reply, but I guess thats not the case here.


    If I choose the Hifiberry Amp+ driver I hear the system sound from the Hifiberry speakers, but no sound from movies (neither Amp speakers, nor HDMI -> TV speakers).


    If I switch to the HDMI driver I can hear all sounds through the HDMI TV connection.


    Set 44.1 MHz in Audio options

  • @popcornmix thanks for your help, here the relevant part of the log.20:20:25.560 T:1962148608 NOTICE: VideoPlayer: Opening: smb://POSTMASTER3/DVD/__Transfer/Die durch die Hölle gehen 1978/The.Deer.Hunter.100th.Anniversary.Edition.1978.German.DTS.DL.1080p.BluRay.x264-Pate.mkv
    20:20:25.560 T:1962148608 WARNING: CDVDMessageQueue(player)::Put MSGQ_NOT_INITIALIZED
    20:20:25.560 T:1242559392 NOTICE: Creating InputStream
    20:20:25.614 T:1242559392 NOTICE: Creating Demuxer
    20:20:25.741 T:1242559392 NOTICE: Opening stream: 0 source: 256
    20:20:25.741 T:1242559392 NOTICE: Creating video codec with codec id: 28
    20:20:25.750 T:1242559392 NOTICE: Creating video thread
    20:20:25.750 T:1242559392 NOTICE: Opening stream: 1 source: 256
    20:20:25.750 T:1242559392 NOTICE: Finding audio codec for: 86020
    20:20:25.751 T:1139803040 NOTICE: running thread: video_thread
    20:20:25.751 T:1242559392 NOTICE: Creating audio thread
    20:20:25.751 T:1437594528 NOTICE: running thread: CVideoPlayerAudio::Process()
    20:20:25.751 T:1242559392 NOTICE: Opening stream: 3 source: 256
    20:20:25.762 T:1437594528 NOTICE: Creating audio stream (codec id: 86020, channels: 2, sample rate: 48000, no pass-through)
    20:20:29.017 T:1584427936 ERROR: AddOnLog: Tvheadend HTSP Client: pvr.hts - unable to connect to 127.0.0.1:9982
    20:21:26.442 T:1276113824 ERROR: Previous line repeats 5 times.
    20:21:26.442 T:1276113824 WARNING: CSkinInfo: failed to load skin settings
    @ckarrie
    thats the solution, thank you

  • You probably have to set the settings level to advanced or higher to see it.

  • Got it. I was on expert level already, but I did not know that you have to select Output configuration to "fixed" before this submenu is shown. Thanks for the support.


  • A clean install from scratch did the trick.

    • Install 7.90.010
    • start Kodi
    • setup Kodi
    • upload latest updates from milhouse
    • append dtoverlay=hifiberry-amp to the lower end of config.txt
    • reboot
    • Setup Kodi audio options (44.1, 2 ch, hifiberry)
    • enjoy


    The "44.1" did it for me. So the default setting "optimized" isn't that optimal.

  • The "44.1" did it for me. So the default setting "optimized" isn't that optimal.


    This looks like a bug in the hifiberry-amp driver to me. If the card only works at 44.1kHz the driver should have setup a constraint for that. It's best to contact hifiberry about this, it'll probably be the same with Raspbian, OSMC, ... as well.


    so long,


    Hias

    Edited once, last by HiassofT ().