WT Play 2: NAND and SD - alpha 10: network disconnecting during playback (Solved)

  • Right,


    After being told that doing NAND installs voids the warranty (WTF?) I'm trying to get to the bottom of this issue several people are reporting (mainly on the wetek forums)
    (see here Play 2: network disconnecting (hardware failure ?) - WeTek Community Forum)
    LibreELEC (Krypton) v7.90.009 ALPHA - Network Crash - WeTek Community Forum



    In short, with the latest alpha versions (/8/9/10) when installing it on NAND NAND and SD and using a wired network connection, the network drops out after x amount of minutes playing a movie/file, with network drop out I mean I can't ping/ssh into the box any longer and whatever i'm playing/streaming via my NAS just freezes and stops after a few seconds.
    A quick way to get the network up and running again (apart from rebooting) is using libreelec settings and switching the wired network off and on.


    Kodi debug log doesn't give much detail other then CVideoPlayerAudio: process - stream stalled, so my suspicion lays with the ethernet driver on the OS side of things.
    dmesg and ifconfig just before a network disconnect dont say much, except a few dropped RX packets which is interesting but doesnt cause any issues like this.
    Thing to add, I noticed the network port link led (green one) doesn't come up, only the orange traffic led works, and no its not the cable or switch, I have a nuc and old wt play that work fine with the same cable/switch.


    Any help to further diagnose (and hopefully fix) the issue is welcome :)


    kodi debug log:
    18:24:49.314 T:548304584704 NOTICE: special://profile/ is mapped to: special:// - Pastebin.com

    Edited once, last by Jester ().

  • Couple of questions,


    why does dmesg report IPv6 when eth0 comes up (ipv6 is off) ?


    [ [email protected]] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
    [ [email protected]] libphy: stmmac-0:00 - Link is Up - 1000/Full
    [ [email protected]] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready



    Also rpcbind fails to start on each boot: (are we actually using it?)


    [ [email protected]] systemd[1]: Starting RPC Bind...
    [ [email protected]] systemd[1]: rpcbind.service: Main process exited, code=exited, status=1/FAILURE
    [ [email protected]] systemd[1]: Failed to start RPC Bind.
    [ [email protected]] systemd[1]: rpcbind.service: Unit entered failed state.
    [ [email protected]] systemd[1]: rpcbind.service: Failed with result 'exit-code'.

    Edited once, last by Jester ().

  • While testing Alpha 10 on an SD card, I just ran into the same problem, while previously I had no issue, only difference is a bigger movies database and on this reboot the rpcbind failed.


    Re-running the test now that rpcbind is running, although I doubt that this is the issue


    (to make the network port disconnect I run the play2 at 4k resolution while playing a 4k movie, it runs fine between 25-35 minutes and then the network stops)

  • right, running from SD card, hit the same disconnect issue even while rpcbind was running...


    updated thread title to reflect issue on both NAND and SD card installs.

  • Hi,


    I'm another one with this issue. Appears to be exactly the same too. Brand new Wetek Play 2, LE beta 10 installed to SD Card, crashes after a few minutes playing from NFS or PVR:


    Usually one of these two errors, usually the latter...ERROR: CDVDAudio::AddPacketsRenderer - timeout adding data to renderer
    NOTICE: CVideoPlayerAudio::Process - stream stalledDon't know what I can do to help but more than happy to pull log files etc if needed


    EDIT: NOT exactly the same issue... my LE installation is to SD card, not to NAND

    Edited once, last by brtsmth ().

  • Here the same ... all libreelec Versions on a sd Card (wetek Play 2) are not usable (also the Version 7) ... Network disconnects . also during reading the Music library the Network Crashed and it is not possible to create a complete library ... thats a worse Problem and i hope the Team will fix it asap
    during watching a movie Network Crash averytime .. sometimes after a hour ... same as the Music library problem

  • If the same thing happens under Android/WeOS then it's a hardware problem and WeTek will replace the unit for you. If it only happens under LibreELEC then we need to do more investigating. I haven't been able to reproduce yet this myself yet, but that might just mean I don't have the right conditions to trigger the issue.


  • If the same thing happens under Android/WeOS then it's a hardware problem and WeTek will replace the unit for you. If it only happens under LibreELEC then we need to do more investigating. I haven't been able to reproduce yet this myself yet, but that might just mean I don't have the right conditions to trigger the issue.


    Hi Ned,


    WeOS uses weplayer (Javis 16.1) not kodi 17 beta 7, so thats a bad comparison, plus I dont want android :)


    to reproduce, I have weOs 2.01 on the play2, I boot a fresh alpha 10 from SD card, add a bunch of movies to the library, switch to Amber skin, display is set to 4k res and play a 4k file using SMB from my NAS, normally the network crashes between 20 and 30 minutes, but sometimes it takes 50 minutes.


    The issue is hard to diagnose as there are very limited indications in debug/dmesg/log files for the issue.
    If a dev reads this, can somebody build a LE 10 version with kernel debug enabled so we can better diagnose what is going on ?

    Edited once, last by Jester ().

  • Would just like to say that I am having exactly the same problem.


    I received my nice new Wetek Play 2 today & installed the latest Alpha 10 of LE to my SD Card.
    Added my Movies & TV Shares via NFS and then set up the TVHeadend client from the Addons (TVHeadend server is a separate Linux PC on my LAN)
    I began watching one of the recordings from the TVHeadend server but after 20 minutes or so the Wetek's network connection seemed to go down. Rebooting the Wetek did bring the connection back & I was able to finish watching my recording, however the exact same problem has happened 2 or 3 times since.
    I have even tried using one of the community builds from over on the Wetek Forums that contains the stable LE 7.x builds but the same problem is occurring even on those builds.


    If I unplug the Ethernet cable & exclusively use a WLAN connection then everything seems fine, no disconnects occur, but I really would prefer to use an Ethernet connection for the increased bandwidth it offers

  • and this problem is in every! libreelec version also in version 7 with jarvis 16.1
    i hope there is a solution asap
    with openelec on wetek devices there were no problems...

  • following a hunch from the wetek forum, i've just upgraded to another power supply, one that outputs 2.0A, after that change I have zero issues any longer (so far....dont get happy...yet, testing on SD card, NAND install is next)


    Update: spoke too soon, just had to happen again on NAND

    Edited once, last by Jester ().

  • Update: still running with another PS (2.0A) and changed out the network switch (HP to 3com) just to see if it occurs again.


    I must say with the new PS the issue seems to happen a lot less so I will keep trying different setups and report back.

  • After reading Jester's suggestion I too changed my PS to a 2.0A one.
    However it has made no difference whatsoever. After watching a HD recording from my TVHeadend server for approximately 20 minutes via Ethernet, the network dropped out as it has been doing previously.


    Back to the drawing board I guess

  • now i installed the latest version of libreelec beta. 010
    i can watch with the Teleboy add on one hour tv. no problems


    than i tried to scan my music library and after a few minutes there is a little knack sound and the network crashed.
    i hope there will be a solution fast

  • Just a quick update from my side of things.


    For the time being I have had to revert to using Android on my Wetek Play 2. Running Kodi 17 RC 1 under Android works perfectly, no network drop outs whatsoever.
    The problem with the network drop outs are absolutely isolated to LibreELEC.


    Now whilst using Kodi through Android is a current workaround, I really would prefer to use LibreELEC if this rather serious bug can be resolved at all