gigabit networking

  • Hi there,


    I'm currently a LE user with both a wetek play and wetek core devices. My home network is fully gigabit compatible, but i was unable to find anywhere how to configure the MTU for the onboard wetek ethernet. The only way to fully utilize a gigabit network is to change the MTU to 9000, so to enable jumbo frames on the network layer.


    Is there any way to do it ?


    Trying to set it mannualy doesn't work:


    #ifconfig eth0 mtu 9000
    ifconfig: SIOCSIFMTU: Device or resource busy

  • Changing MTU values in home networks rarely gives you an advantage. All attached network devices will have to be fully compliant to this highest setting, otherwise performance will sooner drop than rise. Most of the time, the default 1500 value will do just fine.

    Edited once, last by Klojum ().

  • as i told before, my home network is fully gigabit compatible. I have a Dell 10 Gigabit switch, my router is also gigabit capable. All of my hardware is set to jumbo frames. I run 200m of fiber in my home, it's a whole block ;)


    When i asked the question i forgot to tell that i have a computers science degree, i'm a network engineer and have a lot of knowledge on the field. Instead of telling that the default 1500 will do just fine, you could have just answered the question with useful information, because i know what i'm asking about. If this was a real linux distro, it would only need information written on the interfaces file, but as libreelec and also openelec reads it's network configuration from a xml file written by LE configurator and LE configurator doesn't have a MTU option, it would make sense to mess with the xml.

  • Quote


    you could have just answered the question with useful information,


    I guess I could have but our magic crystal ball hasn't been upgraded to the latest version yet. So I couldn't know that we're dealing with a computers science degree guy who knows what he is asking about.

  • Hello,


    I would like to return to this subject. I have a Wetek Play2 and also want to set MTU to 9000. In my home network there are no problems with it only I do not know how I can set the MTU at the Wetek. The commands in this thread don't work. Is there now a way to set the MTU (permanent)?