RetroELEC Kodi+Wayland+Emulationstation+RetroArch (x86/XU4/RPi)

  • My 3 year old i5 nuc plays Mario Kart pretty good while other games are a bit laggy. I think the latest gen nucs should run Dolphin well.

    Well I have a NUC DN2820FYKH with cereron which is much slower. I will investigate the latest gen NUC

  • No, I cut the nvidia-legacy driver from the latest build as it crossed 512MB and thus won't fit on a standard LE /flash. I'll have a look if there's something that can be slimmed down.

    It would be great for my old computer, so I stay on official build for the moment

  • Well I have a NUC DN2820FYKH with cereron which is much slower. I will investigate the latest gen NUC

    I also have a NUC core i3 and can play almost all wii game but need to fallback to 1280x720 resolution before launching dolphin

  • Wouldn't that lead to input delay, as your TV would need to upscale the resolution to 1080p? Perhaps not noticeable in Wii games?

  • I do not feel any delay, but 1080p is also upscaled as I own a 4K TV

    for example DK Country Returns is not playable in 1080p and playable in 720p with some lags

  • Hi escalade


    20170621 build for rpi appears to have broken bluetooth. Libreelec is showing no adapter found. Nothing appears in logs.


    Rolling back to 20170615 and bluetooth is fine.

  • Kodi has nothing to do with hardware support. Upload the logs from the "Logfiles" share.

    I'm not sure what you mean by "Logfiles" share, however here is the output from the journal when restarting bluetooth.

    Code
    1. Jun 23 01:45:28 LibreELEC systemd[1]: Stopped Bluetooth service.
    2. Jun 23 01:45:28 LibreELEC systemd[1]: Started Bluetooth service.
    3. Jun 23 01:45:28 LibreELEC bluetoothd[893]: Bluetooth daemon 5.44
    4. Jun 23 01:45:28 LibreELEC bluetoothd[893]: Starting SDP server
    5. Jun 23 01:45:28 LibreELEC bluetoothd[893]: kernel lacks bnep-protocol support
    6. Jun 23 01:45:28 LibreELEC bluetoothd[893]: System does not support network plugin
    7. Jun 23 01:45:28 LibreELEC bluetoothd[893]: Bluetooth management interface 1.14 initialized

    Hopefully this is okay? Looks like a problem with the kernel bump to .6?

  • HOW TO:Provide Logfile - LibreELEC (this could be found by putting "Libreelec logfiles share" in the address bar)


    BNEP is not needed and has never been included with RPi builds official or otherwise. There is 0 difference in kernel configuration from my previous release. Not excluding the kernel as a possible cause but it seems strange as it's a minor release.


    You have a RPi or RPi2? In that case you have an external bluetooth adapter? Always provide full details about your hardware and full logs.

  • HOW TO:Provide Logfile - LibreELEC (this could be found by putting "Libreelec logfiles share" in the address bar)


    BNEP is not needed and has never been included with RPi builds official or otherwise. There is 0 difference in kernel configuration from my previous release. Not excluding the kernel as a possible cause but it seems strange as it's a minor release.


    You have a RPi or RPi2? In that case you have an external bluetooth adapter? Always provide full details about your hardware and full logs.

    Apologies, I didn't realise Kodi logging enabled system logging in Libreelec.


    RPi3 and only using the internal adaptor.


    Thanks

  • Hi escalade,


    i had the same problem with my rpi3 internal bluetooth adapter and LibreELEC-RPi2.arm-8.0-devel-20170621. LibreELEC-RPi2.arm-8.0-devel-20170615 is working fine for me, too. I get the same information that no bluetooth controller can be found by kodi.


    Regards,

    DoC

  • Probably because libevdev isn't included in the RPi image. I've added it as a dependency to reicast and a 20170615 image is uploading try that ;)

    Hi escalade,


    i just installed the Image 20170614 where i could not connect my ps3 controllers via bluetooth also. After updating to 20170615 i can connect them again. Since this version i cannot connect my bluetooth keyboard anymore. Is it possible that because of this libevdev? I can remember that i had the same problem with the retropie image. There you had to choice if you wanted to connect ps3 controllers via bluetooth or any other devices. Both at the same time was not possible.


    My old "escelade" image i used before 20170615 allowed to connect my bluetooth keaboard and my ps3 controllers at the same time. That was pretty cool and your "retro gaming image" was the only one i found where both was working at the same time.


    Do you have any clue what could have been different in the past image? If needed i can look after the specific escelade version i used before.


    Regards,

    DoC

  • Finding the problem should be easy because there's only been a few commits since the last release. I'll put out a new build soon.


    EDIT: 20170626 uploaded for the RPi, please test. Only downgraded kernel.


    DoC JoNeS


    As for your ps3 controllers, they should just work. libevdev is just a library it has nothing to do with the kernel or bluetooth.

    Edited 2 times, last by escalade ().

  • Hey escalade,


    Just tried 20170626 and still have no bluetooth adapter unfortunately.

  • As far as I can see from the logs posted earlier, bluetooth is working fine. There's this however:


    Code
    1. 01_KODI.log:00:38:31.574 T:1741681568   ERROR: ## LibreELEC Addon ## bluetooth::monitor::remove_agent ## ERROR: (AttributeError("'NoneType' object has no attribute 'remove_from_connection'",))
    2. 01_KODI.log:                                              File "/home/trondah/LibreELEC.tv/build.LibreELEC-RPi2.arm-8.0-devel/LibreELEC-settings-6336f1e/.install_pkg/usr/share/kodi/addons/service.libreelec.settings/resources/lib/modules/bluetooth.py", line 736, in remove_agent


    The only other relevant commit is perhaps upgraded busybox, a new build 20170627 will be uploaded in a moment. Before upgrading, could you just test "bluetoothctl" from the command line and post the output?