RetroELEC Kodi+Wayland+Emulationstation+RetroArch (x86/XU4/RPi)

  • Hallo together,

    maby I'm too stupid to find a solution Bit I can't configure my PS3 controller.
    The controller works fine in the menu but in game the D-Pad up is for example the Start button.
    I used several times the setup menu for configuration of the controller but this didn't helped.
    Any ideas?

  • use some retroarch.cfg input examples of retroarch wiki or in some other discusstions are some of inputconfigurations....copy all in your cfg an restart retroarch

  • Hi Escalade and all community members. I don't know if anyone asked this before, I read a good part of the thread but didn't find it.
    Is there a way to install and use RetroArch on LibreElec 8 simply installing an addon instead of burning the full image you developed?

    Before installing LibreElec I've being using OpenElec and installed RetroArch addon 1.3.3 and it was working fine. Upgrading to LibreElec I've lost the ability to use the RetroArch addon (still present, but not working).

    It would be very appreciated if you could extract only the RetroArch related stuff from your image and build an addon, so everybody can install RetroArch without a full upgrade. Is it possible?

    Thank you for your good work.

  • "retroarch on libreelec" in google search gives you Gamestarter on first place.

    i like this "full" build better though

  • Hey all, apologies if this has been asked and answered - I've skimmed the thread, and Google failed me.

    I'm trying to install this image on a nuc ivy bridge. My TV is reporting the resolution is invalid, and no picture is displayed. I've tried a clean install from loading the image onto a USB, and at boot the installer doesn't even display. I've also tried with a clean libreelec 8 install and copying the tar file into the update folder - it installs, but then when it reboots it has the same display error.

    The pc is an Intel nuc ivy bridge i3. Libreelec 8 reports the video is mesa dri Intel ivybridge mobile. Opengl version 3.0 mesa 13.0.6.

    Is this fixable?

    Edited once, last by SickIcarus ().

  • Do you see the post screen on boot ?

  • latest .tar -file in Update-Folder and reboot

    Ok, I tried to update this way but something failed.
    So, I made a fresh install (format SD; burned the image on the SD; boot) and I got some bootloops: It keeps booting after the home page appears.
    What happened?

    thank you!

  • I have the same issue. Just setup the x86 4-10 iso on a VM.

    PS3 works fine over BT in LE, and works fine in ES, but once I start a rom, the buttons are all out of wack (similar to this post).

    A suggestion was to "set them up in retroarch, but while i've used retropie, I have no idea how to get into retroarch settings (or where the manual configs/etc are) ?

    To be fair, i'm not using a keyboard at all, an ir remote (for kodi) and ps3 for emulators.

    Any pointers, links, etc to fixing tweaking this/etc?

  • Hi there!
    I'm very new to Linux and Raspberry Pi, but want to setup a HTPC, based on a Raspberry 3 and Libreelec.
    Since I own a Amiga 500 since the eighties, I would like to play occasionally an old Amiga game or another.

    Yesterday, I found this great image and installed it immediatly.
    I just managed it to move the *.adf files of the games to the right folder using the file manager, but when I start the emulator and choose the game it shows the following error:
    "Could not load system rom, trying system rom re ..."
    Copying the kickstart.rom in the same folder as the game doesn't bring success.

    Could anyone help me, please?
    Best regards

  • My emachines x86 pc has NVIDIA GeForce 9200, librelec v8 no longer works with this GPU.

    I managed to use the build in this post, that includes the legacy 304.135 nvidia drivers, to get a stable build of libreelec running.

    Does anybody know if there's a version of this community build that includes those drivers? Too noob to compile myself.

  • Hi escalade,

    Hi I got my new NUC7i7, can you implement the Bluetooth driver to your build? With Win10 everything works thanks to the drivers. In Librelec unfortunately not yet

  • Does anybody have any ideas on this issue? It feels like an issue with xorg.conf but I don't know how to fix it.