RetroELEC Kodi+Wayland+Emulationstation+RetroArch (x86/XU4/RPi)

  • I am using version 7.95.1 on my HTPC Asrock Beebox N3150 with integrated RTL8723AE Wifi Chip.
    I have massive problems with my wireless internet connection and connecting to my NAS.
    Sometimes it doesn't even show any avaible wifi networks, on other days I can connect, but it's really slow, or I get time out errors.
    Any idea what I can do about it?
    I have heard, this might be a linux related driver problem...

  • how can i use the scraper from sselph ?
    I believe that scraper has a option to add metadata to a dir (amiga and psx) because each rom is in a different folder because of multiple dics

    thanks in advance
    and i really love your build m8!

    Edit : I dit found a workaround but then i need to change the xml by hand and change to <folders>, but still leave one <game> otherwiste it won't work at all

    Edited once, last by Waspoeder ().

  • Waspoeder

    It's CLI only and no special automation in my build, so you'll have to check the doc on sselph github.

    For anyone interested:

    I managed to compile the latest reicast for RPi2, could someone test the binary I've uploaded on my gdrive?

  • escalade

    Ok thanks
    Reicast core on generic works perfect, i added gb and gbc to your system list and i am busy with dosbox and scummvm now
    Iinstalled the mq7 skin, it works like a charm, but i had to use advanced launcher to run chrome and emulationstation
    Tried other theme's for ES but the one that comes with the package is the best i think

    Edited once, last by Waspoeder ().

  • Hi, I have tried it on rpi3 with the following result:

    Emulator runs fine. I managed to run Crazi Taxi (Very playable) and Cannon Spike (not playable, too much graphical glitches and defects). I didn't manage to run Armada and Atari Anniversary (probably not yet on compatibility list

    For the controller config I have used this py script:

    reicast-emulator/ at master · reicast/reicast-emulator · GitHub
    and generated config stored in /storage/.config/reicast/keyboard.cfg (of course you can use any name you want)
    and then pointed in /storage/.config/reicast/emu.cfg to the proper controller config:

    evdev_device_id_1 = 2
    evdev_device_id_2 = -1
    evdev_device_id_3 = -1
    evdev_device_id_4 = -1
    evdev_mapping_1 = /storage/.config/reicast/keyboard.cfg
    joystick_device_id = -1

    where evdev_device_id_1 points to your game controller in /dev/input/eventX
    and evdev_mapping_1 points to stored controller mapping
    the reicast-joyconfig script helps you to identify proper eventX

    0: Љ Mini keyboard (/dev/input/event0, usb-3f980000.usb-1.2/input0)
    1: Љ Mini keyboard (/dev/input/event1, usb-3f980000.usb-1.2/input1)
    2: PLAYSTATION(R)3 Controller (/dev/input/event2, b8:27:eb:7b:56:53)
    3: PLAYSTATION(R)3 Controller (/dev/input/event3, b8:27:eb:7b:56:53)
    Please enter the device id: Traceback (most recent call last):

    I have also created the necessary directory tree structure:

    and placed dreamcast bios files to /storage/.local/share/reicast/data :
    dc_boot.bin dc_flash.bin

    Good work Escalade

    Edit : found the problem : sound volume was set to the minimum... But I did not change it myself ?

    This is issue with the game controller.
    Sometimes the analog sticks are stuck in the position which decrease the volume to minimum. So you can either increase it back with controller and then turn off/on controller to reset the position or configure mapping in the way to disable volume controll by analog stick.

    Edited once, last by coverilla ().

  • Thanks for testing, the joyconfig utility will be included in the next build. I'll see about including ds4 config and linking the bios directory to /storage/roms/bios as well.

  • Wow, that makes sense ! Thanks !

  • does anyone succeed with the picodrive emulator for MEGADRIVE/SEGACD/MEGA/CD on RPI2/3?
    Any rom/image file I test I just see the black screen. I use latest picodrive_libretro.

  • Hi Escalade,

    I have try your reicast bin.

    Do you think it's possible to change default bios directory to the bios general directory instead of /storage/.local/share/reicast/data/ (i did not found if there is a possibility to change it in emu.cfg) ?
    So I put dc bios in /storage/.local/share/reicast/data/

    I add this entry in es_systems.cfg :

                    <extension>.cdi .gdi</extension>
                    <command>/storage/reicast.rpi2.bin %ROM%</command>

    I also add (try to) my xbox360 controller mapping :
    evdev_mapping_1 = <path to mapping file>.cfg

    but it seems to be rewritten at each start of the emulator so I do a chattr +i on emu.cfg so controller OK.

    Marvel vs capcom 2 start but is not playable the sound is crackling and fps is low (to compare reicast in retropie allow to play mvc2 just some 2D glitch to note).

    I'll check If there are specifics parameters used in the retropie reicast config as I haven't change anything in this run.

    See you.

    Edited once, last by FoxXav ().

  • Sure, a symlink would do the job.

    I've uploaded "amiberry-sdl2.bin", which is a new fork of uae4arm that uses sdl2. Could someone take it for a spin and let me know how it works?

  • Is it possible to add nvidia legacy again? Or at least dig up the old version that had nvidia legacy? Built an older pc for retro-gaming for my cousin who just took his PhD and wanted to give him something he can enjoy :)

    Big thanks for your effort into this project by the way!

  • Legacy is included, perhaps your GPU needs the 304.xx series?

    could very well be so, i believe it's an old nvidia 9400 card. Would it be possible to include that, or do you have some older version somewhere?

    getting xorg failed to start when trying to boot from usb.

    Also, i have another pc running your build fine, but how do i use the scummvm emulator and dosbox?

    Edited once, last by slacker666 ().

  • does anyone succeed with the picodrive emulator for MEGADRIVE/SEGACD/MEGA/CD on RPI2/3?
    Any rom/image file I test I just see the black screen. I use latest picodrive_libretro.

    Bios in bios folder, then test it. Bcracers works fine with plus_gx for Sega CD, pico for 32x not so much... ill play around with it some more...


  • Definitely do not buy the Wintel. Wireless and bluetooth is not working, there's random crashes and the BIOS is very buggy. If you want a cheap device, the Tronsmart Ara X5 Plus works good. It has minor issues as well but wifi/BT works and it's a lot more stable than the Wintel.

    If you want a real upgrade, get a NUC.

  • escalade, It'a a little offtop but some time ago you said that you use a NUC. Can you tell us what model is it and if that model has enough power to run smoothly all games that your libreelec build supports?