S802/S812-Libreelec images for 7/8/9

  • So I managed to fix the box and get it going again in android but in the whole process it seemed to me that I could kind of get v8rc4 working by using the boot recovery once with the written image in SD slot and then booting it from USB. However, it would not boot from SD - its like it wanted to and found the 1st partition and its like it couldn't find the 2nd partition. I think there is something there that could be fixed ?


    Also I prefer to use Kodi 16.1 for now so that means using v7.0.3 but that does not boot from either SD or USB. Again, once the box has had the first reboot-recovery done and picked up the AML script from v8rc4 it should be able to dual boot v7.0.3 also (?) - and v7.0.3 does not have the AML script, hence the convoluted way of first using v8rc4 - and again for v7.0.3 it is as if it boots the 1st partition and then cannot find the 2nd. I think this could be fixed ?


    If this could be fixed this would be so cool - its been ages since I thought about have libreelec (openelec then) running on S802 box as no one, up until now, has worked on this dual-boot problem, so I think its close (thank you !) but hoping the issue of not finding the 2nd partition and being able to use kodi 16.1 can be worked out. Thanks in advance.


  • We might need to flash an S812 bootloader :)


    Oh no - I feel a brick coming on - we went through all this before with 805s etc and i think thats why kszaq came up with environment variable way instead as people were bricking their boxes by flashing bootoladers. The other thing I noticed with the new builds is that they have non-standard partition labels - not SYSTEM and STORAGE anymore and I wondered if that was anything to do with partitions not being found. Just a thought.

    Edited once, last by Jed ().


  • Partition Labels are Libreelec&Libreelec_Disk


    I see that. They used to be SYSTEM and STORAGE. Was that a change generally from Jarvis to Krypton or just for AMlogic or S802 ?
    [hr]
    So I thought I would try to clone the working 8rc4 onto another USB (actually an SD in a USB adapter) and so I managed to do that with Linux Mint and Clonezilla. I booted up the clone and it worked. Great. Next step to try resizing the 2nd partition (since the clone SD was 8Gb and the original was 2Gb). So I did that, again in Linux Mint with GParted and that booted fine.


    Next step to "upgrade" the working 8rc4 (on USB) to 7.0.3 so I could use Kodi 16.1. So I copied the image file into the update share, as usual and rebooted. It found the image and did its thing but it failed with this 3-line message:


    Error in prepare_sysroot: mount_common: Could not mount dev/SYSTEM ***
    Starting debugging shell... type exit to quit ###
    can't access tty: job control turned off


    And so thats why I thought the problems might be due to the partitions, perhaps how they are named or mounted during the install/upgrade process.


    So thats my report, best I can do. I have no knowledge to fix it.

    Edited once, last by Jed ().

  • Hey Demetris I have a tronfy mxiii 4k box with 2 gig of ram. I am unsure which file to download as mxiii download states 1g.

  • Make sure you save your remote.conf you will find it in etc folder on android. Just use astro file manager to navigate to it.


    Demetris
    Hey mate I couldn't get le to work on the mxiii I'm on stock tronfy android rom. When I try with toothpick method it looks like installing with the android dude but then just boots back into android rom. Also tried usb stick method but still no joy.


    When I installed on m8 box with files I got off chunk1982 I did notice it had a recovery file in with the files on micro sd. Could I just use that recovery file?