Gamestarter: Retrogaming add-ons (RPi/Generic)

  • Did you manage to the third step in the guide (after installing the repo from the zip file)?

    "Go to Kodi → Add-ons → Download or Install from Repository and select the addons you want to install"


    With Zip you only install the new repository - after that you need to download individual add-ons from there.
    The first screen shot in Github shows installed add-ons (and not just from this repo).

  • Hi Mario & Teemu,

    Thanks for both replying. Having looked at this again and not finding the entry I tried to reinstall the repo. This time I got an error message saying failed to install repo.

    This didn't happen last time. It just exited without anything. I assumed it had worked. It explains why I couldn't find the repo in the submenus.


    Went back to the start and redownloaded the repo zip. I realised i'd got an outdated version of the repo zip!

    It worked this time.


    Silly me.


    Thanks for trying to help guys.

    Appreciate it!

  • Hello Teemu,


    Thank you for the reply and suggestion! I opened the retroarch config file and replaced the ozone menu line to Xmb, and seems to be working so far in regards to navigating through Retroarch!


    I am still having performance troubles with my various games+cores (which I installed all through the Retorach kodi addon settings option). While I test with different retroarch configurations, are there any recommended "default" settings I should change to get better performance? (best video driver to start with for R.PI oin Kodi, , overlay/processor speed configs, etc)? I should add that most 2D related emulators and roms (SNES, Genesis, PCEngine, GBA) seem to work fine in the Kodi Retroplayer, but using same cores in Retroarch seems to be slow.


    Thanks !

    Edited once, last by Zantaskan ().

  • Error "GLIBCXX_3.4.26' not found


    Hi guys,


    I've installed the gamestarter addon on my RaspberryPie 4 under "LibreElec v9.2.3 (KODI v18.7)".


    When trying to load a Nintendo N64 game with "RetroArch v9.186.20" " using "Mupen64Plus Next" as core, I'm getting the error message "Failed to load Libretro Core"

    The log file has an entry saying "Error(s): /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.26' not found (required by /storage/.kodi/userdata/addon_data/game.retroarch/cores/mupen64plus_next_libretro.so)"

    I've attached the packed files "retroarch.cfg" and "retroarch.log".


    Being a NOOB regarding this issue, I'm totally clueless how to solve this problem and would appreciate if someone could help. Thank you in advance!

  • Are you using the cores downloaded from retoarch UI menu or the cores downloaded from retroarch addon settings?

  • Mario77


    I'm using the cores downloaded from the "RetroArch" addon setting via "Download Libretto cores full package". Maybe that's the cause for the problem?


    Okay, following the other option and to first get a "clean" start, I've tried the following:


    - I logged into "LibreElec" via SSH

    - I deleted all files under "\storage\.kodi\userdata\addon_data\game.retroarch\cores\"


    When then running "RetroArch" and selecting "Load Core/Download a core" in the menu, a list of cores is displayed. but there are no entries for "Nintendo N64" - I've searched through the whole list, but apparently these cores are missing. (Other cores, for example, "Nintendo - SNES / SFC (Snes9x - Current)" are there, can be installed and are working fine with games made for this console).


    What can i do now?

  • You should download the cores from addon settings not from retroarch menu..


    Did you try another version of LE?


    Did you check that the library is there /usr/lib/libstdc++.so.6?


    Edited 2 times, last by Mario77 ().

  • @Mario66:


    Okay, after having downloaded the cores from the addon settings again, I also tried it under LibreElec 9.2.0 (KODI v18.5) and LibreElec 9.2.1 (KODI v18.6), unfortunately with the same failing result :-(


    And yes, the library /usr/lib/libstdc++.so.6 is there actually.


    Do you have any idea what I can try next?

  • I would try these 2 emulators:

    parallel_n64_libretro.so

    mupen64plus_libretro.so

  • Hello everyone, I have some problems on generic build, when i load retroarch it loads for a couple seconds and then it crash back into kodi splash and it loads the system again. Sometimes i can boot into retroarch but then if i try to change any configuration or load a core it crashes.

    Im using the latest version of LE with kodi leia. What can i do to check the problem?

  • @bite_your_idols:


    As stated in several postings above, when using your "Gamestarter" addon with "RetroArch"s' core "Mupen64Plus Next" under "LibreELEC v.9.2.3" (and also under its previous versions 9.2.0 and 9.2.1) on a RaspberryPi 4, there are some incompatibility problems producing errors like "/usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.26' not found (required by /storage/.kodi/userdata/addon_data/game.retroarch/cores/mupen64plus_next_libretro.so)"..


    To solve this issue, I had the idea to "manually" replace it with an updated version of libstdc++.so.6.0 which has `GLIBCXX_3.4.26' included. Actually, there is one, "Lakka" in its current version comes with libstdc++.so.6.0.27, so in my opinion the solution was to use it with "LibreELEC" v.9.2.3" by renaming it to libstdc++.so.6.0.25, but I didn't know how to "integrate" it properly into LE's Read-only file system ...


    I contacted one of the developers of "KODI under "LibreELEC" , "Hiassoft", for help, but he pointed out that "most certainly I installed a wrong/incompatible addon" and "trying to work around that by swapping out libraries on LE will only create more problems, and I should only install addons that are compatible with LE 9.2 by using from the official LE repository". See here.


    I've also tried other suggested cores, for example "Parallel N64", but unfortunately there are incompatibilities between "Gamestarter" and "Libre ELEC v9.2", too :-(


    As a NOOB, I don't know what to do next, of course I would love to continue using your excellent addon!


    Could you please have a look into the problems mentioned above? Maybe you could contact "Hiassoft" directly and you both find a solution together?


    Thank you in advance for your feedback!

  • Mario77:

    Yes, I did try "Lakka" on a spare sd card, and "Mupen64Plus Next" does work, but just because it comes with the required version of libstdc++.so.6 corresponding to the one the core has been compiled with (see error message from above).