Gamestarter: Retrogaming add-ons (RPi/Generic)

  • I just released a new RA 8.170.9 version including those missing libs, I tried it out and it worked in a fresh new LE9 alpha build installation.

    You can update from kodi's Gamestarter repo or download zip from here: game.retroarch-8.170.9.zip


    Also, I tried to get new RA 1.7.3 binary from escalade's/5schatten's releases but I can not make it work in official LE build... Since nowadays I just use my RPi for hyperion/ambilight control (and twice a month to watch some downloaded movies) by the moment 1.7.0 will be the last RA version in gamestarter addon, unless someone offers itself to compile RA using official LE toolchain... sorry...

    hi bite_your_idols,


    Brilliant! Now I can start RetroArch. It's really cool. Thank you very much!!!



    Now I have another problem. This time it's Advanced Emulator Launcher. I don't understand how I have to configure this. I read the read me in github but don't know what I have to do exactly. I could configure RetroArch, but don't know which configuration file I have to import in ALE? Can someone explain me what I have to do here?


    Thx

    Edited once, last by Sepalod ().

  • I just released a new RA 8.170.9 version including those missing libs, I tried it out and it worked in a fresh new LE9 alpha build installation.

    You can update from kodi's Gamestarter repo or download zip from here: game.retroarch-8.170.9.zip


    Also, I tried to get new RA 1.7.3 binary from escalade's/5schatten's releases but I can not make it work in official LE build... Since nowadays I just use my RPi for hyperion/ambilight control (and twice a month to watch some downloaded movies) by the moment 1.7.0 will be the last RA version in gamestarter addon, unless someone offers itself to compile RA using official LE toolchain... sorry...

    Isn't lakka built on LE? Or is there some technical reason the binaries from lakka can't be used?

  • It's all here and here and here..


    Start by downloading this...these are the AEL assets that you need to setup the launchers..you can download them also from retroarch addon settings..then go to AEL settings → I/O → Import category/launcher configuration... and select the systems you want to import from default path where you saved the assets..You can install all or the ones you are going to use only...then you set AEL to download artwork or use your own and from each launcher menu point to the folder where you have the roms...example from the nes launcher browse to the nes roms folder and scan for roms..

  • Isn't lakka built on LE? Or is there some technical reason the binaries from lakka can't be used?

    yes, you're right. But lakka's retraroch binary has some additional features such as poweroff option or lakka updater... if a user use the latest lakka will updte and overwrite libreelec installation... I tried that way a lot time ago and some users lost their OpenELEC installation... ;(


    To avoid that you can compile Lakka and edit retroarch package file and change just one parameter, then you will get a clean retroarch binary. But I can not compile any linux distro anymore...


    The thing is that in new retroarch 1.7.3 there are some settings to "hide/view" some options in menus so I can try to hide "online updater" to avoid users loosing their LE installation... I'm gonna try it out :/

  • After struggling with Ubuntu/Lakka compilation, finally, here it is the brand new Retroarch 1.7.3 addon release: RA-8.173.10


    Repo is updated so if notification doesn't appear just force repo update manually (context menu).


    enjoy!

  • It's all here and here and here..


    Start by downloading this...these are the AEL assets that you need to setup the launchers..you can download them also from retroarch addon settings..then go to AEL settings → I/O → Import category/launcher configuration... and select the systems you want to import from default path where you saved the assets..You can install all or the ones you are going to use only...then you set AEL to download artwork or use your own and from each launcher menu point to the folder where you have the roms...example from the nes launcher browse to the nes roms folder and scan for roms..

    HI Mario77 ,


    this helped me a lot and I was able to get some roms imported. But I have still problems starting roms or importing some other roms.


    In the kodi log I can find something like this:

    I don't know why I get something like "Permissions denied".

    The other thing is, for some emulators / categories I get errors like this:

    Does anybody know what is causing my problem?


    thx a lot

  • It seems that I could solve my problem by granting write access to the following folders for the whole user group:


    • /storage/.kodi/addons/plugin.program.advanced.emulator.launcher
    • /storage/.kodi/addons/game.retroarch
    • /storage/.kodi/temp
  • It seems that I could solve my problem by granting write access to the following folders for the whole user group:


    • /storage/.kodi/addons/plugin.program.advanced.emulator.launcher
    • /storage/.kodi/addons/game.retroarch
    • /storage/.kodi/temp

    I don't think you have to do that to be honest..I don't remember doing that when I set mine..

    If the roms run from retroarch they should run fine from AEL...it does take some time to setup all with artwork and get used to how it all works especially if you just started with emulation..


    I just use retroarch for running roms..never scanned any rom folders from retroarch or downloaded artwork......just downloaded cores and changed few settings for audio and video and few other settings and that's it...


    I run my roms from AEL or Emulation Station...both sharing same artwork from same folders...been some time now that I set everything and working flawless...when you r done make sure you have a backup cause it's hard work to start again especially if you have 1000's of roms...

  • I would be glad, if somebody could help me,


    I have been using Libreelec for a very long time and want to play retro games on my pi.

    I have now discovered Gamestarter but the Zip V.3.0 has only about 400kb. I think there is something wrong.


    How do I install the

    RA-8.1.7.3.10 on my

    Pi 3B+ with

    Libreelec 8.2.5?


    I made Gamestarter V2.9 successfully running on my System, but my Roms could not start.


    Please Help

    Edited once, last by xOnur: nobody cares ().

  • Are you using retro player builtin kodi?

    No, I'm not. It's not completely working.


    Also I already downgraded to 8.2.5 and did soft reset of LE. And now I can't download core package from RA addon settings. It's downloading zero-sized archive😀

  • No, I'm not. It's not completely working.


    Also I already downgraded to 8.2.5 and did soft reset of LE. And now I can't download core package from RA addon settings. It's downloading zero-sized archive😀

    Download from here