LE12-11.95.1 kodi 21 wiimote problem

  • Hello
    I've updated to LE12 11.95.1.
    When connecting the wiimote, a warning to configure a new controller.
    When I set the keys as requested, the sequence stops after the "up" key, I can do the rest manually except the "B" key is not recognized.
    In previous versions of libreelec LE19 and LE20, the "1" and "2" keys were "page up" and "page down", with LE12, this has changed.

    With keymap editor, I customized the "-" key for the contextual menu, but with LE12, I can no longer customize any wiimote key.

    I've been using the wiimote to navigate in kodi since version LE19 with no problem.

  • Hi,

    Similar issue as mentioned above:

    • Hardware: RPI 5
    • LE versions tested: LibreELEC 12 Beta1 and LibreELEC-RPi5.aarch64-12.0-nightly-20240426-4513878.img
    • Logs: Logs for the nightly built

    With both versions of LE (beta 1 and nightly built of the 2024-04-26), it was a fresh install, default config. Paired the Wii Remote and the behaviour was different depending on the setting for Settings / System / Input / Drivers settings / Joystick drivers:

    • Linux: D-pad is not recognised, all the buttons are
    • Udev: D-pad and all the buttons are recognised

    In both cases, the button mapping is not usable and completely different that how it was with LE Nexus 11

    I could not find how to remap the buttons, so will wait until this is fixed to test further LE 12.

    Btw, I also plugged the nunchuck to see if it would make any difference, it did not (the logs are without the nunchuck being plugged).

    I hope this helps if anyone wants to investigate, and if anyone knows how to remap the Wii Remote buttons so it matches how it was, by default, in LE 11, please share :)

  • HI

    i add :

    Hardware : PC with dongle usb bluetooth

    LE versions tested: LibreELEC-Generic-legacy.x86_64-11.95.1.img.gz and LibreELEC-Generic-legacy.x86_64-11.95.2.img.gz

  • Tested with the new non-beta LE 12 release (LibreELEC-RPi5.aarch64-12.0.0.img), still on RPI 5, and same issue as described above, so I did not add new logs

    April 27, 2024 at 4:29 PM

    I see a similar issue was also raised on Kodi's forum few years ago (Wii Remote D-pad not working with linux drivers, and working with udev), and I tried the suggestion by Drakkos to add an udev rule, without success (the rule was taken into account but the button mapping was still all over the place, not sure what some buttons do):
    Wii classic controllers

    Also, in case it helps, the current mapping as defined in


    The post mentioned above with Drakkos and garbear comments does not indicate how the issue was fixed properly at the end, not sure how to investigate more. If anyone has a clue, please share :)

  • I made a new joystick.xml file (added it in the keymaps directory). Changing the D-pad mapping is reflected when using the Wii Remote (changed down for to facilitate testing, and left to test) but changing the a and b button do not.

    With the Wii Remote, currently, pressing b generates a ScrollDown (again this is with udev, as with the linux drivers the D-pad is not recognised, but the buttons behave in the same way, meaning b triggers a ScrollDown).

    Using another gamepad, all the changes in joystick.xml (including a and b) are reflected.

    As I see garbear has not been actif in the libreelec forum for the last 4 years, should this thread be moved to https://forum.kodi.tv/forumdisplay.php?fid=292 ?

  • garbear did give the below reply on the Kodi forum https://forum.kodi.tv/showthread.php?tid=377671 :


    This seems like a problem that was introduced in a kernel or driver change in LE 12. The Kodi drivers in the RP builds (linux/udev) haven't changed in a Linux-specific way in quite a while. I would follow up in the LibreELEC slack, though maybe they can pin it to a Kodi problem.

    I wanted to do further test to see how the kernel version was impacting the Wii Remote, and also checking both Libreelec, using Raspberry OS and Coreelec. In short, it did not seem to be linked to the kernel version, and I am not sure how to test the drivers.

    Test results:

    • Hardware: Raspberry pi 5
      • OS/Kodi: LibreELEC 12.0 with Kodi (Omega) v21.0
      • Kernel: 6.6.28
      • Wii Remote: Dpad NOT working
    • Hardware: Raspberry pi 5
      • OS/Kodi: LibreELEC (Nexus) 11.0.5
      • Kernel: 6.1.71
      • Wii Remote: Dpad working
    • Hardware: Raspberry pi 5
      • OS/Kodi: Raspberry pi OS 2023-12-06, Debian 12 / Kodi (Omega) v21.0
      • Kernel: 6.1.69
      • Wii Remote: Dpad NOT working
    • Hardware: Odroid N2+
      • OS/Kodi: CoreELEC 21.0-Omega (April 9th, 2024)
      • Kernel: 4.9.269
      • Wii Remote: Dpad NOT working
    • Hardware: Odroid N2+
      • OS/Kodi: CoreELEC 20.5-Nexus (March 5th, 2024)
      • Kernel: 4.9.269
      • Wii Remote: Dpad working

    So the kernel version does not seem to be linked to the issue. Concerning the drivers, let me know what I need do to check and compare the drivers if that can help.

  • Hello
    I did a test with “LibreELEC-Generic.x86_64-13.0-nightly-20240607-408d637”.

    it's worse, the D-pad (up, down, right, left) doesn't work at all and is not configurable like with LE12

    hope a fix can be found


  • The same issue is replicable on Coreelec and when installing Kodi on Linux (tested on Ubuntu), so it is not only impacting Libreelec

    I have tried with a more recent version of the add-on peripheral.joystick (version 21.1.18 ) but unfortunately that did not solve the issue with the Wii Remote for both linux and udev drivers Sad

    Not sure what else to try or where this issue should be raised.

  • Is there any test we can do to help investigate the issue, knowing the Wii Remote problem is on both Coreelec and Libreelec since they moved to Kodi 21?