Suddenly, my Raspberry Pi 4 can't display video when both HDMI ports are in use

  • Hi community!

    After achieving the use of one HDMI for video and the other for audio with the Raspberry Pi 4B, I used it for a couple of days without any issues.

    However, now when I turn on my Raspberry Pi and both HDMI cables are connected, I can't get video, or I have it for only 1 second when the color palette appears.
    After that, I can't see the boot process, but I know that it boots correctly because I can manage Kodi from the Kore app to turn it off correctly.

    I have to unplug the HDMI cable used for audio and turn on the Raspberry Pi to get video.
    Even if the home theater is turned off, just with the HDMI plugged into the Raspberry Pi, I can't get video.

    I initially thought that it was related to the power supply I was using (5V 3.1A), so I bought a better one (5V 4A), but the issue persists.

    Is this a configuration issue or a hardware issue? How can I fix it?

    Thanks in advance.

  • Reddirt check my previous thread:

    February 4, 2024 at 7:09 AM
  • After hours of testings, I've noticed that if the HDMI cable is not connected to the AVR, Raspberry display image, but if I connect the HDMI to the AVR, even if the AVR is not plugged to the wall socket there is no image.

    Something that I didn't mentioned before is that now I'm using HDMI adapters or extensions for the HDMI used to pull audio.

    Is that a root cause of the issue? Should I buy a micro HDMI to HDMI 3 or 5 mts. cable?

    I've tested with and micro HDMI adapter to HDMI and a HDMI cable 3 mts but didn't work. :(

    I've tested with an micro HDMI to HDMI 1.5 mts cable but it was to short so I used an extensor adapter HDMI and then an HDMI 1.5 mts cable, but didn't work. :(

    I've put the Raspberry pi and AVR closer to reuse the same micro HDMI ro HDMI 1.5 mts cable, that worked days ago and didn't work. :(

    I'm out of ideas. Can i fix this modifying the config.txt file?

    Edited once, last by EloyFarina (February 11, 2024 at 8:57 AM).

  • I think that this video can help to understand my issue:

    External Content
    Content embedded from external sources will not be displayed without your consent.
    Through the activation of external content, you agree that personal data may be transferred to third party platforms. We have provided more information on this in our privacy policy.

    Sorry for my bad english, my natural language is spanish.

  • Just a wild ass guess here but it sounds like you have introduced a number of potential problems. I might suggest you start simple by using a micro HDMI to HDMI cable and see what works. If audio from HDMI is an issue you can always use the audio output jack with a separate cable. At least this way you can test and find what might cause your issues.

    If you provide your entire setup (Monitor type, AVR, Sound System) some the wiz kids here might come up with an answer for you.

  • Thanks for the reply, Reddirt!
    All that info it's in my previous thread, also as reference I put the link in a comment in this thread.
    If I use the audio output jack it only pulls stereo PCM sound, I want use the raspberry via HDMI to pull audio because I want that AVR decode DTS, Dolby Digital, Dolby Digital +, DTS HD Master Audio and Dolby True-HD.

    Let me clarify something, the HDMI that has the adapter is only the output used for video, I always used that adapter with the HDMI, it's true that now I have the other HDMI output connected. In my town everything is closed until Wednesday by Carnival here in Argentina, I would like to resolve this at the same way that it was working days ago.

  • Make sure you're using HDMI-0 (close to the USB-C port) for video, and HDMI-1 for audio.

    If that doesn't help...

    1. Login by SSH, and open the file cmdline.txt. It works similar to config.txt.
    2. Append vc4.force_hotplug=1 to the end of the line.
    3. Store that file, and reboot.
  • Thanks for replying Da Flex .

    I can confirm that HDMI-0 is connected for video and HDMI-1 for audio.
    This is my cmdline.txt modified:

    usb-storage.quirks=152d:1561:u boot=UUID=1108-5701 disk=UUID=3542a3ff-9e05-4d2b-80ce-0438958f4de6 quiet vc4.force_hotplug=1

    However, issue persists

  • Thanks, then you can remove that option again. I think we have to know what happens under the hood now...

    Please provide a full debug log.

    How to post a log (wiki)

    1. Enable debugging in Settings>System Settings>Logging
    2. Restart Kodi
    3. Replicate the problem
    4. Generate a log URL (do not post/upload logs to the forum)

    use "Settings > LibreELEC > System > Paste system logs" or run "pastekodi" over SSH, then post the URL link
  • Thanks. I've asked a developer, and he answered this:


    Standard procedure: what does the bootscreen say in the "display:" line when booting without any sdcard / USB drive /... attached?
    Note: this requires an up-to-date bootloader eeprom installed (i.e. run "rpi-eeprom-update -a" via ssh)

  • Funny that the HDMI-1 is still connected to the AVR and I can get video disconnecting the USB Drive.

    For that reason I bought a better Power supply for the Raspberry Pi 4 (5v 4a) because I thought that the power was not enough.
    AVR is still without electrical connection.

    Edited once, last by EloyFarina (February 11, 2024 at 8:04 PM).

  • I'm starting to feel like postal service ^^. Reply to your screenshot:


    hmm, that looks OK.
    please tell the user to add drm.debug=0x04 to cmdline.txt and post a new log.
    Also please ask him/her to run modetest | pastebinit and post the URL

  • The user MikeKL that he helped me on the previous post and who faced with a similar issue, he recomended to create a EDID and based on the logs that I've shared here, he wrote the following


    m_deviceName      : hdmi:CARD=vc4hdmi0,DEV=0
    m_displayName     : vc4-hdmi-0 (vc4hdmi0)
    m_displayNameExtra: GSM LG TV SSCR2 on HDMI


    m_deviceName      : hdmi:CARD=vc4hdmi1,DEV=0
    m_displayName     : vc4-hdmi-1
    m_displayNameExtra: MAI PCM i2s-hifi-0

    Then I noticed something. I remembered that I took a screenshot when everything was working fine, just to document it in case that I need it in the future. "YMH HTR-3064" is not in my previous logs

    Reason is that when I pulled the logs, the AVR is not connected to the electricity as I showed in the video.

    Since now I will have the AVR plugged to the electrictiy to took logs and troubleshoot, and I will create an EDID with YMH HTR-3064 and for m_displayName I will set vc4-hdmi-1 (vc4hdmi1)

    I will keep you posted shortly

    I just connected the AVR to the electricity and with exactly the same connections than before... and it worked.

    I'm totally out of ideas why booted showing video this time.

    Here are the logs of everything working

    -Using pastekodi via SSH:

    Using modetest | pastebinit via SSH


    Edited once, last by EloyFarina: Merged a post created by EloyFarina into this post. (February 12, 2024 at 2:00 PM).