Update system-tools addon

  • I usually do everything regarding my LibreELEC system from the command line (ssh), so I use the "System Tools" addon, under "Program Add-ons".
    Currently I have v7.0.100 installed, which doesn't provide midnight commander.


    I see here: LibreELEC.tv/package.mk at master · LibreELEC/LibreELEC.tv · GitHub
    that latest version is v7.0.103, which adds mc among others.


    My questions are:
    1) how do I update to this version of the addon? I tried updating from Kodi but it stays at version 100.
    2) how can I add more programs to this addon? I'd like to add ncdu, vim and git in the list :)
    3) I see no guides (maybe I didn't search enough) on how I could create a custom addon for kodi adding the aforementioned tools. Any info on the subject is welcomed.


    PS:
    I just switched from openelec, and I admit LibreElec is smoother, especially on my ancient RPi1. I have no idea about developing Kodi addons yet, but if there is a howto guide I'd like to try a couple of things. I see people mentioning I have to build libreelec myself, but this is not something I can do at the moment. Anything that you can share would be helpful.

  • Thanks for the link, sadly it doesn't answer any of the three issues I am trying to resolve.
    Neither does the conversation in the link.


    I am pretty confident that if I get the method to update the system-tools addons, I'll be able to create custom addons of the same logic (providing system packages) for Kodi.

  • bserem,


    There is no reason why you could not update system-tools to 7.0.103.
    Have you tried to update the LibreELEC Add-ons repository?


    As to adding add-ons, here is an example of how it is done.

    @

  • Thats what I thought, but when trying to update it (the repository) it says "currently no updates available".
    It is on version number 7.0.0
    The instalation of LE was done yesterday, using LibreELEC-RPi.arm-7.0.2.img.gz


    From your link, I get that if I create github repo, with this folder structure, and then add the source that I want in it, Kodi/LE will be able to install it somehow.
    I'm gonna give it a try, though I will probably have to install stuff from zip files. I guess github can't server as a repository.


    Thanks for the reply

  • The version of the LibreELEC Add-ons repository should be 7.0.0
    The version of the System Tools addon should be 7.0.2, which provides mc.


    As for addons, you also have to build them

    @

  • I can't seem to make "system-tools" go to v7.0.2, it doesn't find a new version.


    As for building addons, I already made the package.mk file like I want it, I now read on building! Thanks

  • I am afraid I do not really know how to build this thing. I can only build all of librelec, and for x86_64.

  • Yeah, you are right :)


    So, I:

    • cloned the Librelec repository
    • created a new folder, named power-tools, based on the existing 'system-tools'. It has a default.py file, icon and package.mk (just like LibreELEC.tv/packages/addons/tools/system-tools at master · LibreELEC/LibreELEC.tv · GitHub)
    • how do I build this, or make it a zip file that Kodi can understand?
    • the folder is under the rest of the libreelec structure (that provides a makefile)
    • I am on a x86_64 system. I am targeting a RPi1 (armv6)
    • is it possible to NOT build all of libreelec (takes ages) and only build the plugin? Not that I managed to build anything at the moment :D


    Thoradia seems to be closer to what I am trying to do. So I checked his/her repos:
    thoradia (Thoradia Quack) / Repositories · GitHub
    one is for prepared zip files (already built), and the other has a structure similar to the official libreelec git repository. Still, I found no information on how to go from there to zip files!


    It looks like I am missing some important steps, but from there on its just a matter of devotion to start making plugins.

  • I'm not sure why you're trying to build the add-on when it's already built and present in our repo. Solve the network (or whatever it is) problem that prevents you from downloading the add-on, then it will self-update. Put Kodi in debug mode and activate http logging and look at the logs for more information. If that doesn't show anything you can PM me your public IP address so I can see what's in our webserver logs.

  • The main reason is that I'd like to see how I can create an addon, and learn from the process.
    I also want to add ncdu, mc, vim, htop to my system, which is not available on the system-tools addon.


    However, you are correct about the updating issue.
    You have a PM! Thanks :)

  • *.*.158.199 - - [05/Dec/2016:23:58:56 +0000] "GET /7.0/RPi/arm/addons.xml.gz.md5 HTTP/1.1" 206 295 "-" "Kodi/16.1 (X11; Linux armv6l) LibreELEC/7.0 HW_RaspberryPi/1.0 App_Bitness/32 Version/16.1-Git:c327c53"
    *.*.158.199 - - [06/Dec/2016:09:56:14 +0000] "GET /7.0/RPi/arm/addons.xml.gz.md5 HTTP/1.1" 206 295 "-" "Kodi/16.1 (X11; Linux armv6l) LibreELEC/7.0 HW_RaspberryPi/1.0 App_Bitness/32 Version/16.1-Git:c327c53"
    *.*.158.199 - - [07/Dec/2016:09:56:16 +0000] "GET /7.0/RPi/arm/addons.xml.gz.md5 HTTP/1.1" 206 295 "-" "Kodi/16.1 (X11; Linux armv6l) LibreELEC/7.0 HW_RaspberryPi/1.0 App_Bitness/32 Version/16.1-Git:c327c53"
    *.*.158.199 - - [08/Dec/2016:09:58:00 +0000] "GET /7.0/RPi/arm/addons.xml.gz.md5 HTTP/1.1" 206 295 "-" "Kodi/16.1 (X11; Linux armv6l) LibreELEC/7.0 HW_RaspberryPi/1.0 App_Bitness/32 Version/16.1-Git:c327c53"


    ^^ Your box is querying the current 7.0 repo without issues (MD5 is checked, if the hash changed the full XML is downloaded). Your IP doesn't show up in error logs for the same period so I have to assume the issue is client side and the box is not querying for the updated add-on. Perhaps remove the Addons*.db file(s) and let it recreate the DB on next boot? .. and/or enable http component logging in Kodi and look there.

  • I had started documenting building packages and add-ons, but I have yet to finish.
    Hope this helps in the meantime

    @

  • Thanks chewitt! Removing the DB file didn't work either.
    I am updating to the alpha version of LE and will check if this changes anything.


    awiouy thanks for your link, I'm gonna give this a try
    [hr]
    Nah... the alpha bricked my system. I did a clean install (with the libreelec usb creator) and booted it.
    Still it doesn't find the system tool updates, even on the fresh install where I haven't customized anything yet.


    Are we sure this is not a bug?

    Edited once, last by bserem ().

  • I'm able to install any add-on I like from the 7.0 and 8.1 repos on an RPi3, Slice_CM3, x86_64 box, and WeTek Play2/Hub boxes, which means I'm fairly sure the repo is working fine. I'm going to ask again (last time) for a Kodi debug log with additional component logging on http so we can see what's being queried and the response given. Otherwise, no log = no problem.

  • Here it is, from the fresh installation. NOTE: I am on RPi1 (armv6).


    These lines appear in the log when I click on the addon name, open the dialog, click update, second dialog, select the one and only available version and click it to update.
    The CPLUFF line says it can't access a folder, the folder is there of course.
    The medium is a mostly-unused 32GB Class10 Sandisk SD Card.
    The hardware is RPi1 512mb RAM, clocked to 950mhz, with a HifiBerry DAC and a HD44780 LCD (pi pins: 22,18,17,23,25,25, gpio 27 which is suggested by tutorials produces sounds glitches on the dac on the 512mb version of the board)


    I don't know if I can share anything more with you :)


    Early next week I can get a new SD card to test if needed.
    [hr]
    Update:
    this url virtual.system-tools-7.0.103.zip which should be the one of the new version (right?), resolves to a 404 error

    Edited once, last by bserem ().