new LE user, lost my 2160P

  • So I took the plunge and upgraded from OE to LE (V7.90.008), and everything went great with one small exception. I no longer have 3840x2160P available as a resolution option. The resolution is not available to select.


    I have tried changing the refresh rate to 30 fps before trying the resolution, but no luck.


    4K worked fine with OE, but I cant make it work in LE. Nothing has changed in my setup or cabling.


    setup:
    Intel NUC 54250WYK
    miniDP-HDMI pigtail + High speed HDMI cable to HDCP2.2 port on sony TV (Video 4)
    Sony XBR55X850A


    Any tips or advice?


    Thanks.


  • can you post the output of the following command via ssh?

    Code
    xrandr | pastebinit


    I bought a ROKU premiere+. Was easier than trying to figure out how to ssh. It plays 4K movies seamlessly from my NAS.

  • ¯\_(ツ)_/¯ just trying to help


    Care to send me your unused NUC? [emoji13]


    thanks. appreciate it. why cant things just work? IM still using my NUC for plex media server. will try to make LE work too.


    let me figure out ssh
    [hr]
    Here's the output.


    Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 32767 x 32767
    DP1 disconnected (normal left inverted right x axis y axis)
    HDMI1 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 1220mm x 680mm
    1920x1080 60.00*+ 59.94 30.00 24.00 29.97 23.98
    4096x2160 24.00 23.98
    3840x2160 30.00 25.00 24.00 29.97 23.98
    1920x1080i 60.00 59.94
    1600x900 60.00
    1280x1024 60.02
    1280x720 60.00 30.00 59.94 29.97 24.00 23.98
    1024x768 60.00
    800x600 60.32
    720x480 60.00 59.94
    720x480i 60.00 59.94
    640x480 60.00 59.94
    HDMI2 disconnected (normal left inverted right x axis y axis)
    VIRTUAL1 disconnected (normal left inverted right x axis y axis)



    note: this was after swapping out HDMI cable and miniDP pigtail for mini hdmi to hdmi cable straight to tv. THe resolution now works. However, the LE box is really laggy playing 4k content. unwatchable.

  • Code
    xrandr --output HDMI1 --mode 3840x2160 --rate 30.00


    that command should kick it into 4k.


    Im not sure why kodi isn't detecting it.
    Can you post the output of

    Code
    kodi-xrandr | pastebinit


    after swapping to a straight HDMI cable it works. no need to manually code. somehow LE didnt like my mini DP - HDMI pup cable, while OE had no problems with it.


    still have major lag issues though (also on OE). Would love to make this work, but thinking my NUC is underpowered.

    • Official Post

    yes thanks

    Code
    10:52:35 T:140104080844544 INFO: ffmpeg[7F6C85F86700]: Stream #0:0: Video: hevc (Main 10), yuv420p10le(tv, smpte170m/bt709/bt709), 3840x2160 [SAR 1:1 DAR 16:9], 23.98 fps, 23.98 tbr, 1k tbn, 23.98 tbc (default)


    so hevc isn't supported by your hardware, it is trying to software decode the video and that cpu probably doesn't have enough horsepower


  • yes thanks

    Code
    10:52:35 T:140104080844544 INFO: ffmpeg[7F6C85F86700]: Stream #0:0: Video: hevc (Main 10), yuv420p10le(tv, smpte170m/bt709/bt709), 3840x2160 [SAR 1:1 DAR 16:9], 23.98 fps, 23.98 tbr, 1k tbn, 23.98 tbc (default)


    so hevc isn't supported by your hardware, it is trying to software decode the video and that cpu probably doesn't have enough horsepower


    weird. i'm playing a different hevc video right now. One where I reencoded the audio from DTS to AC3. Also, the video size is smaller on that one. That must make just enough difference that it can software decode.

  • after swapping to a straight HDMI cable it works. no need to manually code. somehow LE didnt like my mini DP - HDMI pup cable, while OE had no problems with it.


    still have major lag issues though (also on OE). Would love to make this work, but thinking my NUC is underpowered.


    I have this same problem, Intel NUC i5, Haswell. OE and LE 7 worked well with the mini display port DP1 in 4k/ 2160p; in fact, if I used HDMI, the resolution was selectable, but the screen would flash off at about 1Hz in 2160p/30. In 4K it was fine at any refresh rate. And, for the record, both my NUC i3 and i5 used to play 4k content at full rate, with no stutter/issues at all.


    Unfortunately the LE8 (beta) does not see the DP1 port resolutions at 4K - i thought it might have been because I was loading the new OE image into "Updates" and something in my old config was stopping it; so over the Christmas break I wiped the install and loaded a fresh copy. Unfortunately this made no difference. So I'm back to 2k.


    I use 4K because my screensaver is the picture slideshow and our photos are well above 4K so the higher resolution of 4K (over 2K) is very noticeable; not to mention photos look great in large (tv) size in high resolution compared to viewing on a small monitor.


    I am not near my NUCs at the moment, but I can dump an xrandr when connected to HDMI1, and DP1 tonight if that helps.

  • HDMI connected - 2160p an option, but does not work well on HDMI
    LibreELEC (community) Version: 7.90.010
    LibreELEC:~ # xrandr
    Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 32767 x 32767
    DP1 disconnected primary (normal left inverted right x axis y axis)
    HDMI1 connected
    1920x1080+0+0 (normal left inverted right x axis y axis) 1440mm x 810mm
    1920x1080 60.00 + 50.00 59.94 30.00 24.00 29.97 23.98*
    4096x2160 24.00 23.98
    3840x2160 30.00 25.00 24.00 29.97 23.98
    1920x1080i 60.00 50.00 59.94
    1680x1050 59.88
    1600x900 60.00
    1280x1024 60.02
    1152x864 75.00
    1280x720 60.00 50.00 30.00 59.94 29.97 24.00 23.98
    1024x768 60.00
    800x600 60.32
    720x576 50.00
    720x576i 50.00
    720x480 60.00 59.94
    720x480i 60.00 59.94
    640x480 60.00 59.94
    HDMI2 disconnected (normal left inverted right x axis y axis)
    VIRTUAL1 disconnected (normal left inverted right x axis y axis)


    power off, DP1 connected, power on - 2160p not an option (but used to be on previous LE)
    LibreELEC (community) Version: 7.90.010
    LibreELEC:~ # xrandrScreen 0: minimum 8 x 8, current 1920 x 1080, maximum 32767 x 32767
    DP1 disconnected primary (normal left inverted right x axis y axis)
    HDMI1 disconnected (normal left inverted right x axis y axis)
    HDMI2 connected
    1920x1080+0+0 (normal left inverted right x axis y axis) 1440mm x 810mm
    1920x1080 60.00*+ 50.00 59.94 30.00 24.00 29.97 23.98
    1920x1080i 60.00 50.00 59.94
    1680x1050 59.88
    1600x900 60.00
    1280x1024 60.02
    1152x864 75.00
    1280x720 60.00 50.00 30.00 59.94 29.97 24.00 23.98
    1024x768 60.00
    800x600 60.32
    720x576 50.00
    720x576i 50.00
    720x480 60.00 59.94
    720x480i 60.00 59.94
    640x480 60.00 59.94
    VIRTUAL1 disconnected (normal left inverted right x axis y axis)


    EDIT:formatting
    [hr]
    added --prop flag


    LibreELEC:~ # xrandr --prop
    Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 32767 x 32767
    DP1 disconnected primary (normal left inverted right x axis y axis)
    Broadcast RGB: Automatic
    supported: Automatic, Full, Limited 16:235, Video 16:235 pass-through
    audio: auto
    supported: force-dvi, off, auto, on
    HDMI1 disconnected (normal left inverted right x axis y axis)
    aspect ratio: Automatic
    supported: Automatic, 4:3, 16:9
    Broadcast RGB: Automatic
    supported: Automatic, Full, Limited 16:235, Video 16:235 pass-through
    audio: auto
    supported: force-dvi, off, auto, on
    HDMI2 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 1440mm x 810mm
    EDID:
    00ffffffffffff004dd9034201010101
    01180103809051780a0dc9a057479827
    12484c2108008180a9c0714fb3000101
    010101010101023a801871382d40582c
    45009f295300001e011d007251d01e20
    6e2855009f295300001e000000fc0053
    4f4e5920545620202a30370a000000fd
    00303e0e460f000a202020202020018e
    02034df0571f101405130420223c3e12
    16030711150206015d5e5f62260d0707
    150750830f000078030c001000b83c2f
    d08a010203040140007f203070809076
    e200fbe305df01e50e60616566023a80
    d072382d40102c45809f295300001e01
    1d00bc52d01e20b82855409f29530000
    1e000000000000000000000000000023
    aspect ratio: Automatic
    supported: Automatic, 4:3, 16:9
    Broadcast RGB: Video 16:235 pass-through
    supported: Automatic, Full, Limited 16:235, Video 16:235 pass-through
    audio: auto
    supported: force-dvi, off, auto, on
    1920x1080 60.00*+ 50.00 59.94 30.00 24.00 29.97 23.98
    1920x1080i 60.00 50.00 59.94
    1680x1050 59.88
    1600x900 60.00
    1280x1024 60.02
    1152x864 75.00
    1280x720 60.00 50.00 30.00 59.94 29.97 24.00 23.98
    1024x768 60.00
    800x600 60.32
    720x576 50.00
    720x576i 50.00
    720x480 60.00 59.94
    720x480i 60.00 59.94
    640x480 60.00 59.94
    VIRTUAL1 disconnected (normal left inverted right x axis y axis)

    Edited once, last by Madelaide ().


  • Looks like it will only work via hdmi at max 30hz


    With 7.90 yes, with 7.03, and OE before it, it worked at 4k fine for over a year.


    7.90 is a regression in this feature I believe.

  • Brand new to LE. Used to run FireTv. I too am not able to stream anything in 4K. When I change resolution it either goes Black or Green screen. I had no problem steaming 4K on Fire TV. Any suggestions would be appreciated. Thanks!


    Im running LiberELEC (Community)
    Version 7.95 Beta
    Architecture S905.arm
    Kodi 17.1-RC1 Esturary


    Currently have resolution set at [email protected] Hz