Real Time Clock for dual boot systems: switch to RTC

  • Hi all, I am currently using LibreELEC in my notebook in a multi boot environment. It is well known the issues with Windows 10 and UTC time.
    I have managed to switch to RTC in my Xubuntu partition, but am looking to switch my LibreELEC one.
    Can you please help me on what to change to have LE work with RTC instead of UTC (for the hardware clock).
    Otherwise everyone I boot to Windows after LE my time is off by 3 hours.


    Am using the x86 version.


    Thabk you and regards.

    Beelink MiniMX III 2GB/16GB gigabit LAN

    Edal T95Z Plus s912 2GB/16GB gigabit LAN

    LibreELEC running from SD card (will confirm version on post).

    Slowly being replaced by Intel NUCs (7th/8th gen i3/i5).

  • IMO not possible due to read only /etc file system.


    Think about changing Windows to UTC.


  • IMO not possible due to read only /etc file system.


    Think about changing Windows to UTC.


    Have already thought of that, things is that Windows apparently is now 100% ready for UTC time, so I'd rather switch my Linux boots to RTC.
    I guess it may be possible to symlink the required directory to be able to modify the clock setting.

    Beelink MiniMX III 2GB/16GB gigabit LAN

    Edal T95Z Plus s912 2GB/16GB gigabit LAN

    LibreELEC running from SD card (will confirm version on post).

    Slowly being replaced by Intel NUCs (7th/8th gen i3/i5).


  • Have already thought of that, things is that Windows apparently is now 100% ready for UTC time, so I'd rather switch my Linux boots to RTC.


    Which issues still do exist in Windows 10?


    Quote


    I guess it may be possible to symlink the required directory to be able to modify the clock setting.


    Only if you build LibreELEC yourself.


    In addition with local time set all three OS will try to correct the RTC on daylight saving time change.


  • I do not seem to find one of the articles listing the issues for Windows system and UTC.
    One of the things I have read is that you need to disable automatic time adjustment, and need a registry hack to set it up, so it may not be fully supported.


    In any case, I have tried the UTC time hack some time ago in my quad boot system without full success.
    Windows kept showing odd times.


    Now that I have figured out the proper setting for Linux I would like to keep it this way.


    A simpler approach would be to select a different time zone that matches my local time in RTC.

    Beelink MiniMX III 2GB/16GB gigabit LAN

    Edal T95Z Plus s912 2GB/16GB gigabit LAN

    LibreELEC running from SD card (will confirm version on post).

    Slowly being replaced by Intel NUCs (7th/8th gen i3/i5).

    • Official Post

    Copy the default file

    Code
    wget -P /usr/lib/udev/rules.d/80-clock.rules /storage/.config/udev.rules.d


    Then edit it to remove the --utc part. Save. Reboot.

    Edited once, last by lrusak ().


  • Copy the default file

    Code
    wget -P /usr/lib/udev/rules.d/80-clock.rules /storage/.config/udev.rules.d


    Then edit it to remove the --utc part. Save. Reboot.


    Anyone got this working on LibreELEC V8.0?


    I created the udev rule without --utc on both lines, however the log still shows that the clock is set to UTC.
    Additionally I tried adding the option --localtime instead of --utc but that made no difference either.