MPD Audio output

  • Does anyone have any pointers for getting this working? I've been tearing my hair out for the last couple of hours. I've got my library scanned and can access it using ncmpcpp on my laptop, the default config has this as the only uncommented audio output:

    Code
    1. audio_output { type "null" name "My Null Output" mixer_type "none" # optional }


    which I presume means that the audio is just being sent nowhere, but all kinds of fiddling with either an alsa or pulseaudio output just does nothing for me. I've been trying to follow the guidance on the archwiki but it hasn't helped, any setting to alsa does nothing whilst pulseaudio makes mpd fail to start.


    The really confusing thing is that aplay -l gives no soundcards found and pactl list only has one sink called Dummy Output that is suspended, I'm finding it impossible to even find an output to try and use.


    It's a raspberry pi 3, any help would be appreciated

    Edited once, last by SanpoChew ().

  • lucky I kept searching the forums! for anyone else, adding:

    Code
    1. dtparam=audio=on


    to your config.txt and uncommenting the ALSA example in the mpd config will get it working. From LibreELEC


    cheers lrusak if you ever see this

    Edited once, last by SanpoChew ().

  • This works for me, look at the very bottom of the file.


    I have disabled the audio device keep alive on Kodi.
    I use RPi1+Hifiberry.
    For your use I think line 215 is where you should start.
    Null output produces no output as far as I know.