Nexbox A95X (GXBB)

  • Hello,

    I have a old box (A95X) (got scammed when I got it a few years ago, it only has a S905(H) chip and NOT a promised S905X chip)

    I have had this box working with both Libreelec (Legacy V9.2) and Also Correelec legacy works, using the DTB : gxbb_p200_1G_1Gbit_RealtekWiFi.dts

    All hardware worked fine, also wifi.

    However watching live TV stoped working with this box with the Widvine changes :( a while back on the old legacy builds so I stopped using it.

    I now saw that with Libreelec 11 there again is official support for the S905 chips. (with some caussions but im fine with those)

    I flashed the generic box image : LibreELEC-AMLGX.arm-11.0.0-box.img.gz on a SD card,

    I tried adding the meson-gxbb-p200.dtb and the meson-gxbb-nextbox-a95x to the uEnv.ini file.

    Like this ;

    bootargs=boot=UUID=2702-0914 disk=UUID=5612844c-8868-4c79-9e43-7d438fe5dbe5 quiet systemd.debug_shell=ttyAML0 console=ttyAML0,115200n8 console=tty0

    At first glance all looks like its working except I dont have wifi.

    Is there any dtb file I can use that is 100% like the old gxbb_p200_1G_1Gbit_RealtekWiFi.dts

    I currently have no need for the wifi so its fine, but I might need it later and dont want to set everything up now if there is a way to get the wifi working before I start :)

    Any help is appreciated,

    thanks alot for adding the old chips back to the new release,

  • It probably requires the RTL8189 WiFi driver which is not available in the upstream kernel and LE will not be adding the vendor driver to the core image; we have a long-standing policy of not adding more downstream drivers that typically break with every kernel bump. That said, the driver is currently included in my own fork:….arm-11.0.0.tar

    I make no promises that the driver will remain in my images. If (as is normally the case) a kernel bump breaks it I will probably drop it.

  • Thanks alot for the very fast answer,

    I gues I have to use that file to build/compile the img to burn to my SD card ?

    I am a major noob about that, I have been reading a bit about it, but most guides/wiki's explain the complete building of my own image's,

    Is there some tool I can use to simply turn your files in to a img file for installing to SD without changing anything to the image ?

    If you can point me to a very good guide to simply build the img I will try to figure it out :)

    thanks alot,


  • Hi,

    Excatly in the same situation, I have an old 905 box (MXQpro4K) works fine with coreelec using gxbb_p200_1G_1Gbit_RealtekWiFi.dts. I flashed a new usb stick using LibreELEC-AMLGX.arm-11.0.0-box.img.gz my wifi stiil not working despite i updated like Chewitt explained. I can see RTL8188f (not the RTL8189) in the coreelec dmesg.

    I can read that in the coreelec dmesg : CoreELEC dt-id: gxbb_p200_1G_1Gbit_RealtekWiFi

    but what it is strange is that I have to use : meson-gxbb-p201.dtb to have Librelec working !!!

    Can someone guide me - is it a question of driver missing or firmware ?

    Thanks a lot as wrote Hansie for adding S905 back to the new release !

    Edited once, last by miltof: missing information (March 18, 2023 at 6:37 PM).

  • Hello,

    many thanks first for your answer !!!

    update done (I can see now Librelec (Chewitt) on my boot screen ...but wifi stiil not detected - only wire lan proposed.

    One thing I notice : if i use the "meso-gxbb-p200.dbt", I can read an error message during the reboot just after the installation - "fail to start ethmactool-config service" and here even the wired network not working. I do not have this message when I user p201, wired lan work but not wifi !

    keeping in mind that it wifi works with p200 in coreelect, what should I use p200 or p201 ?

    thanks a lot for your support !!

    fresh news added few minutes after my post;

    decided to restart from begininng to secure I did not miss anything :

    2 fresh usb key generated - 1 with P200 the second one with P201

    boot and install - P200 not network (even wired) - P201 only wired works

    update by putting the update file in storate/.update on both keys

    update done but at the end same situation (no network when using P200) only wired when using P201

    Edited once, last by miltof: more informaion (March 19, 2023 at 9:07 AM).

  • P200 is for internal PHY boards with 10/100 Ethernet. P201 is for external PHY boards with Gbit Ethernet (like your box). Cold boot the box with Ethernet connected, then SSH in and run "pastekodi" and share the URL generated so I can see the boot log. This will show if any WiFi drivers and firmware are being loaded (or not).

  • Hello sorry for late very late reaction - i understand more or less the cold boot proposed but will need to read a little bit to better understand details of the manipulation - I opened the box to see componenet confirmed that there is a realtek in.

  • Code
    Feb 16 18:10:58.938037 LibreELEC kernel: Linux version 6.1.14 (docker@af3b48037063) (aarch64-none-elf-gcc-12.2.0 (GCC) 12.2.0, GNU ld (GNU Binutils) 2.39) #1 SMP PREEMPT Mon Feb 27 21:44:00 UTC 2023

    ^ This tells me that you aren't booting the LE 11.0.0 image that I linked so there is no Realtek driver included. There is no support for the RTL chip in our main releases and that is unlikely to change. It is currently included in my private image.….arm-11.0.2.tar <= don't pay too much attention to the version number, it just means it's ahead of LE 11.0.1 official images.

  • Hello, thanks again for your time.

    What I did :

    download your 11.0.2 file and copy it in the STORAGE/.updated

    start to box .....tar archive found ....extract and update done

    box automaicaly reboot

    connect to ssh via wired and run pastlekodi :

    if it can help I did a pastekodi also with my old coreelec with wifi working

    Edited once, last by miltof (April 3, 2023 at 6:04 PM).

  • hello, just to secure my understanding :

    should I

    1 - restart from a fresh downloaded image from the download section,

    2 - upadte the uEnv.ini to meson-gxbb-p201.dtb

    3 - put the new update in the .update

    4 - update again uEnv.ini to "meson-gxbb-nexbox-a95x.dtb"

    5 - boot again

  • Code
    cd /storage/.update

    Please update again. That's ^ all you need to do. I think it should probe the right driver now; if yes it will probably fail to load firmware but that will show an error and we can see what's missing.