Minix U9-H freeze on kodi loading page / black screen

  • Hello!

    First of all thank you for all of you for the effort to make Minix U9-H usable again!!!!

    I downloaded the LibreELEC-AMLGX.arm-10.95.0-box.img.gz and used the LibreELEC USB-SD Creator to write it to an micro sd card. I updated the uEnv.ini to the correct neo dtb.

    When i start the box with "6 sec button method" than the Libreelec started to boot and the partitioning went well. After the restart i see the Libreelec logo for ca 20sec. After the Libreelec logo disappeared i see only a black screen, or the Kodi "load" screen.(I have not seen any screen like "Starting kodi the first time"). I restarted the device sometimes and always ended up with black screen or kodi load screen.

    To be sure that i did everything well i re-flashed the SD again, made the uEnv.ini changes and started to boot again.

    I left the box for 2 hours, and i still see the kodi loading screen so i guess it is frozen.

    On the box itself i am using the following: FW001 Android 7.1.2 20191120 [Community Edition Nougat Firmware] (…-firmware.2107/)

    Could you please help me with that? Should i flash the original FW to the box? Do you need any log files?(I guess i can see them if i take out the sdcard and read it on my PC).

    Thanks your help in advance!!

  • Go to Best Answer
  • If you see the LE and Kodi splash at some point HDMI/display probably isn't the issue. Edit uEnv.ini and add "ssh" to the boot params line. This forces SSH to run so you can login over the network. Run "pastekodi" and share the URL so we can see logs.

  • Thank you!
    I tried it and I see the libreelec device in the router ip list, but i can not ssh to it (I am using putty with port 22)

    I tried the win11 ssh as well:


    kex_exchange_identification: read: Connection reset

    Connection reset by port 22

    uEnv.ini looks like this


    bootargs=boot=UUID=2001-4326 disk=UUID=1f15e972-a53f-4d06-9d5f-a1195c38a657 quiet systemd.debug_shell=ttyAML0 console=ttyAML0,115200n8 console=tty0 ssh

    Edited once, last by thebence: add info (February 4, 2023 at 12:18 PM).

  • The box is clearly booting and SSH is running if the connection is reset (if it wasn't, it would time out). If you remove "quiet" from boot params it will dump text onto the screen. It will scroll fast so the trick is to record a slow-motion vidio on a phone and as long as you have a steady hand you can watch it back slowly to see if you can spot something. Another option is to add "textmode" and it will boot to a local console session (Kodi is not started) and with a USB keyboard connected you can poke around (run "journalctl | paste" and share the URL).

    For kicks, create a new SD card from…95.1-box.img.gz as there are some minor fixes for things and a newer kernel.

  • Hi!

    I downloaded the file and created a new SD.

    First I tried to boot it as usual, same result - kodi splash screen.

    After that I added the textmode as you wrote and booted it:

    For "journalctl | paste" i got this:

  • Keep the faith. My Minix U9-H is running this image very well off a fast SD card. There is an outstanding issue where I'm not getting passthrough of HD audio formats but I'm confident that will be resolved at some point. The one major difference that jumped out at me as I read your first post is that your box still has Android on the internal storage. Mine has Libreelec 17.6 on the internal storage which also still runs well. Android is long gone from my box. No idea if that difference is of any significance, but it is a big difference.

  • Code
    touch /storage/.cache/services/sshd.conf
    systemctl start sshd
    agent on
    connect <service_string>
    (enter pw when prompted)

    Running ^ that sequence of commands form the textmode console should enable SSH, start it, then connect you to a WiFi network instead of Ethernet, although from logs it appears SSH is running (as it was forced) and the Ethernet NIC is up/active and assigned 192.2168.1.76. Make sure that you're using a current version of PuTTY as support for ciphers does change over time.

    Then, to have more info on why Kodi isn't working, create /storage/.kodi/userdata/advancedsettings.xml with the following content (to put Kodi into debug mode) then reboot and run "pastekodi" and share the URL:

    <?xml version="1.0" encoding="utf-8" ?>
    <advancedsettings version="1.0">
      <!-- enable debug logging -->
      <loglevel hide="false">1</loglevel>

    Then maybe we get some insights on the problem..

  • Hi!

    I made the the changes in the connection as you wrote, I am using now the wifi connection.

    I created the xml file as well.

    I continued with a reboot command.

    After boot i ran pastekodi which have not returned any URL. (I have not used ssh/putty to login just wrote pastekodi to the same promt as i started to see after I added the textmode).

    1 thing which happened that the screen started to blink (sometimes 4 times a minute, sometimes once in 5 minutes) It started after I ran the commands and added the xml.

    I disconnected the ethernet cable and rebooted.

    To check if i am still connected i ran your commands. When i came to "services" i got no connection at all.

    Edited once, last by thebence (February 7, 2023 at 8:46 PM).

  • The whole point of "pastekodi" is to see whether Kodi is running, which it 100% isn't if the box is still in "textmode" boot, because that stops Kodi from running to give you a local terminal.

    If you are able to SSH into the box now? .. Clean install using a different SD card. Connect via Ethernet. Run "pastekodi" and get the URL back.

  • Hi!

    Clean install is ready (same sd card, I have only one at home). I made the usual changes which you recommended earlier in post #8.

    When i add textmode to the parameters than i can SSH to the box without any problem.

    But when i remove the textmode than i get the:

    kex_exchange_identification: read: Connection reset by peer

    Could it be the problem that the first run were never completed and some settings are not ready?

    When I removed "quiet" as well from the parameters, and left only ssh as additional parameter than i seen no error on the boot messages before the kodi load schreen appear. Only [ok], and some lines without any signal(as you see on the attachment).

    I have a video about the boot as well if you need it :)

  • If you boot to Kodi (and let it hang for a bit) then boot again to textmode and "cat /storage/.kodi/temp/kodi.old.log | paste" and share the URL that's generated, this will pastebin the previous Kodi log and might give some hint on why Kodi is failing to start. If the log doesn't exist there might be a kodi.log file in the same dir. I don't see anything in the screenshots so I doubt the video will be useful.

    It's most odd. User numbers are continuing to climb since the LE11b1 release so I know the box image is good. And there are other users with the same device ..

  • Hi Chewitt!

    Both kodi.old.log and kodi.log are empty :(

    Based on your last message "And there are other users with the same device .." I felt that you think there is some problem with my box. So we can give it up. I went back to an older FW (…-u9-h-008fw.43/) which is working mostly ok(not as good as LE does i guess :) ).

    I wanted to try if my box boots with an older LE (eg Libreelec as Senior Citizen wrote) but the download link in the forum ([] LibreELEC 8.2 for S912) is not working. Do you have maybe a link from where i can download it?

    Thanks for your help!

  • Just wanted to check in and say that I am one of those other users. I have exactly the same device, the same firmware (which I suspect is the culprit) and the same issue as the OP.

    I have been following this thread in order to see if a solution presents itself.

  • I'm doubtful the underlying Android (or legacy LE) firmware can be an influence as (from thebence screenshots) the box is clearly booting into LE which means vendor u-boot is really only responsible for some low-level power functions at that point; the kernel has taken over. And if we reach far enough into userspace boot to see the Kodi boot splash (sometimes.. it's a timing thing) it's most unusual for a virgin Kodi instance to not then reach the home screen. The usual reason for 'hangs' at that point are truncated DB files (rare on first boot, but it happens from time to time) but that's a simple thing to remove (with SSH access). To comment more, I really need to see some logs from a box, not photo's of boot screens as the output there misses a lot of detail.

    That said, if you're happy to reflash an original vendor firmware and repeat the install it will eliminate that from suspicion. I've put an updated image here…95.2-box.img.gz (ignore the version number)

  • Having the same problem with LibreELEC-AMLGX.arm-11.0.1-box.img.gz

    I can SSH into the box if I get it between when ssh starts and when the screen blacks out. However I only have a few seconds to do anything before it goes tits up.

    It appears something is going wrong with IO, and would explain why you can't SSH in after the issue (anything not loaded into page cache is unreadable).

    In any case, since IO is in a borked state, and don't have access to anything not in page cache, I'm not sure what info I can provide. However I did run dmesg before it died, so I do have access to that.

  • phemmer Ignoring the obvious I/O errors, the one thing that stands out to me is this:

    [ 1.557543] meson_uart c11084c0.serial: Failed to create device link (0x180) with wifi32k

    Most of the errors are I/O and look like a dying SD card or perhaps bad PSU that causes instability issues for the (known to be problematically sensitive) MMC devices: SD/eMMC/SDIO. The failure of the wifi32k device to probe right means WiFi (SDIO) will not work, but oddly the other UART based device, BT, appears to proble. Most odd. Another possible cause is the MMC clock speed being too high, but it's only 100MHz (default in the upstream kernel is 50MHz) and it's been stable at that rate with other devices (stats show other U9-H users) so I don't think that's the reason. If the device has been booting CE or Android fine that would generally rule out PSU issues; they would likely show up in other OS too.

    Please put this on a new/different SD card….0.2-box.img.gz and see if you can grab the boot log again. I'm not seriously expecting anything to be different but it has some additional patches and a newer kernel than the official release so you never know /shrug