Add-On Repository Problems 2024/03

  • We are currently having problems with our add-on repository.

    If you have any problems (can't download add-ons, add-on updates are not working etc) with the repository then please let me know here.

    March 13, 2024 at 8:16 PM
  • Tried to download TVheadend HTSP client from official libreelec addon repository. Installation fails.

    TVheadend 4.2 service/server download worked.

    libreelec 10.0.4 on Rpi3


    Edited 3 times, last by Astro98 (February 4, 2023 at 2:39 PM).

  • I have the issue. Please see the log below, my ip is x.x.4.144

  • Issue still seems to be present :(

    I.P. X.X.152.148

    Rasberry Pi 3B+

    LibreElec 10.0.4

    Kodi and other Repos work fine.


  • Still not working, ip address x.x.242.15

    kodi.log errors:

  • I adjusted again and hopefully this is now stabled enough.

    Just to get some background, we are facing some kodi bug that creates a lot connections and A LOT traffic so we try to workaround to minimize the impact.

  • Edit 08/02/2023 14:46 : Working ATM.

    Problem still on going.

    Ip : x.x.232.32

    Edited once, last by Nickoos: Adding ETA (February 8, 2023 at 1:46 PM).

  • LibreELEC 10.4 on a PC machine. Currently I can install any Kodi addons, but cannot enter LibreELEC Add-ons repository at all, says "Could not connect to repository". My IP is

    Before that I had an "installation failed" error on most LibreELEC add-ons (Chrome and System-tools would fail, but for some reason I was able to install everything from the Audio encoders section). I reinstalled the system since then, didn't realise it wasn't a problem on my side. I do remember seeing the 429 error for Chrome installation in the logs and error (22) for system-tools

    Here are the logs:

  • So seems like there's a daily quota for addon installs, and it's fairly low. Today I've managed to install Chrome, enable repos and installed under a dozen emulators before I started getting installation fails again.

    I mean, normally it would be okay, but I did a fresh install just yesterday, so there are quite a few things I wanted to set up.