Run LibreELEC in virtual machine without real gpu

  • Hello


    Is it possible to run LibreELEC without a real GPU?


    Here is some Background:


    I have a small server that runs proxmox with some containers and services.

    I want to us it's soundcard in a dedicated media vm - this is not a problem (the passthrough works)

    This media vm should be able to play spotify via spotify connect, play internet radio and youtube files - all of this works with LibreELEC BUT ONLY when a dedicated gpu is attached to it.


    What i really want is to have this media vm without the dedicated gpu attached to it and use instead a virtual gpu to have this LibreELEC instance just as an audio player.


    Is this somehow possible? (I know that this is also proxmox related)


    According to this thread it works with vmware:
    VirtualBox: failed to start xorg. is your GPU supported?


    Kind regards

    Edited once, last by e-ru ().

  • The OVA image we spawn from Generic images is designed for vmware to make booting in a Desktop environment simple, and with the sole purpose of supporting development of project GUI items like the settings add-on. Any other kind of platform or use-case is deliberately "not officially supported" to keep project maintenance simple. Over time the number of other environments it might work in has probably grown, but we do not test that image much, have no intention to start testing it much, so anything that happens to work is accidental.


    In all cases LE needs to boot with a supported GPU, which is either real hardware mapped for our use, or one of the working virtual GPUs in the kernel. The Generic kernel defconfig is probably missing drivers for whatever GPU that proxmox uses; or the GPU that is there doesn't support the OpenGL video pipeline that Kodi requires.


    /shrug

  • Hello thanks for your replies. I was able to run LibreELEC without a dedicated gpu by setting the display setting in proxmox to "VirGL". it's a quite new feature that was introduced in proxmox 7.2. VirGl provides the needed OpenGL functionality. I'm very happy that is works now.


    Keep up the good work and a happy new year!!

  • works with both

    I quickly tried it but it does not work, I am stuck at a reboot loop. I just see it booting and thats it.


    Is that setup correct ?

  • Hello CvH you need to follow the instructions from the tails tutorial i mentioned in post number 5


    this is the hardware config that works for me


  • Hello CvH you need to follow the instructions from the tails tutorial i mentioned in post number 5

    The import disk to vm part is not that difficult but I have no luck in running it.

    As soon I switch to uefi/q35 I am not able at all to boot from the LE.img anymore. If I run it with your settings I end up at the efi loader.

    I switched the boot order to boot from the LE.img.


    Running it with i440fx/pc35 and SeaBios I can even install LE, but it does not run past the LE bootscreen.

  • best thing would be to delete the existing vm and completely start from scratch and follow the tutorial from post number 5 step by step. this should work