LibreELEC 10.0.2 causes crashes and reboots

  • Hi there,

    someone deleted my request with the same title because of "fake-log" (?!), so I try again and post the link to the log at first. It is no fake-log and created like described here (wiki log files). Please do not delete this request again. I never posted something in this forum before. If something is wrong with the post or log, please let me know, so I get the chance to correct the issue.

    I just installed LibreELEC 10.0.2 (stable version) on my Raspberry PI 3B and figured out that the Raspberry PI reboots during some operation. Best reproducible is to scroll fastly through my music-library in WALL or InfoWALL-mode with about 130 album-pictures over all.

    After that I set up LE10 again with the latest nightly build (LibreELEC-RPi2.arm-10.0-nightly-20220828-7689d67.img.gz) completey from scratch. I built the music-library completely new. I did only some basic settings like language, keyboard layout, network (LAN) and so on (all manually). There are no imported settings or libraries from the old system. This did not fix the problem. The Link to the log-file above shows is about this nightly build and the reaction of LE10 during scrolling through the music-library in WALL-mode.

    So far I can see, I found this error messages in the log-file:

    Aug 28 20:13:08.977558 LibreELEC-10 kernel: [drm:vc4_bo_create] *ERROR* Failed to allocate from CMA:
    Aug 28 20:13:08.978027 LibreELEC-10 kernel: vc4-drm soc:gpu: [drm]                            V3D: 195472kb BOs (108)
    Aug 28 20:13:08.979413 LibreELEC-10 kernel: vc4-drm soc:gpu: [drm]                     V3D shader:     44kb BOs (11)
    Aug 28 20:13:08.980725 LibreELEC-10 kernel: vc4-drm soc:gpu: [drm]                           dumb:   4052kb BOs (1)
    Aug 28 20:13:08.981795 LibreELEC-10 kernel: vc4-drm soc:gpu: [drm]                         binner:  16384kb BOs (1)
    Aug 28 20:13:08.982560 LibreELEC-10 kernel: vc4-drm soc:gpu: [drm]                total purged BO:  56952kb BOs (15)

    I tried also, like described in one similar thread, to change the CMA by setting:

    dtoverlay=cma,cma-512 (in the file /flash/config.txt)

    But this also did not help.

    Do someone know, how to fix that or if that is a known bug in LE10 or can help somehow else?

    Thanks a lot in advance!

    Best Regards


  • This time the log is fine. Your fake log was a link to the same thread. Probably just a glitch.

    DNB music-addicted finger drummer.

  • You haven't enabled debug logging so it's a bit hard to tell what really went wrong in your case but my guess is this is the long standing issue with kodi trying to create too many scaled-down thumbnails on the fily and thus exhausting (graphics) memory.

    You could try running c, this will take a while and create thumbnails in a way that shouldn't trigger the issue - after that browsing should work fine.

    Increasing CMA memory (that's the kind used for graphics) could remedy the issue a bit, too but probably won't help as much as creating all thumbnails upfront - add eg dtoverlay=cma,cma-512 to the end of /flash/config.txt

    so long,


  • Hi Hias,

    thanks for your comment!
    I activated debug-logging and reproduced the reboot again. The log is stored under:

    If this log shows not the information you need, please advise how to create the debug-log correctly.

    As I wrote I tried already dtoverlay=cma, cma-512 without any result. Unfortunately I was also not able to check if the CMA was really increased. I tried the command cat /proc/meminfo but got no other values than without the dtoverly-command.

    I do not really know how to use texturecache, but will follow this hint.

    Anyway the reboot takes not place during the creation of the thumbnails, but when scrolling through the already created ones. In LE9.2.8 the scrolling hangs sometimes for a second but then proceeds, in LE10 a reboot takes place.

    The reboots takes also place during other operations like using some Add-ons for ARD and ZDF-Mediathek (but it is not so reproducible like the scrolling through the music-library).

    Currently I will stopping building-up a LE10-system on RPI 3B until this is fixed or a stable workaround has been found, because it will reboot within short time of usage and therefore it is not usable in "productive environment". This a pitty, because I really would like to upgrade because I would like to use some addons only working with LE10.

    Best Regards