LibreELEC with Intel AX210 PCI-e card. Wifi works but Bluetooth doesn't

  • lspci | grep -e Intel

    03:00.0 Network controller: Intel Corporation Device 2725 (rev 1a)

    dmesg | grep -e Blue output:

    [ 208.712549] Bluetooth: hci1: Reading Intel version information failed (-22)

    [ 208.712554] Bluetooth: hci1: Intel Read version failed (-22)

    [ 208.712607] Bluetooth: hci1: Intel reset sent to retry FW download


    I tried copying this firmware .ucode: https://wireless.wiki.kernel.o…wifi-ty-59.601f3a66.0.tgz

    to

    /storage/.config/firmware and it seems to get to the overlays correctly but still doesn't load.

  • I've tried adding:

    Kodi-Salon:~/.config/firmware/intel # ls -lah

    -rw-r--r-- 1 root root 13 Jun 23 12:55 ibt-0040-0041.ddc

    -rw-r--r-- 1 root root 730.1K Jun 23 12:55 ibt-0040-0041.sfi

    -rw-r--r-- 1 root root 9 Jun 23 12:55 ibt-0041-0041.ddc

    -rw-r--r-- 1 root root 671.3K Jun 23 12:55 ibt-0041-0041.sfi


    To no luck :(

  • 10.0.2 Generic with a 5.10 kernel which should normally supports the AX210 both wifi and BT.

    Looks like the firmwares weren't there and adding them doesn't solve the issue. btintel.ko module is loaded but modinfo indicates it doesn't use the right Bluetooth firmwares


    I'll get a dmesg pastebin and btintel modinfo after work :)