Adding boot parameters to the rpi (and any arm build probably)

  • I am now on multi-user.target, logged in via ssh and running memtester again with 850mb this time. Launching le there does not make much of a difference memory wise, because it now idles at 60-65mb.


    Leaving that aside, I am now very upset at the rpi. Last time, I had it right next to me, so that it has proper wifi signal and get my job done faster. When I was done, I shut it down and I unplugged it from the power socket.

    I reconnected it now, waited for it to boot without for like 5 minutes, but it did not connect to the wireless network or at least it did not any ip from the router which is like 1m away! I repeated the procedure 3 times with no luck, then I got mad and got it back to the tv where I had to reenter the wifi key once more to make it connect.


    What is worse is that every time I put it on the tv, I move the antenna cable so slightly and some air-transmitted channels get artifacts. Now I am at the point that the ones that had low signal quality now are no longer available :P


    ---edit

    The poor wifi signal made the ssh connection drop, so I had no way to stop memtester, so I simply unplugged the rpi from the wall.

    I got it back on my desk, it connected on first try and I am now retrying...

    Edited 2 times, last by jim_p ().

  • Another run of memtester was completed with no issues on Saturday, but I forgot to report back. I connected to it wirelessly, did the upgrade to 20220528-84fdbeb on Sunday and nothing else for that day.


    And today, I started the day (Monday 30th of May, ~7am) with testing. I got the rpi next to me again, powered it on and even after 2 minutes it was not visible anywhere. Pinging its .local name (I use zeroconf everywhere on my network) returned that the host is unreachable. It was not visible under the router's connected clients too, so I unplugged and replugged it.

    Same thing happened after the reboot, so I had another idea. Leaving the rpi on the same spot, I tried the sdcard with lakka on. It booted with no issues, connected wirelessly and I could see it under connected clients. I ssh-ed to it and shut it down properly.


    Then I got an ethernet cable and connected it to my router, hoping to get a reliable wired connection. It showed up for a few seconds under connected clients and it suddenly dissappeared. Disconnecting the end of the cable from the rpi's end only and reconnecting it gave a stable wired connection. I ssh-ed to it to run ifconfig -a only and saw that the wireless was completely disconnected!


    I sweared a bit and moved on for today's upgrade (20220530-2d50f5f). I downloaded the tar file, checked its sha256sum, it was correct so I rebooted. And after the reboot it was still on yesterday's version...

    I connected ssh-ed to it again to start over and while it was downloading the update file again, it got disconnected and reconnected with a different ip! First time on wired it was 192.168.1.142, second time was .143 and third time it was .144.

    I know from experience that *elecs request a new ip from the dhcp server although their lease time has not passed (I have mine set to 1 day), so the above is now normal behavior.

    The file was downloaded completely, its checksum was checked again, it was correct again, but no update happened again. I am now downloading it for the third time and I will give up if it fails again.


    ---edit

    Oh look it worked! And with that third try, I am now on 20220530-2d50f5f after 30+ minutes of trying something that would take 5 at most.

  • I just noticed the following. While disconnected from the wifi, if I go to libreelec settings > connections > my wireless network, the options say connect, edit delete and refresh.

    Notice the ones that say edit and delete, because they mean that the wireless network is already stored in connman's settings. For a wireless network that is not stored, e.g. my neighbor's, the options are only connect and refresh.

    When clicking connect on the first situation, i.e. when the network is already stored, the user is asked to reenter the wireless key.


    So i moved to the old laptop, which is like 2m away from the router and has very good signal, to check what happens on le 9 and 10 (both x64) under the same menu. I disconnected from the wifi, clicked connect and both installations did not ask me to reenter the wireless key. Could this be a bug of le 11?


    I am asking because it is really weird to have the rpi right next to the router, with 70/70 signal quality (as reported by iwlist scan) and sometimes having to use the cable because it does not connect automatically.

  • If le 11 can boot from ventoy AND work in persistent mode, why not.

    As for the rpi, probably not due to my lack of sd cards :(

  • Not sure what ventoy is but you can boot from an USB stick on x86.


    Concerning RPi and your filesystem corruption issues I'd say the 10 bucks for a Sandisk 32GB SD card might be a really good investment and could save you a lot of time.


    so long,


    Hias

  • Ventoy is a tool for creating bootable usb drives that boot straight from iso or img files. You install ventoy on the stick, you copy any iso or img on the stick, boot from it and ventoy allows you to boot the system from any of them by mounting them first. For me, who has been using isos on usb sticks since pcs allowed booting from usb, it is a real lifesaver.

    Ventoy
    Ventoy is an open source tool to create bootable USB drive for ISO files. With ventoy, you don't need to format the disk again and again, you just need to copy…
    www.ventoy.net


    I am 100% sure ventoy can boot the le img file because I tried it on a very first nightly of le 11, when it was still on kodi 19. What I do not know is if it can use persistence, because it would be mandatory to store settings, i.e. my wireless network and its key.

    If not, I will have to use another stick, because the ventoy one has isos in it, and flash the img with rufus.


    File system corruption has happened once (maybe twice) since I reflashed the img file on the card. I check dmesg for relevant messages a few times a day and I have not seen a sign of it for days now. And I boot the rpi like 5+ times a day :P

    Also, it is not for the cost of an sd card, its for the wasted space. The 32gb sd card that came with my rpi3b bundle was like 95+% empty (not counting the default 5% of each partition size that is reserved by ext4) back when it had le 9 on it, because I was only using it for streaming. It only had ~200mb of the le installation on mmcblk0p1 and like 100mb of kodi stuff on mmcblk0p2.


    In other news, I continue troubleshooting the wifi, so after it did not show up in my router at today's first boot (right next to the router, so wireless quality was 100% surely), I connected it via ethernet and sshed to it.

    Then I had the idea of reconnecting the wireless interface via connman, so I followed arch wiki's instcructions here*. And it reconnected without asking for the key, which means that connman had stored the network credentials and skipped the last step completely. 2 cold boots later and it still connects wirelessly with no issues, but I will wait and see how it goes this afternoon or tomorrow.


    * https://wiki.archlinux.org/tit…_a_protected_access_point

  • RE : uSD cards - I've had issues with Sandisk and Kingston. I always use Samsung these days. Have had far fewer issues with them.

  • Unlike ssds, where I have used products from all those 3 manifacturers and I am equally satisfied in terms of vfm (because samsung ssds are quite more expensive) from all of them, I do not recall using a samsung sd card (or a usb stick) ever. However, they always were an option when I was searching to buy one.


    About the x86 img.gz files. Can I flash them to a usb disk by just running

    Code
    zcat le-something.img.gz > /dev/sdc

    or, assuming I have extracted the img file from the img.gz,

    Code
    dd if=le-something.img of=/dev/sdc

    (as a root that is). I am too busy to reboot my system to windows and use rufus right now.

    Edited once, last by jim_p ().

  • zcat should work fine, I've used it myself a lot of times to create fresh SD or USB media.


    YMMV though, ISTR some people reported that their linux desktops doing media autodetect while writing the image interfered (didn't have that issue myself yet).


    Regarding x86: when you first boot from a fresh USB media you get a choice of 3 modes: install, live and run - the latter will create a persistent storage partition on the USB drive so that's what you probably want to use.


    so long,


    Hias

  • I am off to try zcat then. I went with the ventoy option first, but I ran on this issue here.

    [issue]: Latest LibreELEC generic image does not work · Issue #1268 · ventoy/Ventoy
    Official FAQ I have checked the official FAQ. Ventoy Version 1.0.61 What about latest release Yes. I have tried the latest release, but the bug still exist.…
    github.com


    ---edit

    This is gonna take a while... The nightly does not list the laptop's wireless under connections and it can only connect via ethernet. Here is what lspci -k (because I thought it would use b43 instead of wl) and dmesg say about it, and it is identical to what le 9 and 10 say too

    Code
    04:00.0 Network controller: Broadcom Inc. and subsidiaries BCM4312 802.11b/g LP-PHY (rev 01)
    Subsystem: Broadcom Inc. and subsidiaries BCM4312 802.11b/g LP-PHY
    Kernel driver in use: wl
    Kernel modules: wl
    
    
    # dmesg | grep wlan
    [    7.143290] wlan0: Broadcom BCM4315 802.11 Hybrid Wireless Controller 6.30.223.271 (r587334)


    In other news for the rpi, I noticed earlier that the wireless gets disconnected once the ethernet wire is connected. Disconnected as in "it no longer appears on my router's connected clients list". I assume (and hope) this is some connman setting that prefers wired over wireless, so it disables it.

    Edited once, last by jim_p ().

  • And connman just decided to bite me back :P It did not connect wirelessly at first, so I connected the ethernet cable and sshed to it to try connman like yesterday.

    Code
    connmanctl> agent on
    Agent registered
    connmanctl> connect wifi_b8xxxxxxxxxx_47xxxxxxxxxxxxxxxxxxxxxxxxxxxx_managed_psk
    Agent ReportError wifi_b8xxxxxxxxxx_47xxxxxxxxxxxxxxxxxxxxxxxxxxxx_managed_psk
    invalid-key
    Error /net/connman/service/wifi_b8xxxxxxxxxx_47xxxxxxxxxxxxxxxxxxxxxxxxxxxx_managed_psk: Input/output error
    Agent request cancelled by ConnMan

    That input/output error is what I have been getting as a notification upon failed connection on libreelec since I first installed it on the rpi, back in 2019 and I always blame its poor wifi for it.

    Note that the key is fine, I double checked it on /storage/.cache/wifi/wifi_b8xxxxxxxxxx_47xxxxxxxxxxxxxxxxxxxxxxxxxxxx_managed/settings, where it is mentioned as "passphrase" and written in plain text. And I have checked it like so in the past as well.

  • Can your grab logs after a wifi connect fail? Usual "pastekodi" log will do fine.


    LE master recently switched from wpa_supplicant to iwd and I'm wondering if that might be related.


    so long,


    Hias

  • If by logs you mean just dmesg, then yea. Here you go. It is connected via ethernet and it is right after a cold boot which failed to connect wirelessly (cold boot > no wireless > unplug from power > connect ethernet > plug power back). Please ignore the cec timeouts, it is not connected to the tv.

    http://ix.io/3Zcv


    As for the wpa_supplicant vs iwd, when was this change made? I am still on yesterday's nightly (20220531-0e57a30) and I am waiting for new images to show up in the main folder of test.libreelec.tv (= not in the hotdog subfolder).


    And now that I posted the dmesg, I will retry connman and if it won't work, I will remove the forementioned folder with the settings related to my wireless network and start over.

  • No, by "pastekodi" logs I meant "pastekodi" logs :)


    dmesg doesn't help much, pastekodi includes journal (which might give some clue) and other useful info


    so long,


    Hias

  • You are right.The above was the output of

    Code
    dmesg | pastebinit -

    because

    Code
    dmesg | pastekodi

    returned some error. Anyway, I do not want to post something that includes kodi's log because I am now checking if or how some addons work on kodi 20. If there is another thing I can paste for you, I will.


    Back to connman, which is still biting me back

    Code
    connmanctl> connect wifi_b8xxxxxxxxxx_47xxxxxxxxxxxxxxxxxxxxxxxxxxxx_managed_psk
    Agent RequestInput wifi_b8xxxxxxxxxx_47xxxxxxxxxxxxxxxxxxxxxxxxxxxx_managed_psk
    Passphrase = [ Type=psk, Requirement=mandatory ]
    Passphrase? thewifikey
    Agent ReportError wifi_b8xxxxxxxxxx_47xxxxxxxxxxxxxxxxxxxxxxxxxxxx_managed_psk
    invalid-key
    Error /net/connman/service/wifi_b8xxxxxxxxxx_47xxxxxxxxxxxxxxxxxxxxxxxxxxxx_managed_psk: Input/output error
    Agent request cancelled by ConnMan
    Retry (yes/no)?

    The wifi key is obviously correct. I am now rebooting the router just in case.

  • Just run "pastekodi" and post the URL you got. We can't provide any more help if you don't provide full, unredacted logs.


    so long,


    Hias

  • Ok, just don't complain about my third party addons and repos. They are not gonna be removed until I decide to stop using the nightly.

    http://ix.io/3ZdM


    ---edit

    And it connected wirelessly after I rebooted the router. I am now searching the router's log for something like "access denied to mac b8xxxxxxxxxx".

    Edited once, last by jim_p ().