Where can I find info on nightlies or LE v11 dev roadmap?

  • So I have a couple of x86 boxes pulling data from the same Maria dB.


    I built a small replacement 1u box as my main system but discovered LE10 doesn't support the Intel chipset/GPU.


    I tried a v11 nightly and it did support the GPU but did not support HDMI audio out. I figured I would pull the Radeon GPU from the x86 box it is replacing and just run v10 for now.


    The only way I could get the GPU in the 1u case is to put the OS on an nvme drive built into the MB. But v10 can't see that drive because v10 doesn't support that chipset yet (ASRock H510M-ITX/AC LGA 1200 Intel H510).


    I'd really like to follow along with v11 dev and see how builds are coming along, get filled in on the roadmap.

    Edited once, last by AGLyons ().

  • AGLyons - LE11 pretty much tracks the kernel releases, usually a kernel update ~ once a month. Kernel 5.18 will be next.


    The package updates are in GitHub - https://github.com/LibreELEC/LibreELEC.tv/pulls.


    My development tree is https://github.com/heitbaum/LibreELEC.tv/tree/dev for which commits may/may not be planned/scheduled to go in. I update all packages, but my x86 focus is GBM - and Intel specifically. Some of the other developers run other graphics chips (and X11/vulkan)


    I run a tiger lake i7 with both hdmi audio and passthru.


    To get a “functioning” Gen11 cpu. At least kernel 5.12 - but realistically you will want nightly, which includes updates to the graphics subsystems - wiki here - https://wiki.libreelec.tv/hardware/intel-x86-64-generic

  • hey @heitbaum,


    Thanks for jumping in!


    So I'm not a dev really but I do know enough to cause serious system problems lol


    If I wanted to give your build a go how would I build the USB key? I tried a nightly build a while back, LE11 X86 04-02-2022 and while it did recognize the GPU, it did not see the HDMI audio out. Perhaps that's been resolved. I haven't checked a new build yet

  • All the parts that you are wanting will be in the current nightly. There have been lots of updates since February. My dev tree is probably not a good place to learn building you own LE image. If you are going to build your own - start with your own fork of the main tree and then add your changes to it.

  • How far off do you think v11 is?


    I just tried today's nightly and I still can't things up and running right.


    None of the default shares are present, at least Win can't access any of them for some reason. I even went down to SMBv1.


    I managed to get a copy of my advancedsettings, mediasources, sources and passwords XML's over and it took them. I then defined the media folder contents and that's when things blew up. Reboots would freeze the Kodi splash screen for about 2 minutes before the UI would come up. None of my content showed up after that.


    I then got smart and thought I would put my GPU back in and stuff the SATA SSD with my existing 10.02 in the case. But that wouldn't boot as I totally missed that 10.02 wouldn't support the 11th gen chipset. I get the suslinux line and that's it.


    I don't think I'll be able to put this box in production till v11 is out or if someone has compiled Kodiv19 with a 5.18 Kernel.


    I'd do this myself but I haven't the first idea of how to start.

  • There is a known samba issue. See the GitHub, that we are working through. You can go to the shares directly. The browse is the issue.


    LE11 is a ways off.


    from a hardware support perspective - it sounds like nightly was working fine? <please confirm> Happy to help work through this - but this needs to be step 1, and ensure stability. We have had good success with Intel Gen11 CPUs with nightly, so will want to check this is ok in your hardware first, with your motherboard hardware.


    As you indicated - something blew up, was that adding some of files back manually? (🙂 my crystal ball is broken without seeing logs….)


    If you are assembling a Frankenstein software then you will need to be able to stop kodi, move the .kodi directory out of the way, start kodi, and try, try again.


    Check the journalctl and kodi.log, etc ….

  • ok, round 3. This time it's the MB and nvme drive by itself. No AMD GPU.


    Installed todays nightly. First thing I came across is selecting option 1 at the install screen returns "Failed, no such file or directory"


    Install did complete and this time instead of adding my advancedsettings.xml, I manually added source folders. I'll have to wait till general release of v11 to use the external DB.


    All the files scraped properly and playback is working, both audio and video.


    Now, I wish there was a simple way to copy the skin settings so I don't have to rebuild the UI each time I install a new box. I use Aeon Nox:Silvo. Is there a simple approach you use?


    A.

  • Glad that it is working. In the /storage all the configuration is stored. If you are trialling (trying to get to the why the addon isn’t working…) you will want to keep a “working copy of” this as you experiment. You can stop and start Kodi from the prompt using systemctl stop kodi - and systemctl start kodi. The update process to the next nightly will keep your settings in place, etc. you can always revert back to a working in your situation nightly, as long as you keep a copy of the img.gz file around.

  • as long as you keep a copy of the img.gz file around.

    AGLyons I use a small script to manage that.

    the script fetches a new nightly (the *.tar) and keeps a copy in ~/backup.

    cleaning of ~/backup is up to your own ...



    copy the content of the "code box" into a file, and name it, let's say "get_nightly.sh".

    chmod u+x get_nightly.sh to make it executable


    and run it - after ssh'ed into the box with:

    ./get_nightly.sh


    shortcomming's:

    - script doesn't distinguish between new nightlies with same git tag and different date. what leads to a 2cd download...

    - my thinko's I did in the script

    - warranty does not exit !

    Edited 3 times, last by GDPR-7 ().

  • Hey Joeaverage!


    So I made the script (thanks!). Saved it to the storage folder and chmod the file.


    I tried calling it and putty just returned "can't find the file". I tried moving that to the user folder (one level up) and couldn't do that as the file system is read-only.


    I moved the sh file to the downloads folder and tried to run it there. Again, can't find file.


    I'm not sure how to execute this.


    Also, is it normal that stopping Kodi also kills all samba shares?


    Once it's stopped I can't get to any files with my Win10 laptop.

    Edited once, last by AGLyons: Merged a post created by AGLyons into this post. ().

  • 1. I ssh into my LE, ( I had a typo in comment #9, wrongly wrote ssd'ed - me old idiot :cry: -)

    2. cd to the folder where the script is

    3. and run the script from there with


    ./get_nightly.sh


    note the point in front of the slash ("/") !


    the script just downloads the last nightly into ~/.update (script line 32+34) and additional copies it to ~/backup (line 36) and then offers you to run the commands "sync && sync && systemctl reboot" (line 38).


    it offers only !

    if you don't run the offered commands nothing will happen until you reboot the box.

    only during reboot the last nightly in ./update will get installed and the folder ./update will emptied from the update-installer


    the scripts doesn't stop any service, e.g. smb.


    hint:

    on linux you could just mark/highlight the command "sync && ..." with your mouse and now do a middle-click to copy it for subseq. execution with the Enter-Key

    Edited 3 times, last by GDPR-7 ().

  • Hmmmmm Problems


    I managed to get the script in and I can run it. But it keeps saying there are now new nightly builds



    Code
    LEv11:~ # ./get_nightly.sh
    Connecting to test.libreelec.tv (5.9.116.10:443)
    saving to 'releases.json'
    releases.json        100% |*********************************************************************************|     2  0:00:00 ETA
    'releases.json' saved
    
     No new nightly
    
    LEv11:~ #


    It's clear I am running an older nightly 05-02-2022.


    Code
    Using username "root".
    ##############################################
    # LibreELEC #
    # https://libreelec.tv #
    ##############################################
    
    LibreELEC (community): nightly-20220502-907d2d6 (Generic.x86_64)


    The latest I can see in the list is LibreELEC-Generic.x86_64-11.0-nightly-20220723.




    Any ideas?



    EDIT - releases.json is blank. That's why there are no new releases.


    https://test.libreelec.tv/releases.json


    chewitt - Do you know of any reason why the releases.json is not getting updated? Has that file been abandoned or could there be a bug somewhere?

    Edited once, last by AGLyons ().

  • AGLyons we are in the midst of moving to the final (updated servers)


    test3 is now test as of last night.


    The new server has the additional storage to hold previous nightlies.


    For the moment - wget the img file into .update.

  • ... and please read the first page of this thread:


    esp.: => requirements


    and of course get the last script before

    Edited once, last by GDPR-7 ().