LE 10.0.2 RPI4 recorded tv seeking issues

  • Hi,

    I have a little problem with recorded TV videos files since upgrading to LE 10. (on my 2 RPI4 setups)

    Files are played just fine , and usually seeking forward works fine.

    When i seek backward (even 10 seconds) , playback is stopped and seek info bar shows 00:00 (the start of the file) and playback is not usable anymore.

    To eliminate causes , I took the .ts file (using TVH as pvr) out of the TVH box and put it on a "normal" share and local file system , exactly same issue.

    I tried to play the file on kodi 19.4 on windows box , it plays just fine and seeking works perfectly.

    I made a 30 seconds example .ts file , attached is a link to my shared google drive (less than 7mb file).

    https://drive.google.com/file/…gIr78jtNW15HZdTDsiDa/view (just click download on the top bar)

    To reproduce the issue , just play it , seek 10 or 20 seconds forward , then try to seek back.

    Also here is a debug log while the issues happens :

    debug log

    Thanks in advance.

  • Hi,

    I did more testing to find a workaround.

    I changed TVheadend recording profile from "pass" to "matroska".

    This indeed seems to resolve the issue (for new recording only - naturally) , although it introduced old streaming issues with some dvb2 streams. (https://github.com/kodi-pvr/pvr.hts/issues/431)

    So if anyone has similar problem with .ts files seeking , this might help him.

    Still , I think this issue should be looked at , since same file works just fine on kodi/windows (and of course LE 9.X with rpi 4) , so there is an "hidden" problem with ts parser on LE 10.X RPI4.

  • Well , My workaround is not "perfect" after all.

    the matroska container solved the seeking issues but introduced new one, when watching activly recorded recording the seek is really really slow after 20-30 minutes of recording. (also refered here https://tvheadend.org/boards/14/topics/44384)

    I hope some one will look at this issue since its a problem with LE 10.X on RPI4 (as mentioned before).

    Thanks in advance.

  • Hi, If anyone cares/experience same problem, it seems LE version 10.0.3 solves this issue.

  • Hi Hagaygo,

    I have a similar problem, for me the big difference was switching TVH to use matroska, but the seeking issue still occasionally happens, but it is tolerable now

    What version of TVH are you using for your backend? is it containerised?

    I'm on one of the 4.3 nightlies, but i'm thinking if its worth switching back to 4.2 stable

  • Hi,

    When i wrote :

    Hi, If anyone cares/experience same problem, it seems LE version 10.0.3 solves this issue.

    I meant that the .TS recording is now o.k (works like on PC librelec/windows kodi) and seeking backward works.

    I stopped using matroska container since it caused more problems overall.