PineA64+ and HDMI - No interface if TV starts after SBC

  • I've readed many thread about the HDMI issue, where if I start my PineA64 (or any other PC) before the TV turn on, I cannot see the Kodi interface, instead I see the last terminal message in the up left corner and the LibreElec logo in the center.


    I've installed the latest nightly build of LibreELEC for PineA64+, version 20220213.


    I've tried to use edid.bin inside FAT partition and andd commands inside the extlinux.conf file, but the Pine64 does not start, and I got a critical error.


    I've tried to use the command getedid create but I got the error getedid: command not found.


    So, my question is: is there a solution to use LibreElec on PineA64+ even if I power off/power on my TV?


    thanks for your supply.

  • if I start my PineA64 (or any other PC) before the TV turn on, I cannot see the Kodi interface, instead I see the last terminal message in the up left corner and the LibreElec logo in the center.

    This is probably Kodi issue, not LE. At this point it would be interesting to know if Kodi is running (output of top) and information provided by pastekodi


    I've tried to use edid.bin inside FAT partition and andd commands inside the extlinux.conf file, but the Pine64 does not start, and I got a critical error.

    You have to be much more specific than that. What exactly did you write, what edid.bin file did you use, what error did you get?

    I've tried to use the command getedid create but I got the error getedid: command not found.

    what are you trying to do with that command?

  • In this moment, the interface does not appear. When the screen shows only LibreELEC logo and last 2 rows of terminal (appearing during startup), the control seems to work. When I press arrow keys, I can listen to typical sound of interface.


    This is the pastekodi: http://ix.io/3QfL


    The commands used for edid.bin was:


    Code
    mkdir -p /storage/.config/firmware/edid
    cat /sys/class/drm/card0-HDMI-A-1/edid > /storage/.config/firmware/edid/edid.bin

    Then I've copied the edid.bin inside boot partition and then I've append the config in the APPEND row inside extlinux.conf:


    Code
    drm.edid_firmware=edid.bin video=HDMI-A-1:D


    Thanks.

  • Log shows that TV was properly detected (all resolutions are listed) and you even played video. Make another log, this time make sure it's created "during" the issue, e.g. when you only hear sound effects but Kodi is not visible.


    I'm not sure what needs to be done in order for kernel to pick up edid file. FAT partition is mounted to /flash, so proper line would be /flash/edid.bin, but then kernel might request file before /flash is even mounted... Anyway, reading EDID should not be problem even if TV is turned off. Try with only video=HDMI-A-1:D

  • I need to make an update. It seems the issue is resolved.

    The only modify I've applied on extlinux.conf is to remove the WiFi and Bluetooth overlay. I had this row in my extlinux.conf when the problem appeared:

    Code
    FDTOVERLAYS /overlays/sun50i-a64-ir.dtbo /overlays/sun50i-a64-pine64-wifi-bt.dtbo


    When I've removed the WiFi/BT overlay, I've restarted the SBC, and now the Kodi interface remains even I start the TV after the LibreELEC is running. I've powered off my TV, waiting over 10 hours before repower it again. The interface works great.


    Maybe, the issue because the hardware WiFi/BT module was not present, while the overlay was loaded from startup.


    I'll make the inverse-test, reloading the overlay and restart LibreELEC. What I'll verify is the Kodi interface stops to show on TV after one half hour within the TV powered off.

  • Well, if you don't have wifi+bt module connected, then having overlay for it is pointless. But I agree that it shouldn't make any harm, just some overhead. I don't see any issue in wifi+bt overlay, so maybe you can just omit it and be done?

  • For now, it seems removing the overlay for wifi-bt resolve the issue.

    I want to make a test, using overlay once within the hardware module, and again without wifi-bt hardware module.


    I'll inform you about results soon.